Bluetooth no inicia

bluetooth

#1

Buenas a todos.
Recientemente instale en una latitud 13 manjaro 17.
Cuando inicio el administrador de bluetooth recibo un mensaje de error:
Error%20bluetooh

mi lsusb da lo siguiente:

Summary

00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
09:00.0 Ethernet controller: Broadcom Limited NetXtreme BCM5761e Gigabit Ethernet PCIe (rev 10)
0c:00.0 Network controller: Intel Corporation WiFi Link 5100

El lspci da lo siguiente:

Summary

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
09:00.0 Ethernet controller: Broadcom Limited NetXtreme BCM5761e Gigabit Ethernet PCIe (rev 10)
0c:00.0 Network controller: Intel Corporation WiFi Link 5100

systemctl status bluettoth:

Summary

● bluetooth.service - Bluetooth service
Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
Active: inactive (dead)
Condition: start condition failed at Mon 2018-08-13 17:28:19 -03; 23min ago
└─ ConditionPathIsDirectory=/sys/class/bluetooth was not met
Docs: man:bluetoothd(8)

Es mi primer tema en un foro asique si hice algo mal tengan me paciencia.
Espero que puedan ayudarme. Gracias


#2

Hola,
Me parece que este modelo tiene la WiFi y el Bluetooth en el mismo dispositivo, y para iniciar las dos simultáneamente tienes que utilizar la combinación de teclado Fn+F7
Igual tienes que ver si no esta deshabilitado desde el BIOS, o si también tienes Window$, comprobar que esta iniciado …
Desde el terminal:
rfkill unblock bluetooth
probablemente es mejor con
rfkill unblock all
Mira en _/etc/udev/rules.d/50-bluetooth.rules _ lo que tiene …


#3

Gracias por responder.

Efectivamente el bluetooth viene integrado con la wifi, y la tecla de bloqueo (fn+F7) solo bloquea y desbloquea la wifi

rfkill list me devuelve esto:

Summary

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

El bluetooth nunca apareció, cuando hago rfkill unblock all no indica nada.

En /etc/udev/ruled.d/ no hay ningun archivo.
Busque el archivo 50-bluetooth.rules y no lo encuentro tampoco.
En el bios esta habilitado el bluetooth.


#4

Intenta editar etc/default/tlp que tiene esta linea:
USB_BLACKLIST_BTUSB=1

Probablemente tienes que instalar el bluez-firmware desde el extra repo, pero no soy seguro.


#5

Edite el archivo, probe y nada. Instale bluez-firmware. Y nadasigue igual.


#6

Buenos dias

Por si te sirve: lee esto
Nota:

  • Por defecto el demonio de bluetooth solo ofrecerá dispositivos a usuarios que son miembros del grupo lp . Asegúrese de agregar su usuario a este grupo si desea conectarse. Es posible cambiar el grupo que se requiere en el archivo /etc/dbus-1/system.d/bluetooth.conf .
  • Algunos adaptadores de bluetooth están combinados con una tarjeta de Wi-Fi (v.g. Intel Centrino). Estos requieren que la tarjeta Wi-Fi sea activada (normalmente hay alguna combinación de teclas en el teclado) para que el adaptador de bluetooth le sea visible al kernel.
  • Algunos adaptadores de bluetooth (v.g. Broadcom) entran en conflicto con con el adaptador de red, así que es necesario que el dispositivo de blueetooth se conecte antes del inicio del servicio de red.
  • Algunas herramientas como hcitool o hciconfig han sido abandonadas por los desarrolladores originales, y no son incluidas en el paquete bluez-utils

https://wiki.archlinux.org/index.php/Bluetooth_(Español)
y ademas dice tambien esto: mira si esta asi en tu sistema

/etc/bluetooth/main.conf

[Policy]
AutoEnable=true

buen dia a todos


#7

Buenas, perdon la tardanza y gracias por responder.
Ley el articulo de bluetooth de Arch antes de iniciar el tema pero no me ayudo mucho.

A travez del comando usermod agrege mi usuario al grupo “lp”.
Edite el archivo de main.conf, descomentando la linea y editando por true el Autoenable.
Pero de todos nada parece funciona.

Me falta hacer que el servicio de bluetooth inicia antes que el de wifi… No se como hacerlo, pero aun asi no cree que cambie.


#8

buenas merce:

me gustaría ayudarte pero como nunca uso bluetooth, no se me ocurre que te puede estar pasando, aunque ya he leído por ahí que le pasa a bastante gente el mismo problema.

De todas maneras, en el escritorio xfce(no se cual usas) tiene opciones en “sesion e inicio” (arrancar servicios de gnome ayuda?)
Esto lo digo por probar, no me hagas mucho caso.

Y aqui comentan esto otro:(por si tienes win)Entonces dije: Por qué no voy a windows, enciendo el bluetooth, transfiero algo y reinicio en mint??

https://forums.linuxmint.com/viewtopic.php?t=189872#p983931

Enfin si encuentro algo que te ayude ya te lo pondre…miraste en la busqueda del foro?

En mi escritorio xfce no esta instalado el paquete de gnome-bluetooth(supongo que no sera necesario pero no se tu caso)

Un saludo y buen dia

Editado: algun enlace para que revises, parecen interesantes…

http://bernaerts.dyndns.org/linux/74-ubuntu/322-ubuntu-trusty-intel-centrino-6235-slow-freeze

https://forums.linuxmint.com/viewtopic.php?t=223383

Que tengas suerte…chau


#9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.