Адаптеры Bluetooth не найдены.(No Bluetooth adapters found.)

Hello dear forum participants! On the laptop, the data of which is indicated below, 2 operating systems are installed. Win10 and Manjaro. I installed everything myself. The problem is that the bluetooth adapter is not detected in the Manjaro operating system, while in Win 10 everything works fine. I visited various solutions found on the Internet, but nothing happened. I will be glad to receive help from true professionals.

Operating System: Manjaro Linux
KDE Plasma Version: 5.19.4
KDE Frameworks Version: 5.73.0
Qt Version: 5.15.0
Kernel Version: 5.7.14-1-MANJARO
OS Type: 64-bit
Processors: 8 × Intel® Core™ i5-8265U CPU @ 1.60GHz
Memory: 7.7 Gb of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620

Maybe this can help something.

hwinfo --bluetooth

I tried running this command, it didn’t help. By the way, after the first installation of Manjaro, I tried to install other Linux distributions for comparison, it did not help, tried to install another kernel in it did not help either.
Снимок экрана от 2020-08-20 16.33.14

Can you get the info about your bluetooth device from Windows? Then you could search for the model on Arch Wiki or on DuckDuckGo.

I am adding screenshots from Win 10.


Похоже на Realtek Bluetooth 4.2 Adapter или Fujicom FJ-BTSPORT1.

Perhaps I need to install the driver for the bluetooth adapter, but where can I find it for Manjaro. Yes this is Realtek Bluetooth 4.2 Adapter.

It seems to me that this is the same adapter for the wireless network and for bluetooth.

There is no answer yet, but it makes sense to follow that topic.

Usually for such cases you need to add a driver from AUR if one is available.
But the available ones are for RTL8822BU.

Ao, probably you can give up on the idea or contact the Github developers of the RTL8822BU driver and see if they can help you with creating your own RTL8822BE driver.

I also have an HP laptop as in the topic on the Arch linux forum that you found for me. You have heard about problems other than the one we are talking about related to HP laptops?

I heared about similar problem with other devices and the solution was to build the -dkms- driver from AUR if it was available. I read also of some combined WiFi and Bluetooth chipsets on which only WiFi worked on Linux.

The name of the network adapters in the second link is not quite the same with my adapter. I have rtl8822be in the link rtl8822bu. Is it worth trying to install?

Maybe on a test system. And with firmware I cannot guarantee that the wrong driver won’t kill the chip.

If I buy an external bluetooth adapter, will it work? And what advice would you give to work properly with linux?

I don’t know, never tried any of them, but here are two lists:

I will be glad to know a solution to this problem if it appears

Are you open the settings advanced ? It seems than do not open the bluetooth, the network of bluetooth is not find.

I checked everything in the settings, everything that can be included. It’s not about the settings.