Bluetooth Mouse Lag

Hi guys,

I'm enjoying my (slow but getting there) switch to Manjaro.

I've been using my bluetooth mouse (MX Master 2S) for a couple of weeks, recently it has started to be very laggy. I have tried removing and re adding the mouse, as well as using multiple channels on the mouse. I have a dual boot with Win 10 and it works fine there.

I've been searching the forum looking to see if anyone else has had this issue but couldn't find anything, I do apologise if I have missed a post.

Let me know what information I'm missing to help

Thanks in advance

Kind regards

E

Test different kernels.

sudo echo "options iwlwifi bt_coex_active=0" >> /etc/modprobe.d/btlag.conf

and reboot.

reference:

edit: it probably would of been a better idea to have you post your inxi -Fxxxza output before suggesting a fix to a driver im unsure your even using. :man_facepalming:

Thanks so much

I have tried using Kernel 51, 52, 419, and 414 with the same result

My inxi output is below

$ inxi -Fxxxza
Network: Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: 3000 bus ID: 02:00.0 chip ID: 8086:2526
IF: wlp2s0 state: up mac:

1 Like

give the one-liner i posted a try and reboot.

I tried

sudo echo "options iwlwifi bt_coex_active=0"

and restarted to no success, when I tried

sudo echo "options iwlwifi bt_coex_active=0" >> /etc/modprobe.d/btlag.conf

I get permission denied

sudo nano /etc/modprobe.d/btlag.conf

copy/paste this line

options iwlwifi bt_coex_active=0

ctrl+o to save, ctrl+x to exit

As a temporary troubleshooting test, disable the tlp:

sudo sytemctl mask tlp

Reboot.

If there is no improvement then re-enable tlp.

To enable tlp again:

sudo sytemctl unmask tlp
sudo sytemctl enable tlp

Then restart.

1 Like

Unfortunately those two didn't work

Thanks for the help

the arch wiki on bluetooth points here for input lag
https://wiki.archlinux.org/index.php/Mouse_polling_rate

You could also try this when your mouse starts to lag.

Issue this command:

nmcli networking off; sudo rmmod btusb; sleep 2; sudo modprobe btusb; nmcli networking on

I was having lag on some kernels a while back and I used a little more complex script whenever my wireless logitech trackball started lagging. Of course mine's not bluetooth but perhaps something similar would work for you.

I installed and ran evhz and my mouse is sitting at a "smooth" 20hz :joy:

Am I being stupid to ask, how would I fix this?

post

hwinfo --mouse
  [Created at input.249]
  Unique ID: AH6Q.wJ5XlLsA+Z6
  Hardware Class: mouse
  Model: "MX Master 2S Mouse"
  Vendor: 0x046d 
  Device: 0xb019 "MX Master 2S Mouse"
  Compatible to: int 0x0210 0x0048
  Device File: /dev/input/mice (/dev/input/mouse2)
  Device Files: /dev/input/mice, /dev/input/mouse2, /dev/input/event23
  Device Number: char 13:63 (char 13:34)
  Driver Info #0:
    Buttons: 8
    Wheels: 4
    XFree86 Protocol: explorerps/2
    GPM Protocol: exps2
  Config Status: cfg=new, avail=yes, need=no, active=unknown
1 Like

btw, your not the only one
https://bbs.archlinux.org/viewtopic.php?id=248185

Should've done my research before getting this mouse

open a terminal and run these 4 commands

su
echo 0 > /sys/kernel/debug/bluetooth/hci0/conn_latency
echo 6 > /sys/kernel/debug/bluetooth/hci0/conn_min_interval
echo 7 > /sys/kernel/debug/bluetooth/hci0/conn_max_interval

  • reconnect mouse
  • does the latency improve?

EDIT: as an updated solution, here's how to make this persistent through reboots

5 Likes

bash: /sys/kernel/debug/bluetooth/hci0/conn_latency: Permission denied

My bad I accidentally a command. I did the 4 and it didn't seem to change anything, do I need to set a min and max interval?

try reconnecting the mouse now, maybe a reconnect is needed to notice a change.

my reference for those is here:
https://bbs.archlinux.org/viewtopic.php?pid=1857256#p1857256

1 Like

Forum kindly sponsored by Bytemark