Bluetooth mouse disconnects often after Plasma 5.23 upgrade

I don’t have a device to test it on. If anyone else could try it, it would be much appreciated.

I’ve tested the script : the detection is okay when the laptop resume from sleep. I can this the output
Mouse connected, attempt to pair...
but the cursor is still stuck.

It’s not working for me.

This doesn’t work for me either.

I saw a new aur package called rebind devices which seems worth trying. It’s a systemd service to automatically reset devices when resuming from sleep.

If you decide testing it, let us know how it went.

I’ve tried the package but I can’t figure out how I can retrieve the BUS ID for a bluetooth mouse :confused:

I’ve tried also to switch to 5.15 kernel (some users report that it can solve bluetooth connection with Intel AX200 Wifi / bluetooth card : Bluetooth of my Logitech mouse sometimes not-working - #7 by Firestar) but no changes.

I’m using 5.10 kernel normally.

maybe it’s time to update the kernel first before ongoing any troubleshooting. it’s a good choice to update to the newest kernel actually, there are too many changes under the hood.

Ok I’ll stay with kernel 5.15.12 (no RT) for further troubleshooting

Have you tried running inxi -Fxz?