Bluetooth headphones no longer identified as output device

Hello Manjaro forums.
My Bluetooth headphones (Sony WH-1000XM3) don’t seem to be identified as a sound output device once connected.
After a little digging there did seem to be a recent update of PulseAudio recently, and I think it might be due to the PulseAudio 13.99.3 update, as there seem to be some changes made there.
I was wondering if anyone either has a fix, or when if it is a known problem when it should be resolved with an update?

Best regards,

Hello, have you tried searching the forum? Click on the bluetooth tag, you will be presented with some results, amongst them there are some marked with “solution” and there’s also a tutorial as I see.


Thanks for your response. I had not tried the following tutorial: [HowTo] Bluetooth headphones paired, but no sound after a while.

After following the tutorial it does seem to resolve the issue. Still need to check whether the solution is persistent, but I’ll mark this as the solution for now.

As taken from a similar StackOverflow discussion: “… the problem is that the PulseAudio Bluetooth module is loaded before X11 …”.
Is there a way to otherwise ensure that the module in question is loaded after X11?

Thank you for your patience.

1 Like

It did seem to resolve my problem initially, though now the headphones are not shown as an output device. Regardless whether they are re-paired, manually connected via BT or automatically connect once paired. Following the tutorial instructions, the file to modify does have persistent changes between boots.

Other Bluetooth units work fine. This includes both non-audio units (Logitech MX Ergo mouse) and audio units (Antlion Modmic Wireless).

Really uncertain of how I should continue the troubleshooting process.

Update 2:
After removing cookies from ~/.config/pulse the headphones are automatically added to the list of output devices. Seems to solve the problem, but annoying if this need to be done at regular intervals :confused:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.