Bluetooth headphones connect, doesn't appear in sound settings

gnome

#1

I did some solutions that appear here but they didn’t help. I just installed Manjaro GNOME in two laptops, it is working great. Now I’m using the Xiaomi Notebook Air 13 (2016).
When I used Elementary OS or Ubuntu, bluetooth worked great, I paired my headphones and I was able to choose them in sound settings, now they pair, they are detected as audio devices but in sound settings there is only the built in speakers to choose from.
I tried with my TicPods free and with my Google Home, in both laptops, same issue is happening, nothing in sound settings.
Also, I “undid” everything else that I tried searching online or here.


#2

I noticed that Gnome on Arch and Manjaro has a thing that the bluetooth (and some related stuff/devices/etc) came up after a restart, once the pairing was done.
I usually avoid anything that is “wireless” so i don’t know how bluetooth headphones would be shown in audio settings, but i have the feeling that should be a “generic” bluetooth audio device …


#4

It didn’t work. I really wanna use bluetooth and I don’t get why when searching I don’t find my problem.


#5

Look at this post and my reply.


That is a way to describe the problem. Post some errors you get. It didn’t work simply doesn’t help anyone to identify the problem.


#6

But I don’t know what to show. I paird them, it makes the sound in the speaker (paired sound) and then it doesn’t appear in bluetooth settings. In Windows, in Ubuntu, in Elementary it just worked, I paired my bluetooth headset and it appeared in sound settings. I don’t have any error messages, I don’t have any notification, what should I check to get errors?


#7

I have the same problem. I paired my headset in september and everything worked fine. After the latest lagre update (18), the sound settings for the headphones are gone, even tho pairing and connection seems to be ok.