Bluetooth does not work with kernel 5.15.12-1 on my hardware

Hi. My apologies if this is not the thread to post the following:
Bluetooth does not work with kernel 5.15.2-2, it worked with 5.14.18-1
In 5.15 I can’t activate it. In 5.14 it autostarts normally.

I found a solution but it is partial because I have to repeat it every time for it to work: Pulling out the power cable (while the machine was running) fixed the issue for me (when turning on the PC again). (Source: Bluetooth unavailable after updates - Reading Intel version information failed (-110) .)

bluetoothctl show
No default controller available
systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Sat 2022-01-15 22:06:43 CET; 40min left
       Docs: man:bluetoothd(8)
   Main PID: 728 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 19040)
     Memory: 2.5M
        CPU: 25ms
     CGroup: /system.slice/bluetooth.service
             └─728 /usr/lib/bluetooth/bluetoothd

ene 15 22:06:42 PEPE-NUC systemd[1]: Starting Bluetooth service...
ene 15 22:06:43 PEPE-NUC bluetoothd[728]: Bluetooth daemon 5.62
ene 15 22:06:43 PEPE-NUC bluetoothd[728]: Starting SDP server
ene 15 22:06:43 PEPE-NUC systemd[1]: Started Bluetooth service.
ene 15 22:06:43 PEPE-NUC bluetoothd[728]: Bluetooth management interface 1.21 initialized

Agent registered

The result of rfkill is all unblocked.
Neither bluez-utils-compat nor bluez-utils fixes the problem.

Thanks in advance.

Sorry, mistake… current kernel running 5.15.12-1
About the power cable… a copy/paste from the source post.
Y no… tampoco es 28 de diciembre.

did you found any solution?


Nope :frowning:

i’m having the same issue. have you found a solution now?

Kernel Linux 5.16 fixed it.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.