Bluetooth crashes since updated to kernel 4.13.2

bluetooth
kde
kernel

#22

I get this from journalctl when trackpad dies:

Oct 05 22:39:27 ZaManjCin kernel: Bluetooth: hci0 link tx timeout
Oct 05 22:39:27 ZaManjCin kernel: Bluetooth: hci0 killing stalled connection d0:a6:37:f1:ac:8a
Oct 05 22:39:27 ZaManjCin bluetoothd[776]: GLib: Source ID 807 was not found when attempting to remove it

And occasionally this:

Oct 05 22:40:34 ZaManjCin bluetoothd[776]: D0:A6:37:F1:AC:8A: error updating services: Connection refused (111)

and this when it comes back on:

Oct 05 22:39:50 ZaManjCin bluetoothd[776]: No cache for D0:A6:37:F1:AC:8A
Oct 05 22:39:50 ZaManjCin kernel: magicmouse 0005:05AC:030E.000C: unknown main item tag 0x0
Oct 05 22:39:50 ZaManjCin kernel: input: Apple Wireless Trackpad as /devices/pci0000:00/0000:00:14.0/usb3/3-9/3-9:1.0/bluetooth/hci0/hci0:6/0005:05AC:030E.000C/input/input16
Oct 05 22:39:50 ZaManjCin kernel: magicmouse 0005:05AC:030E.000C: input,hidraw4: BLUETOOTH HID v1.60 Mouse [Apple Wireless Trackpad] on 00:0e:a1:32:f7:5b

#23

@rcrath 1) Have you tried to use kernels 4.13 and 4.14? 2) Have you considered filing a kernel bug (drivers section)?

https://bugzilla.kernel.org/


[Stable Update] 2017-09-30 - Timeshift, Kernels, Nvidia, JADE, Haskell, JDK9, Snap Support
#24

lol, I had to file a kernel bug last time bluetooth went spotty…scary place. :fearful: will try newer kernels.


#25

Newer kernel makes no difference. Also tried uninstalling
1.9.0-1
Synaptics driver for notebook touchpads

to let the newer libinput drivers take precedence. this still works, but changed the settings to something much jumpier, so now it is skittish and failing regularly instead of just the latter. I’ll be out of town for a week starting tomorrow and won’t have time to do the due diligence to file a kernel bug. might try downgrading kernel to see if that makes a difference as I have three old ones in cache.


#26

Wow, crazy weeks, no time to check back here. My inxi is here.

So, yes this is Intel 8260 wireless/bluetooth too.


#27

So, I have installed kernel 4.13.4. Bluetooth functions as long as I have wireless disabled. When I enable wireless, bluetooth immediately dies. Or rather, becomes unresponsive. The BT icon and manager still show my mouse is connected, however, it doesn’t react to anything anymore.

Then I disabled BT coexistence as per @jsbach’s instructions and lo’, BT and wireless suddenly function together again.


#28

downgrading kernel to 4.9.44, the last working setup, hung on boot :slightly_frowning_face: as mentioned, I don’t have any wireless on this computer. Wonder if there are wireless drivers installed or something. ANyone know how to check for this? nothing shows under network connections for wireless obviously.


#29

@rcrath I suggest:

  1. Open a Manjaro ticket: Manjaro gets a modern Ticket System .
  2. If that fails, then file a kernel bug (drivers section): https://bugzilla.kernel.org/ .

#30

Is there any update here? My bluetooth is suddenly dying every 1-3 minutes this morning. I constantly have to restart it via the terminal. I’m still on kernel 4.13.

I’m on Intel Wireless 8265


#31

Have you tried to disable bluetooth coexistence? To do so, create the file /etc/modprobe.d/iwlwifi.conf with

options iwlwifi bt_coex_active=0

and reboot.


#32

That seems to have fixed it!


#33

I am noticing this too on 4.13.8-1


#34

@Clickster and @asynec Is your wireless chipset Intel 8260 as well? If so, you may want to share your experiences in the bug report I filed:

https://bugzilla.kernel.org/show_bug.cgi?id=197061


#35

8265/8275


#36

You may consider to file a separate bug (Drivers section -> network-wireless):

https://bugzilla.kernel.org/enter_bug.cgi

If the problems you are experiencing are similar to the ones I am experiencing, you may want to reference the bug report I filed.


#37

When I get home from work I’ll jump on it.


#38

Yep, I’m also on the 8265


#39

Had the same issue on kernels newer than 4.12. On 4.9 bluetooth was working flawlessly.
jsbach’s fix (options iwlwifi bt_coex_active=0) seems to have done the trick, running 4.14 now with bluetooth and wifi: all working fine. Thanks!
Is there any downside to be expected from this?

[leonard@cassiopeia ~]$ inxi -Fxzc0
System: Host: cassiopeia Kernel: 4.14.0-1-MANJARO x86_64 bits: 64 gcc: 7.2.0
Desktop: KDE Plasma 5.11.2 (Qt 5.9.2) Distro: Manjaro Linux
Machine: Device: laptop System: LENOVO product: 20H1CTO1WW v: ThinkPad E470 serial: N/A
Mobo: LENOVO model: 20H1CTO1WW v: SDK0J40709 WIN serial: N/A
UEFI: LENOVO v: R0DET57W (1.57 ) date: 02/10/2017
Battery BAT0: charge: 42.2 Wh 96.0% condition: 44.0/45.0 Wh (98%) model: LGC 01AV412 status: Discharging
CPU: Dual core Intel Core i7-7500U (-HT-MCP-) arch: Kaby Lake rev.9 cache: 4096 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 11620
clock speeds: max: 3500 MHz 1: 2900 MHz 2: 2900 MHz 3: 2900 MHz 4: 2900 MHz
Graphics: Card-1: Intel HD Graphics 620 bus-ID: 00:02.0
Card-2: NVIDIA GM108M [GeForce 940MX] bus-ID: 01:00.0
Display Server: x11 (X.Org 1.19.5 ) driver: intel Resolution: 1920x1080@60.01hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2)
version: 4.5 Mesa 17.2.3 Direct Render: Yes
Audio: Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
Sound: Advanced Linux Sound Architecture v: k4.14.0-1-MANJARO
Network: Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
driver: r8168 v: 8.044.02-NAPI port: c000 bus-ID: 04:00.0
IF: enp4s0 state: down mac:
Card-2: Intel Wireless 8265 / 8275 driver: iwlwifi bus-ID: 05:00.0
IF: wlp5s0 state: up mac:
Drives: HDD Total Size: 256.1GB (59.8% used)
ID-1: /dev/sda model: SanDisk_SD8TB8U2 size: 256.1GB
Partition: ID-1: / size: 20G used: 18G (95%) fs: ext4 dev: /dev/sda2
ID-2: /home size: 207G used: 119G (61%) fs: ext4 dev: /dev/sda4
ID-3: swap-1 size: 8.39GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
Sensors: System Temperatures: cpu: 40.5C mobo: N/A
Fan Speeds (in rpm): cpu: 0
Info: Processes: 176 Uptime: 2 min Memory: 1326.4/15954.3MB Init: systemd Gcc sys: 7.2.0
Client: Shell (bash 4.4.121) inxi: 2.3.40

Cheers,
Leo


#40

I haven’t experienced any problems. If anything, my bluetooth mouse feels a bit snappier and responsive, but that could also be my imagination :slight_smile:

On the other hand, I still need to occasionally rfkill unblock bluetooth, especially after suspending, to get the bluetooth connection to work at all. So all in all, with this fix things seem to be back to how they were for me.


#41

linux-firmware was update today to version 20171009.bf04291-1 . You may try to enable bluetooth coexistence again to check whether the new linux-firmware fixes de crashes. (I haven’t got the time to do that yet.) If you disabled bluetooth coexistence as recommended above, just remove /etc/modprobe.d/iwlwifi.conf and reboot. If you do so, please report back.