Bluetooth crashes since updated to kernel 4.13.2

bluetooth
kde
kernel

#6

Can you post the steps that you took to downgrade linux-firmware? I want to make sure that I am doing it correctly.


#7
  1. sudo pacman -S downgrade

  2. sudo downgrade linux-firmware . Select

  1. linux-firmware-20170622.7d2c913-1-any.pkg.tar.xz (local)
  1. Reboot.

#8

@asynec If you are having a similar problem, could you please share your experience in the comments of the following bug report:

https://bugzilla.kernel.org/show_bug.cgi?id=197039

? Thank you.


#9

Sure thing, done.

One question… I noticed that this process added linux-firmware to the ignore list, I assume ignoring future updates. What steps would I take to download an update at a future date?


#10

Uh oh. It looks like after downgrading linux-firmware, my bluetooth is totally dead. After rebooting, I cannot get it to connect at all.


#11

@asynec I did not add linux-firmware to the ignore list.

That’s strange. Was the previous firmware successfully installed (pacman -Qi linux-firmware)?

I am now running the latest firmware again for debugging purposes. I disabled bluetooth coexistence and so far so good. To do so, create the file /etc/modprobe.d/iwlwifi.conf with

options iwlwifi bt_coex_active=0

and reboot.


Bluetooth does not stay paired after lock screen or boot
Bluetooth issues with ThinkPad x240
#12

Hmmm, ran

sudo modprobe -r btusb
sudo modprobe btusb

Rebooted.

Bluetooth is working now. Will reort back if I’m experiencing any crashes. I still need direction on how to re-upgrade linux-firmware at a later date now that it is in my ignore list though.


Bluetooth no longer turns on
#13

@philm Phil: Can you or another Manjaro dev give me a hand with this problem? I am experiencing wifi/bluetooth crashes. I filed a bug report: https://bugzilla.kernel.org/show_bug.cgi?id=197039 . I was then asked to perform some debugging. I have already downloaded the customized firmware. The debugging instructions are available at

https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/debugging#firmware_debugging

My first question: Is the Manjaro kernel compiled with CONFIG_ALLOW_DEV_COREDUMP set to Y? If not, I understand that I will need to compile the kernel using that setting. Is that correct?

Next, /sys/kernel/debug/iwlwifi does not exist on my system and I am unable to create that folder (even as root). I also don’t have /sys/devices/virtual/devcoredump .

Do you think a Manjaro dev would be able to guide me through this debugging process? How do you suggest I proceed with this? Thank you.


#14

Yes, this option is enabled. But for debug iwlwifi, the option CONFIG_IWLWIFI_DEBUG also needs to be enabled. And this is not the case. So it appears you need to compile your own kernel with more debug options set.

The sysfs is a very special kernel file system. You can’t create folders or files.


#15

@xabbu Thank you! I compiled the kernel and booted into it. The firmware debugging procedure asks us to do the following:

cat /sys/devices/virtual/devcoredump/devcdY/data > iwl.dump
echo 1 > /sys/devices/virtual/devcoredump/devcdY/data
(Y is incremented each time)

However, I do not see a devcoredump folder:

What I have:

[root@darwin5 virtual]# pwd
/sys/devices/virtual
[root@darwin5 virtual]# ls
bdi dmi graphics hwmon input mem misc msr net powercap sound thermal tty vc vtconsole workqueue
[root@darwin5 virtual]#

Would you know how I should proceed?


#16

Did you also enable the debugfs (CONFIG_IWLWIFI_DEBUGFS)? And can you start fw_dbg_collect? I think the devcoredump device is only created when you start fw_dbg_collect with echo 1 or the modified firmware starts fw_dbg_collect by its self and there is a firmware coredump. But if the firmware can start this by its self depends on how the firmware was modified.

Also I never did firmware debugging, so there is maybe something I didn’t know.


#17

There seems to be something wrong with the latest firmware. I was provided with a custom firmware with debug enabled, performed tests and filed the following bug report:

https://bugzilla.kernel.org/show_bug.cgi?id=197061


#18

I am having the same issue…random bluetooth disconnects (apple magic trackpad) after most recent stable update. I have tried with the same result the two most recent lts kernels, 4.9.52-1 and 4.4.89-1 and it happens on both Some mention it is a conflict with wifi, but the machine I am having trouble with has no wifi at all, being a desktop plugged in to the wall. Also tried downgrading linux-firmware 20170907.a61ac5c-1 to 20170622.7d2c913-1 but still having the same problem. can provide various outputs if desired. LMK if that would help.


[Stable Update] 2017-09-30 - Timeshift, Kernels, Nvidia, JADE, Haskell, JDK9, Snap Support
#19

Intel 8260 as well?


#20

Intel® Core™ i7-4770 CPU @ 3.40GHz

rich[~]$  inxi -Fxzc0
System:    Host: ZaManjCin Kernel: 4.9.52-1-MANJARO x86_64 bits: 64 gcc: 7.2.0
           Desktop: Cinnamon 3.4.6 (Gtk 3.22.21) Distro: Manjaro Linux
Machine:   Device: desktop System: MSI product: MS-7823 v: 1.0 serial: N/A
           Mobo: MSI model: Z87M-G43 (MS-7823) v: 1.0 serial: N/A
           BIOS: American Megatrends v: V2.2 date: 06/07/2013
CPU:       Quad core Intel Core i7-4770 (-HT-MCP-)
           arch: Haswell rev.3 cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27211
           clock speeds: max: 3900 MHz 1: 3900 MHz 2: 3899 MHz 3: 3895 MHz
           4: 3887 MHz 5: 3871 MHz 6: 3883 MHz 7: 3886 MHz 8: 3870 MHz
Graphics:  Card: NVIDIA GF108 [GeForce GT 620] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.3 ) driver: nvidia
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: GeForce GT 620/PCIe/SSE2
           version: 4.5.0 NVIDIA 384.90 Direct Render: Yes
Audio:     Card-1 NVIDIA GF108 High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Bose driver: USB Audio usb-ID: 003-005
           Sound: Advanced Linux Sound Architecture v: k4.9.52-1-MANJARO
Network:   Card: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8168 v: 8.044.02-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 14250.8GB (21.1% used)
           ID-1: /dev/sdb model: WDC_WD1002FAEX size: 1000.2GB
           ID-2: /dev/sda model: Crucial_CT120M50 size: 120.0GB
           ID-3: /dev/sdd model: M4 size: 128.0GB
           ID-4: /dev/sdc model: ST1000LM024_HN size: 1000.2GB
           ID-5: USB /dev/sde model: Expansion_Desk size: 8001.6GB
           ID-6: USB /dev/sdf model: My_Book_1230 size: 4000.8GB
Partition: ID-1: / size: 73G used: 60G (87%) fs: ext4 dev: /dev/sda2
           ID-2: /boot size: 494M used: 287M (62%) fs: ext2 dev: /dev/sda1
           ID-3: /home size: 917G used: 461G (53%) fs: ext4 dev: /dev/sdc1
           ID-4: swap-1 size: 17.82GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:78C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 346 Uptime: 5:06 Memory: 8599.8/15993.1MB
           Init: systemd Gcc sys: 7.2.0 Client: Shell (bash 4.4.121) inxi: 2.3.40

#21

Have the following in journalctl:

Oct 04 20:02:56 ZaManjCin kernel: magicmouse 0005:05AC:030E.0022: input,hidraw4: BLUETOOTH HID v1.60 Mouse [Apple Wireless Trackpad] on 00:0e:a1:32:f7:5b
Oct 04 20:02:56 ZaManjCin kernel: input: Apple Wireless Trackpad as /devices/pci0000:00/0000:00:14.0/usb3/3-9/3-9:1.0/bluetooth/hci0/hci0:6/0005:05AC:030E.0022/input/i
Oct 04 20:02:56 ZaManjCin kernel: magicmouse 0005:05AC:030E.0022: unknown main item tag 0x0
Oct 04 20:02:56 ZaManjCin bluetoothd[827]: No cache for D0:A6:37:F1:AC:8A
Oct 04 20:02:50 ZaManjCin dhcpcd[845]: enp3s0: deleted default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:02:50 ZaManjCin dhcpcd[845]: enp3s0: adding default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:02:48 ZaManjCin kernel: Bluetooth: hci0 command 0x0405 tx timeout
Oct 04 20:02:46 ZaManjCin bluetoothd[827]: Can't get HIDP connection info
...
Oct 04 20:02:15 ZaManjCin bluetoothd[827]: GLib: Source ID 3313 was not found when attempting to remove it
Oct 04 20:02:15 ZaManjCin dhcpcd[845]: enp3s0: deleted default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:02:15 ZaManjCin dhcpcd[845]: enp3s0: adding default route via fe80::c2c1:c0ff:fed8:f821
Oct 04 20:02:15 ZaManjCin kernel: Bluetooth: hci0 killing stalled connection d0:a6:37:f1:ac:8a
Oct 04 20:02:15 ZaManjCin kernel: Bluetooth: hci0 link tx timeout

#22

I get this from journalctl when trackpad dies:

Oct 05 22:39:27 ZaManjCin kernel: Bluetooth: hci0 link tx timeout
Oct 05 22:39:27 ZaManjCin kernel: Bluetooth: hci0 killing stalled connection d0:a6:37:f1:ac:8a
Oct 05 22:39:27 ZaManjCin bluetoothd[776]: GLib: Source ID 807 was not found when attempting to remove it

And occasionally this:

Oct 05 22:40:34 ZaManjCin bluetoothd[776]: D0:A6:37:F1:AC:8A: error updating services: Connection refused (111)

and this when it comes back on:

Oct 05 22:39:50 ZaManjCin bluetoothd[776]: No cache for D0:A6:37:F1:AC:8A
Oct 05 22:39:50 ZaManjCin kernel: magicmouse 0005:05AC:030E.000C: unknown main item tag 0x0
Oct 05 22:39:50 ZaManjCin kernel: input: Apple Wireless Trackpad as /devices/pci0000:00/0000:00:14.0/usb3/3-9/3-9:1.0/bluetooth/hci0/hci0:6/0005:05AC:030E.000C/input/input16
Oct 05 22:39:50 ZaManjCin kernel: magicmouse 0005:05AC:030E.000C: input,hidraw4: BLUETOOTH HID v1.60 Mouse [Apple Wireless Trackpad] on 00:0e:a1:32:f7:5b

#23

@rcrath 1) Have you tried to use kernels 4.13 and 4.14? 2) Have you considered filing a kernel bug (drivers section)?

https://bugzilla.kernel.org/


[Stable Update] 2017-09-30 - Timeshift, Kernels, Nvidia, JADE, Haskell, JDK9, Snap Support
#24

lol, I had to file a kernel bug last time bluetooth went spotty…scary place. :fearful: will try newer kernels.


#25

Newer kernel makes no difference. Also tried uninstalling
1.9.0-1
Synaptics driver for notebook touchpads

to let the newer libinput drivers take precedence. this still works, but changed the settings to something much jumpier, so now it is skittish and failing regularly instead of just the latter. I’ll be out of town for a week starting tomorrow and won’t have time to do the due diligence to file a kernel bug. might try downgrading kernel to see if that makes a difference as I have three old ones in cache.