Bluetooth after Update broken / maybe Thinkpad-Bug?

After the very latest update for Manjaro to Gnome 41.3 (yesterday?) I hardly can use my bluetooth anymore.

I am using Kernel 5.15.16-1-MANJARO x86_64 as before, and trying to use the slider in gnome-settings.
It constantly switches back to “off”, same in panel dropdown. The state seemes to switch after pressing “on/off” but in settings it remains “off”.

After a random amount of trying my T480 gets a connection, but sometimes this not happen at all.

Since I use BT keyboard, mouse and speakers it’s a very important feature.

Anyone can help?

1 Like
1 Like

Ty, I tried it, and after restart it’s the same as before. :frowning:

Fun fact: With X it’s seems to work now, but not with wayland. :exploding_head:
edit: okay, nevermind. same in X.

After several reboots and re-logins it keeps misbehaving.
Terminal kill/restart BT will help for one session. Then it needs to be done again. With X and wayland.

Kernel: 5.15.16-1-MANJARO x86_64
bits: 64
Desktop: GNOME 41.3
Thinkpad T480

Same on my KDE after the last stable update to Manjaro 21.2.2, kernel 5.10.93-1.
No bluetooth adapters are found. The bluetooth service is not loaded.

$ sudo systemctl restart bluetooth
$ sudo systemctl status bluetooth
○ bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: inactive (dead)
       Docs: man:bluetoothd(8)

sty 27 10:08:31 kjr systemd[1]: Bluetooth service was skipped because of a failed condition check (ConditionPathIsDirectory=/sys/class/bluetooth).
sty 27 10:15:29 kjr systemd[1]: Bluetooth service was skipped because of a failed condition check (ConditionPathIsDirectory=/sys/class/bluetooth).


The only error in dmesg -Hw is:

[  +0,000803] ucsi_acpi: probe of USBC000:00 failed with error -12

I see something like that in
journalctl -b -g blue:

sty 27 10:08:35 kjr pulseaudio[1364]: configured_default_sink: (unset) -> bluez_sink.00_1B_66_BE_9A_FD.a2dp_sink
sty 27 10:08:57 kjr dbus-daemon[861]: [system] Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)
sty 27 10:08:57 kjr kded5[1279]: kf.bluezqt: PendingCall Error: "Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)"
1 Like

Confirming behavior on T460p (Skylake)

1 Like

Are you also on a Thinkpad? Maybe it’s the HW BT unit.

Can not confirm on X270 (Kabylake)

need to revoke that call, it also happens on that system :sob:

I’m having this same issue with 5.15. I tried 5.16 and 5.10 and it remains.

I run Manjaro on my desktop computer, but use a combined wifi/bluetooth adapter: TP-Link WiFi 6 AX3000 PCIe WiFi Card (Archer TX3000E) which I suppose is similar to the hardware used in laptops.

Other possibly relevant hardware is MSI MAG B550M Mortar Gaming Motherboard and a Ryzen 5 3600.

Hi, Not sure if its the exact same problem, but the cause might be. I have been having trouble since bluez was updated to 5.63-1 After system sleep i have no devices listed at all. I would have to restart the service to get them to show up again.

You might try downgrading bluez if yours is currently 5.63-1 It has worked for me for now (until there is a fix)

My problems occurred on Dell Latitude E7490, so I doubt it’s related to Thinkpad or Dell HW. I’m pretty sure it’s because of the most recent bluez update to 5.63-1

This week’s update fixed the issue on both of my systems. It brought 5.15.19-1-MANJARO and 5.16.5-1-MANJARO, while bluez is still on 5.63-1 :person_shrugging:

Sorry, but I need to revoke my statement again. The bluetooth connection does work again, but only once after login. Once the headphones were turned off and then back on, I see the same effect as OP stated above.

The other thread has a link to a similar KDE issue that is being worked on, but does this relate to our issue here? It proposes to restart the shell as a workaround, but in my case this is not possible because I run Wayland.

So I need to log out and back in everytime I had put the headphones to the side, because they are too damn smart and turn off automatically then :roll_eyes:

Same problem but no need to reboot for me . Did you tried this command line?

sudo systemctl restart bluetooth

Restarting the service does not work for me, but your comment made me come to the idea to check sudo journalctl -u bluetooth, and I found lots of lines saying

src/adv_monitor.c:btd_adv_monitor_offload_supported() Manager is NULL, get offload support failed

so I searched for that and found this issue, which sounds very similar to my issue and is supposedly fixed already. Looks like we only need to wait for another release of bluez.

I have similar problem on my ThinkPad L14 Gen1 AMD, after restart Bluetooth works properly, but after sleep I need to restart bluetooth service in order to use Bluetooth:

sudo systemctl restart bluetooth