Bluetooth adapter cannot be turned on (Realtek RTL8723BE)

bluetooth
realtek
kde

#22

@abc please give me the link to that bug report


#23

from neognomic see above
https://bugs.manjaro.org/


#24

I had the same problem but my device is a Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter.

I installed the last stable Kernel (version 4.9.2-1) and it fixed the problem. Bluetooth is working fine now.


#25

this is no good attention from the manjaro developpers part… I would be very happy if they tell us what is happened, nothing more than this…


#26

see here for bag report : https://bugs.manjaro.org


#27

https://bugs.manjaro.org/index.php?do=details&task_id=80

There may be another but the above Manjaro bug report links to this forum thread, so I assume it is the one mentioned.

Everybody experiencing this issue with Realtek chip should add to that bug report.
Remember, it is the squeaky wheel that gets the grease, ;).


#28

same problem here. bluetooth don’t work with manjaro and archlinux. the developer say that posiibly is a kernel config


#29

Solved the problem. :tada: :tada: :tada: :confetti_ball: :confetti_ball: :confetti_ball:

The issue is with runtime power management

So I just nuked the power management by uninstalling the tlp package using command

sudo pacman --remove tlp
rebooted

And bluetooth works!!

Now someone please find a more peaceful solution where bluetooth and tlp can coexist.


RTL8723BE Bluetooth not working
#30

Alternately, one can block the device in tlp. More on that maybe tommorow.(or you can read the tlp documentation)

Read my posts on the related github issue for more details https://github.com/lwfinger/rtlwifi_new/issues/214#issuecomment-293279884 . We’ll need more people to test this workaround so that the actual bug could be tracked and solved.

I’ll keep updating on what I find either here or on github. I have found some issues, I’ll try to track them down and find solution if possible.


#31

Thank @Aditya , it fixed the issue for me as well.
I added a comment with a link to your contribution on the github thread to https://bugs.manjaro.org/index.php?do=details&task_id=80
I have tried blocking the device in tlp but didn’t succeed, that’s why I finally went the “uninstall” way.


#32

Glad I could help someone :slight_smile:

To block the device in tlp, do the following

  • Get the id of the bluetooth device from lsusb command

[aditya@aditya-pc ~]$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 0bda:57d6 Realtek Semiconductor Corp.
Bus 001 Device 004: ID 0bda:b006 Realtek Semiconductor Corp.
Bus 001 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 006: ID 05c6:f003 Qualcomm, Inc.
Bus 001 Device 002: ID 0461:4e54 Primax Electronics, Ltd
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Here, 1d6b:0003, 0bda:57d6 etc are ids.

  • Let’s say, 0bda:57d6 is the offending device. Now open the tlp configuration file at /etc/default/tlp. I prefer nano editor, so use command sudo nano /etc/default/tlp

  • Find the line that reads

#USB_BLACKLIST=“1111:2222 3333:4444”

change it to

USB_BLACKLIST=“0bda:57d6”

change device id to the offending device id. Remove the#

  • Reboot

RTL8723BE Bluetooth not working
RTL8723BE Bluetooth not working
Wifi (rtl8723be) not working with kernels later than 4.9 release
[Solved] Getting a DS4 (PS4 controller) to work with bluetooth and games
Bluetooth lenovo g50-7'
[Solved] Cannot connnect to or discover wireless networks
#33

@QJas For me, bluetooth only works upto a feet or two from the laptop. Is it the same case for you?


#34

Well done Aditya.
blocking the device worked for me.(distance approx 20ft)
thankyou


#35

Hi,

no I don’t have any range issue. I opened a tab and navigated to a website from another room than the one where the PC sits just to check the range :slight_smile: I was about 9 to 10 feet from the PC.


#36

Is it a desktop or a laptop?


#37

GREAT!!! :clap:
Blocking device in tlp worked for me. I really need my bluetooth and before this i had to use a usb dongle…
Thanks alot


#38

FANTASTIC !
worked here as well =D
:confetti_ball: thanks a lot :confetti_ball:


Bluetooth Resource Not Ready
#39

I had the same problem on my laptop and blacklisting the device in /etc/default/tlp as outlined above worked.

Thanks, @Aditya.


#40

better to blacklist the usb or pci and not to remove tlp, checked in the hp of my sister


#41

i’ve check lsusb to looking for my laptop’s bluetooth devID.
but i have no idea which id is my bluetooth devID.
and i’ve try some of them, but no sense.

and i use hcitool command to find:

$ hcitool dev
Devices:
	hci0	D4:6A:6A:65:2F:94

and i modified file /etc/default/tlp

USB_BLACKLIST="6a65:2f94"

it doesn’t work.

i also used tlp stat command to check, and i found this paragraph:

+++ USB
Autosuspend         = enabled
Device whitelist    = (not configured)
Device blacklist    = (not configured)
Bluetooth blacklist = disabled
Phone blacklist     = disabled
WWAN blacklist      = enabled

so i thinked if i change it to Bluetooth blacklist = Enable, it may work.

so i checked out the file /etc/default/tlp, and i changed this row (change 0 to 1):

USB_BLACKLIST_BTUSB=1

and then i restarted my laptop, it worked.

thanks Aditya! And thanks for the info above.

hope i can help someone.
sorry for my poor English.


Wifi (rtl8723be) not working with kernels later than 4.9 release
Bluetooth on Asus z370 Gaming E