Bluetooth 5.0 dongle

Hello everyone!

I’m having some issues trying to set up a Bluetooth 5.0 dongle.
I’ve already been through many forum questions about this topic, but none of the answers provided worked for me.

First of all, the kernel version I’m running is 5.8.18

Plugging the dongle in a USB port and running the command sudo dmesg
prompts the following error:

[    4.931026] bluetooth hci0: Direct firmware load for rtl_bt/rtl8761b_fw.bin failed with error -2
[    4.931028] Bluetooth: hci0: RTL: firmware file rtl_bt/rtl8761b_fw.bin not found

So, these commands simply won’t work for me:
sudo modprobe btusb
sudo systemctl start bluetooth
sudo systemctl enable bluetooth

Running these:
sudo bluetoothctl
list
returns an empty list.

I’ve also tried:

sudo rfkill unblock bluetooth
rfkill list:
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

But of course those commands didn’t work as well.

The main problem should be the firmware file not found, but I couldn’t figure out how to fix it.

Have you tried installing rtl8761b-fw from AUR?

You should switch to a non-EOL kernel soon.

It worked! Thanks a lot!
I had no idea I could find it on AUR, I’ve recently switched from Ubuntu so I’m still getting used to Arch :sweat_smile:

Oh. Thank you, I didn’t know that either :grinning:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.