Blinking cursor when installing from live USB

Hi everyone. I’ve tried alot of the suggestions shown around this forum unfortunately to no avail. I’m trying to install Manjaro GNOME 21.0.5 with an usb I created using Rufus. All the settings set by the program were on default. I get in to the boot options screen, but whenever I try to use either properitary drivers or open source, neither work, I get stuck at a blinking cursor screen and I can’t do anything but to reset the computer. My specs are:

Z270i Strix
i7 7700k
AMD Radeon RX 6700 XT.

I have tried different USB ports, unplugging everything but the keyboard and the usb but to no avail. Maybe it’s also worth mentioning that if I use the XFCE version, I get stuck on ‘Reached target graphical interface’ instead, compared to GNOME version. I’m at a wits end, where I have googled and tried possibly all the top options shown when searching for these issues. Is there a way I’m able to dump logs to pinpoint the problem more precise from the boot screen? Thanks in advance!

You could try using Ventoy.
It’s also available for Windows.
You use the program to prepare the USB.
Then you simply copy the ISO (or more than one) to it.

Or you try etcher: balenaEtcher - Flash OS images to SD cards & USB drives

Hi again, I tried both Ventoy and balenaEtcher, unfortunately they both resulted in the same issue. The installer gets to ‘started GNOME Display Manager’, before the screen clears out and the blinking cursor appears. I cant seem to paste the image in here as it does not allow me to add link or image.

If you have time can you try if booting with the KDE ISO works?

I tried the KDE version and it also stops at ”Reached target Graphical Interface”. Pretty much the same as the xfce version.

What kernel is your ISO running? You probably need a recent kernel for this graphic card (5.12).

//EDIT: If you have access to a working Manjaro (probably can do it from another OS but the guide will be for Manjaro specific commands), and if you want to try, follow this guide to build a custom Manjaro ISO, and tell it you want to create a full ISO for Gnome on Stable branch with kernel 5.12:

for Gnome

buildiso -f -p gnome -k linux512 -b stable


buildiso -f -p xfce -k linux512 -b stable

To sum it up, install the Manjaro Tools and GIT, download the ISO profiles, and build the ISO. You don’t have to customize more the ISO you can skip that.

I didn’t find an official ISO with kernel 5.12 so it is your best bet if the issue is with the kernel (what I think it is).

I apologize for late answer as I had to use virtualbox to create the iso, but despite the time, it fixed my issue I’ve been trying to fix for atleast a week. Thank you so so much for your help!

“late answer”


you took 3 hours no stress dude :smiley:

Glad it is fixed. Now remember kernel 5.12 is not a LTS (Long Term Support) kernel so make sure you keep informed on when kernel become EOL (End Of Life) in the update announcements, and change kernel before it is removed from Manjaro.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.