Blender HIP hipInit: Invalid device

Blender recently has my 6700xt not being detected as a usable gpu for hip rendering. It worked in the past and there has been no blender updates since it was working. Ive searched all I can for a solution and have come up with nothing. The gpu works for everything else in the system and I have hip-runtime-amd installed which fixed the issue in the past.
image

I would appreciate any help you can give.

installing hip-runtime-amd-blender worked for me.