BLE working but not advertising


I have an issue with advertising for bluetooth
My bluetooth is working well (I can pair with any device), however the specific action of having an advertisement is not working

I have tried the exact same procedure under a live image of ubuntu 20.04.2 and Fedora 34 and it’s working out of the box.

way to reproduce:

~/Downloads » bluetoothctl
Agent registered
[CHG] Controller 4C:1D:96:E1:C4:3F Pairable: yes
[bluetooth]# show
Controller 4C:1D:96:E1:C4:3F (public)
Name: dell
Alias: dell
Class: 0x00000000
Powered: yes
Discoverable: no
DiscoverableTimeout: 0x000000b4
Pairable: yes
UUID: Message Notification Se… (00001133-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control (0000110e-0000-1000-8000-00805f9b34fb)
UUID: OBEX Object Push (00001105-0000-1000-8000-00805f9b34fb)
UUID: Message Access Server (00001132-0000-1000-8000-00805f9b34fb)
UUID: PnP Information (00001200-0000-1000-8000-00805f9b34fb)
UUID: IrMC Sync (00001104-0000-1000-8000-00805f9b34fb)
UUID: Vendor specific (00005005-0000-1000-8000-0002ee000001)
UUID: Headset AG (00001112-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
UUID: Generic Attribute Profile (00001801-0000-1000-8000-00805f9b34fb)
UUID: Phonebook Access Server (0000112f-0000-1000-8000-00805f9b34fb)
UUID: Audio Sink (0000110b-0000-1000-8000-00805f9b34fb)
UUID: Device Information (0000180a-0000-1000-8000-00805f9b34fb)
UUID: Generic Access Profile (00001800-0000-1000-8000-00805f9b34fb)
UUID: Headset (00001108-0000-1000-8000-00805f9b34fb)
UUID: Audio Source (0000110a-0000-1000-8000-00805f9b34fb)
UUID: OBEX File Transfer (00001106-0000-1000-8000-00805f9b34fb)
Modalias: usb:v1D6Bp0246d053A
Discovering: no
Roles: central
Roles: peripheral
Advertising Features:
ActiveInstances: 0x00 (0)
SupportedInstances: 0x05 (5)
SupportedIncludes: tx-power
SupportedIncludes: appearance
SupportedIncludes: local-name
SupportedSecondaryChannels: 1M
SupportedSecondaryChannels: 2M
SupportedSecondaryChannels: Coded
[bluetooth]# menu advertise
Menu advertise:
Available commands:
[bluetooth]# name BTTEST
[bluetooth]# discoverable on
[bluetooth]# back
Menu main:
Available commands:
[bluetooth]# advertise on
[CHG] Controller 4C:1D:96:E1:C4:3F SupportedInstances: 0x04 (4)
[CHG] Controller 4C:1D:96:E1:C4:3F ActiveInstances: 0x01 (1)
Advertising object registered
Tx Power: off
LocalName: BTTEST
Appearance: off
Discoverable: on

Now I use NRF Connect app on Android to try to detect my device, I should see the device “BTTEST” in the list but it’s not showing
I don’t see any error, I tried running bluetoothd manually but same issue

Here are the necessary infos:

> ~/Downloads » uname -a
Linux dell 5.4.116-1-MANJARO #1 SMP PREEMPT Sun May 2 11:10:35 UTC 2021 x86_64 GNU/Linux
> ~/Downloads » lsb_release -a
LSB Version:	n/a
Distributor ID:	ManjaroLinux
Description:	Manjaro Linux
Release:	21.0.4
Codename:	Ornara

> ~/Downloads » lsmod | grep bt
btusb                  65536  0
btintel                28672  1 btusb
btbcm                  16384  1 btusb
btrtl                  24576  1 btusb
bluetooth             692224  43 btrtl,btintel,btbcm,bnep,btusb,rfcomm
dell_rbtn              20480  0
rfkill                 28672  9 bluetooth,dell_laptop,dell_rbtn,cfg80211

> ~/Downloads » rfkill list
0: dell-wifi: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: dell-bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
6: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

> ~/Downloads » pacman -Qs | grep -i blue
local/bluez 5.58-1
    Daemons for the bluetooth protocol stack
local/bluez-hid2hci 5.58-1
    Put HID proxying bluetooth HCI's into HCI mode
local/bluez-libs 5.58-1
    Deprecated libraries for the bluetooth protocol stack
local/bluez-utils 5.58-1
    Development and debugging utilities for the bluetooth protocol stack
local/gnome-bluetooth 3.34.5-1
    The GNOME Bluetooth Subsystem
    Simple library for communicating with USB and Bluetooth HID devices
    LDAC Bluetooth encoder library

> ~/Downloads » dmesg | grep -i blue
[    4.217418] Bluetooth: Core ver 2.22
[    4.217438] Bluetooth: HCI device and connection manager initialized
[    4.217441] Bluetooth: HCI socket layer initialized
[    4.217442] Bluetooth: L2CAP socket layer initialized
[    4.217445] Bluetooth: SCO socket layer initialized
[    4.230883] Bluetooth: hci0: Firmware revision 0.0 build 118 week 15 2021
[    4.251618] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    4.251619] Bluetooth: BNEP filters: protocol multicast
[    4.251621] Bluetooth: BNEP socket layer initialized
[    4.448683] Bluetooth: RFCOMM TTY layer initialized
[    4.448686] Bluetooth: RFCOMM socket layer initialized
[    4.448688] Bluetooth: RFCOMM ver 1.11

> ~/Downloads » inxi -FxxxzD
System:    Kernel: 5.4.116-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: GNOME 3.38.4 tk: GTK 3.24.29 
           wm: gnome-shell dm: GDM 40.0 Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Precision 7540 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Dell model: 0XMC3F v: A00 serial: <filter> UEFI: Dell v: 1.2.3 date: 07/24/2019 
Battery:   ID-1: BAT0 charge: 75.2 Wh (100.0%) condition: 75.2/97.0 Wh (77.5%) volts: 12.9 min: 11.4 model: BYD DELL GW0K999 
           type: Li-poly serial: <filter> status: Full 
CPU:       Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake note: check rev: A cache: L2: 12 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62431 
           Speed: 900 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 900 5: 900 6: 900 7: 900 8: 900 
           9: 900 10: 896 11: 900 12: 899 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b 
           class-ID: 0300 
           Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-11:3 chip-ID: 0c45:6720 class-ID: 0e02 
           Display: x11 server: 1.20.11 compositor: gnome-shell driver: loaded: intel unloaded: modesetting 
           alternate: fbdev,vesa resolution: <missing: xdpyinfo> 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.0.3 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
           chip-ID: 8086:a348 class-ID: 0403 
           Sound Server-1: ALSA v: k5.4.116-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.26 running: yes 
Network:   Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: 3.2.6-k port: efa0 bus-ID: 00:1f.6 
           chip-ID: 8086:15bb class-ID: 0200 
           IF: eno1 state: down mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: efa0 bus-ID: 6f:00.0 chip-ID: 8086:2723 
           class-ID: 0280 
           IF: wlp111s0 state: up mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:7 chip-ID: 8087:0029 class-ID: e001 
           Report: rfkill ID: hci0 rfk-id: 6 state: up address: see --recommends 
Drives:    Local Storage: total: 1.4 TiB used: 422.05 GiB (29.5%) 
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEMKF256G8 NVMe 256GB size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 
           rotation: SSD serial: <filter> rev: 7002 scheme: GPT 
           ID-2: /dev/nvme1n1 vendor: Intel model: SSDPEMKF256G8 NVMe 256GB size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 
           rotation: SSD serial: <filter> rev: 7002 scheme: GPT 
           ID-3: /dev/nvme2n1 vendor: Samsung model: SSD 970 PRO 1TB size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 rotation: SSD 
           serial: <filter> rev: 1B2QEXP7 scheme: MBR 
Partition: ID-1: / size: 233.44 GiB used: 188.38 GiB (80.7%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      Alert: No swap data was found. 
Sensors:   System Temperatures: cpu: 48.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 fan-2: 0 
Info:      Processes: 286 Uptime: 28m wakeups: 1 Memory: 31.12 GiB used: 2.7 GiB (8.7%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 clang: 11.1.0 Packages: 1803 pacman: 1794 flatpak: 9 Shell: Bash v: 5.1.4 running-in: tilix 
           inxi: 3.3.04 

Thanks for the help

Updating to kernel 5.11 fixed the issue using Manjaro Kernels - Manjaro

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.