Blank Screen after screen lock on KDE

Hi All,

I am running KDE plasma and I have a weird problem. I have set the display to go blank and the screen to lock after 10 minutes of inactivity. This works fine, however, when I try to wake it up ( moving the mouse or pressing a key on the keyboard) I get blank screen with just mouse pointer showing. I cant see the lockscreen where I can type the password. If i just type in my password and press enter it seems the screen unlocks but it still remains blank. Any clues as to what is going on? Any help will be appreciated

Thank you.

1 Like

I think I have solved the problem…Adding “Option” “DRI” “2” to the file stored in /etc/X11/xorg.conf.d/20-intel.conf seems to have gotten rid of the issue. Here is the full contents of the file

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "DRI" "2"
   Option      "TearFree"    "true"
   Option      "AccelMethod"  "uxa"

If the file is missing you can just make the file and add the above contents


I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.