Blackscreen & other issues trying to install manjaro xfce

I was trying to install Manjaro to try a new distro, but I’m getting stuck on practically everything I try.
When I try to install both with free / nonfree video drivers, the graphical interface of the live media “blinks” on the screen and then the monitor video “turns off” as if I had pulled the HDMI cable.
If I try to proceed with the installation with nomodeset, I encounter the following problem: “failed to start light display manager”, and after that message the boot script continues until it finally stops at “reached target graphical interface”, nothing happens after that message.
I also tried to change other boot parameters of the live usb, also trying with acpi = off, iommu = soft , amd_iommu = on, iommu = pt.
As my hardware is all AMD, I always had a problem with video drivers on Linux, but these flags mentioned earlier used to solve the problem, at least on Ubuntu (I could install the OS with nomodeset, and then install the drivers manually).

Anyway, basically this is it … I would like to ask for any help or guidance to solve this problem, I didn’t even manage to launch the installer GUI.

My hardware specifications:

PowerColor PCS + Radeon R9 390 GPU
MB GA-970A-DS3P (rev. 2.x)

PS: I even tried to install using Architect with Linux 4.19. I don’t know if the problem was me who set it up badly, but it also didn’t solve it for me.

If you still have your “other distro” working, you should provide more detailed info about your hardware, otherwise no one will be able to remotely give any suggestions.