Blackarch install error logs?


#1

linux412-headers-4… 7.7 MiB 146K/s 00:54 [######################] 100%
(3316/3316) checking keys in keyring [######################] 100%
(3316/3316) checking package integrity [######################] 100%
(3316/3316) loading package files [######################] 100%
(3316/3316) checking for file conflicts [######################] 100%
error: failed to commit transaction (conflicting files)
/usr/lib/python2.7/site-packages/bcrypt/init.py exists in both ‘python2-bcrypt’ and ‘python2-py-bcrypt’
/usr/lib/python2.7/site-packages/bcrypt/init.pyc exists in both ‘python2-bcrypt’ and ‘python2-py-bcrypt’
/usr/lib/python2.7/site-packages/bcrypt/_bcrypt.so exists in both ‘python2-bcrypt’ and ‘python2-py-bcrypt’
/usr/bin/frida-discover exists in both ‘python2-frida’ and ‘frida’
/usr/bin/frida-ls-devices exists in both ‘python2-frida’ and ‘frida’
/usr/bin/frida-ps exists in both ‘python2-frida’ and ‘frida’
/usr/bin/frida-trace exists in both ‘python2-frida’ and ‘frida’
/usr/lib/ruby/gems/2.4.0/cache/ffi-1.9.18.gem exists in both ‘aquatone’ and ‘dawnscanner’
/usr/lib/ruby/gems/2.4.0/gems/ffi-1.9.18/COPYING exists in both ‘aquatone’ and ‘dawnscanner’
/usr/lib/ruby/gems/2.4.0/gems/ffi-1.9.18/LICENSE exists in both ‘aquatone’ and ‘dawnscanner’
/usr/lib/ruby/gems/2.4.0/gems/ffi-1.9.18/README.md exists in both ‘aquatone’ and ‘dawnscanner’
/usr/lib/ruby/gems/2.4.0/gems/ffi-1.9.18/Rakefile exists in both ‘aquatone’ and ‘dawnscanner’
/usr/lib/ruby/gems/2.4.0/gems/ffi-1.9.18/ext/ffi_c/.sitearchdir.time exists in both ‘aquatone’ and ‘dawnscanner’
/usr/lib/ruby/gems/2.4.0/gems/ffi-1.9.18/ext/ffi_c/AbstractMemory.c exists in both ‘aquatone’ and ‘dawnscanner’
/usr/lib/ruby/gems/2.4.0/gems/ffi-1.9.18/ext/ffi_c/AbstractMemory.h exists in both ‘aquatone’ and ‘dawnscanner’
/usr/lib/ruby/gems/2.4.0/gems/ffi-1.9.18/ext/ffi_c/AbstractMemory.o exists in both ‘aquatone’ and ‘dawnscanner’

There was a lot more but I couldn’t fit it all in here. Might sound stupid but I even tried installing ruby… Idk.


#2

Any context how do you get these issues?

Also for every file exists do the following…


#3

That is why I don’t like AUR so much. Please check for each package and remove them as needed. python2-py-bcrypt I don’t know. Only found python2-bcrypt in official repos.


#4

I can’t figure out the use or how to apply this


#5

Check for any conflicting file: pacman -Qo /usr/lib/python2.7/site-packages/bcrypt/init.py and remove the depending package as needed. When done you may update your regular system and then try to figure out how to solve your conflicts if still any.


#6

In truth i don’t understand why people want mix Manjaro with Arch… @cpytron if you use our stable repo i think you break your manjaro installation very quickly … better if you switch on unstable repo and at last already exist balckarch :grin:


#7

IMO better using Blackarch as a separate installation, or in a VM, Blackarch even provides an OVA file so you don’t even have to install it, just import it into virtualbox.

Blackarch doesn’t play nice with Manjaro in my limited experience.


#8

Its just my opinion but an Arch based distro should be able to function in the way a legit Arch distro would.

I could avoid the headache of trying to create ArchJaro (I guess?) but what would be the fun in that?

If I am able to on a debian or ununtu or mint system to perform the same thing, don’t you think manjaro should be the first one with pure functionality of a mix between pentesting tools and also typical user support?

I like manjaro. It is the first distro I am thinking about sticking with for awhile and it would be nice if it could function the same as a typical ubuntu distro would. I don’t like being help back from functions and my distros controlling what I am capable of on my machine. Which is probably why I just simply haven’t installed Arch because of all the ■■■■■■■■ I have to go through to do it.

I want layman typical user functionality while also being able to have some fun with my computer’s capabilities.


#9

I have a Kali USB, but I like to be able to function on one machine without having to reboot (like ever) and it’s more lazyness in that sense.


#10

Then use virtualbox and run Kali and Blackarch in VMs.


#11

As @Ste74 mentioned switch to unstable branch on Manjaro (hint: edit /etc/pacman-mirrors.conf) which will more likely give you the package version you need for BlackArch or install a distro which follows Arch more closely like Antergos which will probably be 100% compatible wih BlackArch. :thinking:

And ask BlackArch related questions on BlackArch support channels - you will get better help and we won’t have the frustrastration of not being able to help which is no fun. :frowning:


#12

A draft horse should perform as a quarter horse, or in reverse, just because are horses? Both are breeds with specific characteristics and for different tasks. Anybody would have unfortunate results by trying to put them in front of the same carriage.


#13

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.