Black screen, XFCE Manjaro does not show login screen after sceen locked due to inactivity

it happened again, i returned to Linux 5.10.36-2-MANJARO XFCE 4.16 computer after a few minutes, it locked the session and went black screen properly (as numerous times before), but this time it does not show login prompt, only black screen. Keyboard reacts, computer goes. What worked was to SSH into computer and run: systemctl suspend
and then hit a key on keyboard to wakeup successfully.

dmesg does not show anything strange.
journalctl -x
shown some interesting lines, but maybe not related.

any ideas what to try, or how to capture more details in case it happen again? Or ideas on commands instead of “systemctl suspend”?

Update: Now i remember that this bug can be workaround by blindly typing password and hit enter. (even the screen is black)

Experiencing same issue after Pahvo upgrade :-\

Black screen, blind typing + login working, though.

1 Like

I’m seeing this, too, even though I’ve disabled screen lock. When locking screen explicitly with CTRL-ALT-DEL, or closing the laptop lid, it still goes over to black screen that won’t go away. Thanks for the tip about blind typing, though, it works!

I wonder if this is related to using the open source Intel graphics driver?

my OS is migrated from Intel GPU computer to AMD GPU-only computer (computer has AMD cpu with integrated graphics) yet this issue still happen for me. I am unsure if intel drivers remains can influence it:

$ pamac search -a intel|grep Installed
tbb         [Installed] 2020.3-1                                      extra 
xf86-video-intel [Installed] 1:2.99.917+916+g31486f40-1                    extra 
vulkan-intel [Installed] 21.2.2-1                                      extra 
libva-intel-driver [Installed] 2.4.1-1                                       extra 
lib32-vulkan-intel [Installed] 21.2.2-1                                      multilib 
lib32-libva-intel-driver [Installed] 2.4.1-1                                       multilib 
intel-ucode [Installed] 20210608-1                                    extra 
intel-media-sdk [Installed] 21.3.2-1                                      community 
intel-media-driver [Installed] 21.3.2-1                                      community 
intel-gmmlib [Installed] 21.2.1-1                                      community 

btw. Manjaro has no active bug tracker where devs. try to debug the issue and fix it?

I downgraded the kernel to 5.10 LTS and screens wakeup works again since then.

PS: 5.13.19-2 woks as well


I tried to downgrade to 5.10 LTS, but that didn’t help. What did help was installing all proprietary drivers in Manjaro Settings Manager. I have a dual GPU Intel-NVIDIA machine, so your kilometrage may vary.

rf2020 sure, proprietary makes absolutely sense for Nvidia, should have asked.
I’m on AMD so the kernel makes more sense there.