Black screen with NVIDIA proprietary drivers and GeForce GT 330M

I use the NVIDIA GeForce GT 330M. When I download and use proprietary drivers (video-nvidia-340xx and bumblebee), I reboot, the screen just plain old blanks out. Or freezes at the wall of text you normally see before login.

Start a thread then and get it sorted.

You mean hard dependencies that can't be easily removed?

That would probably be an Arch issue then, given nearly all Manjaro packages are maintained by the upstream Arch mothership.

1 Like

I would if the board would let me - says I've created the maximum number of threads for the day. Must try to-morrow then, if I remember.

In re: dependencies, no, I just mean the regular sort of orphaned dependencies. If you install package gnomovision, it depends on lib-gnomo... then you uninstall gnomovision, but lib-gnomo stays, as far as I know.

Meh, just do it here ... a continuation of your Manjaro story


inxi -G
mhwd -li

If it is an older card (ie Fermi Family) it could be simply a matter of using the 390 series legacy driver instead of the mainline driver (418 currently).

How do you remove packages?

With the right pacman flags unused dependencies should also be cleaned up.

Check orphaned packages using pacman.

pacman -Qdtq

To automatically delete orphans.

sudo pacman -Rs $(pacman -Qdtq)

Tried the first command, this is what it spits out:

Graphics: Device-1: Intel Core Processor Integrated Graphics driver: i915 v: kernel Device-2: NVIDIA GT216M [GeForce GT 330M] driver: nouveau v: kernel Display: server: X.Org 1.20.4 driver: modesetting,nouveau resolution: 1920x1200~60Hz, 1920x1200~60Hz OpenGL: renderer: NVA5 v: 3.3 Mesa 19.0.3

When I tried last time, it installed video-nvidia-340xx and video-hybrid-nvidia-intel-340xx-bumblebee. Nothing about 390, nothing about 418.


As for removing orphaned packages, I figured it could be done in Pacman - that tool can do anything! - but I have no idea how to do it in Pamac. Pacman is very confusing with its one-letter commands, and I was a big apt-get geek in my Ubuntu days.

That particular GPU might require to add in /etc/default/grub this line:
then run
sudo update-grub

probably add in /etc/mkinitcpio.conf the line
after modifying this you have to run
sudo mkinitcpio -P

and in /etc/modprobe.d/blacklist.conf
blacklist nouveau

but i honestly don't know the state of bumblebee for it. Anyway, there are alternatives and some ways to chose from:

1 Like
inxi -Fxxcz

You have dual gpus, intel and nvidia, is your machine an optimus laptop? I suspect you are only using your intel gpu anyway.

NVIDIA GT216M [GeForce GT 330M]

Your nvidia gpu is in the Tesla family.

Which is supported by the mainline nvidia driver, currently at 418.

For optimus laptops the correct mhwd driver should be video-hybrid-intel-nvidia-bumblebee . The 340 series driver won't support your nvidia gpu, hence the black screen on boot.

Use mhwd to remove your current driver, which I assume is video-linux, use mhwd -li to confirm.

sudo mhwd -r pci video-linux
sudo mhwd -i pci video-hybrid-intel-nvidia-bumblebee

After reboot check nvidia gpu operational with

primusrun glxgears
1 Like

Cannot recommend learning pacman enough.

Pamac also has a cli mode, the commands are verbose and much more apt like.

Sometimes i use this page as reference for nvidia GPU's
it has the list of drivers used ... Maybe will help to identify better what is going on in your particular case.


I tried to install optimus prime, which wrecked my display again (frozen boot), but I was able to get into command line mode, uninstall it, and try your solution.

Then, I followed your instructions, installed the mainline driver, now it's stuck on this:

While installing the driver, mhwd informed me that no such device existed on the system (but installed it anyway).

Optimus laptops on Linux are messy, nvidia doesn't officially support them, only solutions are third party hacks like bumblebee, optimus-manager and prime.

Please provide.

inxi -Fxxcz

Place the output in code tags to make it more readable.


Sometimes kernel parameters are required, depending on the laptop manufacturer.

nick@athena# inxi -Fxxcz
System:    Host: athena Kernel: 5.0.10-2-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: Deepin 15.10 
           tk: Qt 5.12.3 wm: DeepinWM dm: LightDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Apple product: MacBookPro6,1 v: 1.0 serial: <filter> Chassis: type: 10 
           v: Mac-F22589C8 serial: <filter> 
           Mobo: Apple model: Mac-F22589C8 serial: <filter> UEFI: Apple v: MBP61.88Z.0057.B1C.1706170449 
           date: 06/17/17 
Battery:   ID-1: BAT0 charge: 82.1 Wh condition: 83.8/94.9 Wh (88%) volts: 8.0/7.3 model: DP bq20z951 serial: N/A 
           status: Discharging 
CPU:       Topology: Dual Core model: Intel Core i7 M 620 bits: 64 type: MT MCP arch: Nehalem rev: 5 
           L2 cache: 4096 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21291 
           Speed: 1463 MHz min/max: 1197/2661 MHz Core speeds (MHz): 1: 1413 2: 1428 3: 1463 4: 1332 
Graphics:  Device-1: Intel Core Processor Integrated Graphics driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:0046 
           Device-2: NVIDIA GT216M [GeForce GT 330M] vendor: Apple driver: nouveau v: kernel bus ID: 01:00.0 
           chip ID: 10de:0a29 
           Display: x11 server: X.Org 1.20.4 driver: intel,nouveau unloaded: modesetting alternate: fbdev,nv,vesa 
           resolution: 1920x1200~60Hz, 1920x1200~60Hz 
           OpenGL: renderer: NVA5 v: 3.3 Mesa 19.0.3 direct render: Yes 
Audio:     Device-1: Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:3b56 
           Device-2: NVIDIA GT216 HDMI Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0be2 
           Sound Server: ALSA v: k5.0.10-2-MANJARO 
Network:   Device-1: Broadcom and subsidiaries NetXtreme BCM5764M Gigabit Ethernet PCIe driver: tg3 v: 3.137 
           port: 3000 bus ID: 02:00.0 chip ID: 14e4:1684 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Broadcom and subsidiaries BCM43224 802.11a/b/g/n vendor: Apple AirPort Extreme driver: wl 
           v: kernel port: 3000 bus ID: 03:00.0 chip ID: 14e4:4353 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 465.92 GiB used: 60.74 GiB (13.0%) 
           ID-1: /dev/sda vendor: Apple model: SSD TS512B size: 465.92 GiB speed: 3.0 Gb/s serial: <filter> 
Partition: ID-1: / size: 181.81 GiB used: 60.18 GiB (33.1%) fs: ext4 dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 75.0 C mobo: N/A gpu: nouveau temp: 73 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 174 Uptime: 1m Memory: 7.72 GiB used: 823.4 MiB (10.4%) Init: systemd v: 242 Compilers: 
           gcc: 8.3.0 Shell: bash v: 5.0.3 running in: deepin-terminal inxi: 3.0.33 

Apple product: MacBookPro6,1

Ah, this is a Macbook Pro ... I have no experience setting up Linux on Apple hardware.

Maybe the Arch Wiki can help.,1

If you are happy enough with video-linux and simply using the intel gpu then just stick with that.


Similar thread here.

Most likely this looks like where it is paused, but it actually froze later down the line due to the GFX driver failing to initialize the nVidia chip. I've been able to move back and forth from the command line and see that it froze a couple lines after initializing the GPU. I've even had a kernel panic, but that may have been due to another problem I have since fixed.

When using Nouveau I'm unable to launch any game. I'd like to play a little Stardew Valley without switching back to my Mac partition because I'd like to avoid MacOS if I could. It's more of a want than a need but I can see this being a similar desire as OP.

Sorry for double post

pamac remove --orphans or pamac remove -o

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.