Black screen with mouse after last update

Hello, please help me with black screen problem (after update two days ago). I can start command line (Ctrl+Alt+F2) and tried some advices from topics. For example, brahma posts (can’t insert links there) with sudo rm /etc/X11/mhwd.d/vesa.conf → sudo mhwd -r pci video-vesa → sudo mhwd -r pci video-modesetting. Also tried to reinstall SSDM / plasma, update from mirrors, don’t help :frowning: I am very new in Manjaro…

do you have dual graphics? nvidia+intel/amd?

I have HUAWEI MateBook 16 CurieM-WFD9AW, so graphic card is AMD Radeon Graphics. Command “lspci | grep VGA” output is
VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cezanne (rev c5)

so whats the output from:
mhwd-kernel -li

5.15.49-1-MANJARO (linux515)

so only one kernel, and output from:
mhwd -li
if it only shows video-linux, reinstall it:
uninstall it:
sudo mhwd -r pci video-linux
install it again:
sudo mhwd -i pci video-linux
systemctl reboot

Yes, it was only video-linux, i did reinstall, but it did not help.

and type this:

It was a few lines of output with timeouts:
xauth: home/pavel/.Xauthority not writable, changes will be ignored
xauth: timeout in locking authority file /home/pavel/.Xauthority

then some info, for example:
X. Org X server
X Prorocol Version 11, Revision 8

and in the end:
xinit: server error

so remove the xauthority file:
rm /home/pavel/.Xauthority
systemctl reboot

1 Like

Yes!!! Display works! brahma, you are the the great sage :star_struck:
Thank you very! :hugs:
Tell please what what the cause of it? Why system updates may be so inconsistent?

1 Like

reboot again, and see if the issue is resolved…
the xauthority file got somehow messed up… it sometimes happens…

Aftrer reboot all OK. That day when the black screen appears, i added my user to roots (in sudoers and in passwd files) and removed after a while. This couldn’t relate to problem (maybe since that Xauthority becomes not writable) ?

this is very likely why it happened…

Advise please how to safely add to my user root rights. Or this is not good idea at all?

that i dont know how to do it … you can create a post here on forum on how to do it

Ok, thank you

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.