Black screen with cursor when switching between users

Since update [Stable Update] 2023-12-01 I have been experiencing a problem when switching between users.

To reproduce:

  • auto-login to user A
  • switch user to user B
  • wait for < 30s…
  • switch back to user A
  • a black screen is shown with the mouse cursor (it seems that the cursor sees the window borders since moving it changes the cursor shape)

If I wait long enough the same happens to user B.
Switching consoles work. No combination helps on the black screen (alt-tab, ctrl-tab, super-tab, ctrl-esc). The only medicine is ctrl-alt-backspace.

What I tried:

  • I checked the logs, journal - nothing.
  • Tried to switch to kernel from 6.1 LTS to 6.6 LTS - same problem.
  • Removed all screensavers (light-lock, xfce4-screensave, xscreensaver).
  • Renamed xflock.
  • Set xfce4-session LockCommand to /bin/true.
  • Tried to use xkill - nothing is killed.
  • xwininfo shows the window is ‘Desktop’

Any help/hint on what to try, look at would be greatly appreciated.

CPU: 12-core AMD Ryzen 9 5900X (-MT MCP-) speed/min/max: 2383/2200/4950 MHz
Kernel: 6.1.64-1-MANJARO x86_64 Up: 11h 16m Mem: 4.25/62.72 GiB (6.8%)
Storage: 51.71 TiB (21.2% used) Procs: 619 Shell: Zsh inxi: 3.3.31
██████████████████  ████████   a@c
██████████████████  ████████   ------------ 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Host: MS-7D52 1.0 
████████            ████████   Kernel: 6.1.64-1-MANJARO 
████████  ████████  ████████   Uptime: 11 hours, 18 mins 
████████  ████████  ████████   Packages: 2075 (pacman) 
████████  ████████  ████████   Shell: zsh 5.9 
████████  ████████  ████████   Resolution: 1920x1200 
████████  ████████  ████████   DE: Xfce 4.18 
████████  ████████  ████████   WM: Xfwm4 
████████  ████████  ████████   WM Theme: Matcha-sea 
████████  ████████  ████████   Theme: Matcha-sea [GTK2/3] 
████████  ████████  ████████   Icons: Papirus-Maia [GTK2/3] 
                               Terminal: kitty 
                               CPU: AMD Ryzen 9 5900X (24) @ 3.700GHz 
                               GPU: NVIDIA GeForce GTX 1070 
                               Memory: 4128MiB / 64226MiB 

I tried to create a fresh account to see if it’s also affected. Same problem - screen goes black with cursor with the fresh account, too.

I also disabled xfce power manager and disabled dpms and blanking with xset. Problem persists.

Note that the black screen I mention is a graphics mode black screen and the cursor is the mouse cursor (as opposed to tty/framebuffer screen and terminal cursor).

On a different computer there’s a similar problem. There’s only one user on it.
When the computer wakes up from sleep the same happens - (graphics) black screen with mouse cursor.

Noticed however that the problem does not happen if gnome is used instead of Xfce4.

I have only one user and have also the same problem.
For me it was an update, I think it was 2023-12-01, and when I noticed the poblem I used timeshift to revert the update, now 2023-12-10 a new update was released and I tried to update and also update the kernel to 6.6.5-1-Manjaro. The same bug presists.
I’m on an Intel 6600K, Nvidia geforce gtx 960, ManjaroLinux 23.1.0 Vulcan, xfce 4.18.

After the last update (2023.12.10) I noticed that’s enough to switch to the console (ctrl-alt-f1) and back to reproduce the problem. No need to have two users. There was also an update to xfce4-power-manager…

After the update I also noticed (don’t know if it is related) that something blanks the screen after a few minutes (1-2?) even though Xfce Power Manager is not started and there is no screensaver.

Can someone please try this?
Prerequisite:

  • Xfce4 desktop, nvidia propietary drivers

Repro case:

  • Log in as a user
  • Ctrl-alt-F1 (switches to console)
  • Wait 1 minute
  • Ctrl-alt-F8 (switch back to Xfce4 desktop)

Just when I thought I got a perfect reproducer… Please try switching back and forth a few times.

Switching to a different user works for me almost every time :wink:

Tried it,
It happens if a user is logged in the virtual console,
I have also done some tests, here:
https://forum.manjaro.org/t/after-2023-12-01-i-can-not-get-in-to-a-timed-out-session/153101/4

1 Like

Also experiencing this issue, intermittently when waking from suspend.

Tried your instructions and it reproduced the issue.

1 Like

any updates on that? We are sharing the pc with my wife and it is super annoying when I try to switch to my desktop and getting a black screen with cursor

Still happening as of today. All updates applied.

I can’t even switch to console and back without the pesky black screen. I guess this is going to drag on for a very long time.

I can reproduce it with 2 users, but no solution for it.
Maybe reinstall parallel an other Desktop like Gnome or Mate parallel, until its fixed, because i assume its pretty sure a XFCE thing.

Installed update [Stable Update] 2024-01-13 - problem still present.

@Joe_Ge With gnome it does not happen… probably something with XFCE…

1 Like

Same for me. The update, even it looks like it has a lot of new pretty things, did not fix it.
Even nvidia stated that they found a bug about the black screen problem at Gnome in nvidia 545.29.06-01 and fix it at xxx-02.
At least, it doesnt happen every time for me, since i switched at powermanagent under system to suspend instead of sleep or hibernate.

Medicine is supposed to heal, not kill :skull_and_crossbones: :wink:

Your journal contains nothing? Right…

If you share nothing for us to help you, then you will receive nothing from anyone that may be willing to help.

Please see:

Oh, did they now? :thinking: Where did they find that information?

:warning: If I see one more “Me too” reply with no useful information for others to help, this thread will be closed.

??
I did put a hint in it, that i changed at power management /system to suspend, and it made a difference.

For this nvidia-thread, i was not sure, if its really important, since you cant do nothing else as to wait, until we get the updates, when you have a broken suspend mode.
The last comment before 1 week there is, that nvidia fixed it in a patch, therefor it should come with a nearby update, i would conclude.

…and I applied it with 545.29.06-2 last week.

@Yochanan I’m sorry if I offended you somehow.

The ‘journal contains nothing’ means: there is nothing related to the black screen - no log lines are add when it happens.

Can you explain how to switch to 545.29.06-2?

On my system I have installed the following:

# pacman -Q | grep -i nvidia                                                                                              
lib32-nvidia-utils 545.29.06-1
linux61-nvidia 545.29.06-11
mhwd-nvidia 545.29.06-2
mhwd-nvidia-390xx 390.157-9
mhwd-nvidia-470xx 470.223.02-1
nvidia-utils 545.29.06-2
opencl-nvidia 545.29.06-2

… the black screen is still reproducible, though.

Still reproducible (from XFCE4: just switch to first console and back) after installing:

[Stable Update] 2024-02-21 - Kernels, KDE, VirtualBox, Calamares, ROCm, Firefox, Thunderbird

Any hints how to troubleshoot this?

1 Like

Still reproducible (XFC4, nvidia, switch user, black screen) after updating to:

[Stable Update] 2024-05-13 - Kernels, Plasma 6, Gnome 46, LxQT 2.0, NVIDIA

Checked logs again (as root, or logged in ‘black screen’ user):

  • journalctl -w
  • tail -f /var/log/* /var/log/*/*
  • tail -f ~/.xsession-errors

Nada de nada…

Troubleshooting hints still welcome…
I guess nobody is using the switch users feature :slight_smile:

Workaround is to:

  • logout from the first user before logging in as the second one
  • if happens use ctrl-alt-backspace to kill the session

Hi, I had the black screen with cursor problem when switching to console and back, after a heavy upgrade on Devuan Excalibur. During this, a lot of essential packages got deinstalled. The problem was solved after reinstalling one of xfce4-power-manager xfce4-clipman x11-session-utils (I don’t think it was clipman though).

I don’t know Manjaro, if there’s a relation with Devuan, which is more or less Debian without ZyklonB, sorry, SystemD.

Hi,

KDE System:

I also had the black screen with just a cursor problem. I found changing away from the default SDDM theme writes a kde-settings***.conf file in /etc/sddm.conf.d/ this seems to make SDDM not working properly

Simply erasing that file gives you the default (SDDM) theme and working login screen.

Greetings
Tobie

Please create your own Support thread. Your issue may be similar, however everyone has different hardware.