Black screen while updating and other stuff


#1

Hi all,

I did an update yesterday (4th December 2018) and found few problems that most sorted out themselves.

First, half way the update I got a black screen and had to login again after a while, than had to conclude the update and everything was working, so no real problem here, but wanted to let you know what happened.

Then, this package: cups-pk-helper-0.2.6-2 was not installed properly.
This was my first error:

error: could not open file /var/lib/pacman/local/cups-pk-helper-0.2.6-2/desc: No such file or directory

Then I looked for some solution and reinstall it was one of the suggestions. So tried that to discover that the package has 0 Byte size.
(By the way: Pamac on right click on an installed package does not have the “Reinstall” option)

And last I now have these warning, which I’m not expecting to have:

Warning: lib32-systemd: local (239.303-1) is newer than multilib (239.6-2)
Warning: libsystemd: local (239.303-1) is newer than core (239.6-2)
Warning: systemd: local (239.303-1) is newer than core (239.6-2)
Warning: systemd-sysvcompat: local (239.303-1) is newer than core (239.6-2)

Any suggestion?
Cups-pk-helper is the only real problem I suspect.

Thanks


#2

None of the mentioned are

When you do the updates, don’t let the system unattended or go to screen lock. As described in announcements, best practice is to do the update from TTY when there are a lot of packages.
The cups-pk-helper seems to want to read a desc (might be a description file) but is not there or something in the path was truncated; that doesn’t make the package nonfunctional, is just a warning.

Regrading the files that show:

is because those had to be reverted/downgraded as where many reports that are failing. If your system works fine you can ignore that, but you can also make use of:
sudo pacman -Syyuu
so those files will be downgraded on your system too and lineup with the versions in the repos.


#3

i have the same problem, even i has run pacman -Syyuu and reboot,
the system seems run ok, but when install/update package, it always show the error: could not open file /var/lib/pacman/local/cups-pk-helper-0.2.6-2/desc: No such file or directory

i copy file ‘desc files mtree’ from another computer in /var/lib/pacman/local/cups-pk-helper-0.2.6-2 , then reinstall the package cups-pk-helper, and it finally works

i update two other computer from ssh, so the update goes well(though it has black screen, but wait some time, the update will finished)


#4

Thank you @bogdancovaciu,

I did not leave the update unattended, I was watching the update progress and the screen turned black. It never happened before so that’s why I posted, otherwise I won’t bother you for simple things.

Thanks for the tips.


#5

Great, I’m going to try it.

The thing is that the updated logged me out and I found it suspicious. Than running the update again finished the process without issues.

Thanks