Black Screen when Booting Live USB. Would Love Some Help

Greetings. I searched before I ask. I looked through search engines as well. I think I am in over my head. Specs:
Ryzen CPU
RX 580 GPU
2 monitors
Illuminated KB and Mouse
Hard Drive is NOT SSD
UEFI, with Secure Boot disabled (I was getting warnings)

The situation:
Booting with the live USB (18.1.3) KDE. I get wha seems like the usual dmesg, as everything scrolls by, with TLP system startup/shutdown being last seen before the screen briefly shows the mouse pointer for a few seconds, then goes black.

I am unable to switch to other consoles via Shft-Alt-F1, F2, etc... I just get black screens.

I added nomodeset. While this still gives a black screen, I can switch to a console. There I used 'mwhd -li'. I received the following:
WARNING config '/var/lib/mwhd/db/pci/graphics_drivers/catalyst/MHWDCONFIG' is invalid.
There were other warnings, but they all referred to hardware I do not have, such as nvidia.

I also noted;
Name Version Freedriver Type


video-linux 2018.05.04 true PCI

That was the extent of what I could figure out after doing research. F7 (I believe is supposed to be X) is still black.

I then rebooted and tried adding xdriver=radeon to the boot line. This resulted in the same black screen, and NO other console access.

I am obviously no expert. I do use Manjaro quite happily on my cheap Acer laptop, and would love to install it on my desktop. I have simply had enough of Win10, and microsoft in general.

Any help would be greatly appreciated. Please let me know if I can provide more info.

can you try with only one screen ?

1 Like

No luck with that.

Am researching options, but don't know much about all the parameters, such as radeon.modeset, neauvou.modeset etc.

This kinda sucks.

Not sure if it helps, but I did gather a little info.

Kernel is 5.3.11-1-MANJARO
Acer Aspire GX-281
UEFI= American Megatrends
Ryzen 7 1700 8 core
GPU is AMD/ATI Ellesmere (580)
X.org 1.20.5
driver ati, radeon (likely unloaded)

Any other ifo I gleaned is audio and such. Likely not useful in this issue of mine.

have you updated bios ?
if possible under manjaro ( or other )
return inxi -Fxxxza

The BIOS is the latest. I am unable to provide inxi data, as I cannot copy and paste with limited access.

I have tried numerous tactics so far without success. Oddly, it seems that I see the mouse pointer for a while across either monitor, and even occasionally see what looks like a window (Manjaro welcome?) very briefly. It lasts less than a second.

it should use the amdgpu driver by default on that gpu. leave only 1 monitor plugged in and make sure nothing is plugged into the motherboard video outputs, just a single monitor connected directly to the gpu. you can also try editing the kernel parameters changing everything except amdgpu to modeset=0

example:

radeon.modeset=0 nouveau.modeset=0 amdgpu.modeset=1

then you can try adding in this one if your still unable to boot

systemd.mask=mhwd-live.service

Thanks. Sadly this did not work. I do get the moue pointer for a while, then the monitor indicates it has no signal and may enter power saving mode.

Oddly, when I tried other distro live usb, some worked. I am still testing.

I am wondering now if the video card is outputting a video mode/frequency that the monitor cannot handle. Just a shot in the dark, but it that even possible?

Forum kindly sponsored by