Black Screen on XFCE Live USB (IdeaPad Z585)

grub
amd
xfce
installation
#1

I'm currently trying to install the Xfce-Edition on an IdeaPad Z585 with an AMD A6-4400M APU.

Whenever I try to boot into Manjaro from the Live-USB GRUB-Menu I get a black screen and the Laptop heats up until it shuts itself off.

Disabling UEFI Boot in BIOS and selecting the non-free drivers gets me a blinking Cursor on the upper left side. Any other combination (UEFI ON/OFF , free/non-free) I don't even get the blinking cursor.


Update: (for those unfortunate people from the future that may have to deal with this crappy laptop)

Since no matter what I tried I just couldn't get Manjaro to work I tried installing some other distros.
Hey at least it's Linux right. :wink:

All pretty much behave the same, except for one : MX-Linux

Only thing I needed to do was to set ACPI=off and it just worked.
My guess is because it uses a different init-system?
Don't really know but that's my best guess.

Just make sure to set some time aside for the install as the Live-USB worked... but for some reason was really really slow. we are talking 30mins just to get to the Desktop. Full install took about 3hours.

Once installed it works really well.
Only thing not working is the battery status display.

TLDR:

Didn't manage to get anything except MX-Linux to work.

1 Like
#2

Try to remove splash, quiet from the end of the linux line. Also try adding nomodeset at the end.

#3

use the free drivers only for amd. and instead of just hitting enter on the “Boot” option, instead hit " E " , find the word “quiet” and replace it with “nomodeset” and then CTRL+X to boot, make sure there is a space before and after nomodeset

#4

Thanks for your replies
I’ve tried as suggested but the behavior sadly stays the same as before.

and just to make sure I got it right:

#5

ok, dont use the nomodeset, instead leave radeon.modeset=1 as 1 and change

these to 0
nouveau.modeset=0
i915.modeset=0

also remove quiet if its in there.

then crtl+x

this may or may not work, i’m looking for other’s using linux on your model to see what kernel parameters might be needed.

#6

Still just a black screen :pensive:

#7

did you go through basic bios steps before trying to boot?

  • disable secure boot
  • set drive to AHCI

if yes, it appears you should only have to add this parameter

acpi=off

do that the same way you did with the others, replace quiet with acpi=off
and boot.

if that doesnt work, make sure your bios is up to date, check manufacturer.

@TheTrell , i forgot to ask if you are trying to install manjaro to dual-boot with windows? or is it going to be all linux?

i ask this, because if windows is installed in UEFI mode then linux has to be also. if windows is installed in legacy mode, manjaro needs to be also.

#8

Linux all the way :wink:

#9

ok, then make sure bios is set to UEFI, and when you boot the manjaro USB from the boot selection menu, make sure you select the UEFI listing, sometimes there are 2 listings, 1 UEFI and 1 not uefi.

if you boot the usb in legacy bios mode, it will install as such. so make sure you select UEFI.

thats the spirit! dive first and look for a parachute on the way down. :grin: . besides, windows just gets in the way.:see_no_evil:

#10

Well, I’ve been using Manjaro only on my main machine for about 2 years now.
Loving it so far :heart_eyes: and up until now never really ran into any issues.

1 Like
#11

i’ve tried other distro’s but none of them even came close. my machine has never broken once because of manjaro, only self inflicted breakages.

did the acpi=off allow it to boot to a desktop?

#12

Still didn’t get it to work.

I don’t understand the BIOS as much as I’d like to, so just to make sure I’m not making a really basic mistake here is all the options available to me after having flashed it to the newest version:

#13

those look fine,
what did you use to write the manjaro usb?
which iso did you download? version? from where?

#14

Used Etcher and got the iso from here:
https://manjaro.org/download/xfce/
xfce-18.0.4-stable-x86_64.iso

#15

if you have both usb 2.0 and 3.0 ports, use the 2.0 port. and again, try this time with setting those i previously mentioned to 0, remove both quiet and splash

and add these separated with a single space, then ctrl+x to boot
acpi=off
nomodeset
iommu=soft

also, if there are any options in bios like “Optimized for Windows” change it to something else. try changing the value on “legacy USB”

you can also try adding these parameters to the mix
acpi_osi=!
acpi_osi=Linux
sp5100_tco.blacklist=1

#16


still no luck :pensive:

changing the setting for legacy USB just makes it so the USB doesn’t even get detected as a boot-option anymore

#17

ok, i just tried a few things in regards to the parameters on an older amd laptop but i cant get it to reproduce. in this situation others have used a slightly older ISO with success. i think you should try this. after it’s installed and you do a full update, it’s all up to date anyway since manjaro is rolling release there are no versions really, more like snapshot versions if anything.

download this version, format the usb key or try a different one, use etcher to write it.
https://sourceforge.net/projects/manjarolinux/files/archive/17.1.7/xfce/

#18

on the older ISO I don’t even get into the GRUB-Menu anymore it just says “Welcome to GRUB!” on a black screen.

it’s quite late over here so I’m probably gonna try again tomorrow.

thanks for all of your suggestions so far.

#19

my next suggestion is to use the architect iso. also, make sure the USB is starting in UEFI mode, try both usb 3.0 ports and 2.0, for some reason it matters on some setups. when using UEFI there is usually 2 entries for the usb at the boot selection menu (usually F12).

for example, heres mine with a manjaro USB plugged in, not bios boot order, but the boot selection menu (F12)

#20

I see you have both nouveau and radeon. Is that correct? Do you have both.