Black screen on startup

Hey! Running gnome manjaro for a couple of months on my thinkpad w530 for a couple months now. Everytjing went spotless…
Now i ran updates, and it doesn’t start anymore. Well, it boots up, i get the thinkpad screen, then manjaro loading screen for a second, then it goes black. The wifi-light is on, the disk-light blinks very rarely, so it doesn’t seem to be thinking. Backlight seems to be on, but just a black screen.
Hitting crtl+alt+delete reboots it, with no different outcome. The on/off button makes it shut down, with a manjaro loading screen.

So, eh… help? :slightly_smiling_face:
I’m not the nerdiest, so i haven’t tweaked much. Standard kernel, just out of the box gnome manjaro…

Oh! Hitting alt+f2 got me a terminal screen… i’m a disaster in terminal though :frowning:
I did manage to log in… How do i try to switch on the gui from here?

found it! should have googled right away. in a bit of a panic, sorry :frowning:
startx got me running a gui again, nothing seems wrong now? i’ll reboot, see what happens… i’ll report back :wink:

yeah, no. the problem is still there… this is a weird hoop to jump through to boot my computer :stuck_out_tongue:

anyone got an idea what i could try?

No, because we know virtually nothing about your system. An inxi output posted here would be a good start.

inxi --admin --verbosity=7 --filter --no-host --width

meanwhile i also found out gnome terminal doesn’t start up… installed pantheon-terminal to get this output:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LANG = "en_US.utf8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=28550f19-1cd5-413d-afc9-360fa35ee0e7 ro quiet splash apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 3.38.4 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LENOVO product: 24477Z0 v: ThinkPad W530 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 24477Z0 serial: <filter> UEFI-[Legacy]: LENOVO 
  v: G5ETA3WW (2.63 ) date: 09/18/2015 
  ID-1: BAT0 charge: 81.6 Wh (96.9%) condition: 84.2/84.2 Wh (100.0%) 
  volts: 12.5 min: 10.8 model: SANYO 45N1015 type: Li-ion serial: <filter> 
  status: Unknown 
  RAM: total: 15.2 GiB used: 2.29 GiB (15.1%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i7-3740QM bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  cache: L2: 6 MiB bogomips: 43119 
  Speed: 1425 MHz min/max: 1200/3700 MHz Core speeds (MHz): 1: 1425 2: 1247 
  3: 1505 4: 1452 5: 1399 6: 1482 7: 1374 8: 1447 
  Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov 
  constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb erms 
  est f16c flush_l1d fpu fsgsbase fxsr ht ibpb ibrs ida lahf_lm lm mca mce 
  md_clear mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq 
  pdcm pebs pge pln pni popcnt pse pse36 pti pts rdrand rdtscp rep_good sep 
  smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tsc 
  tsc_deadline_timer vme x2apic xsave xsaveopt xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Vulnerable: No microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300 
  Device-2: NVIDIA GK107GLM [Quadro K1000M] driver: N/A 
  alternate: nouveau, nvidia_drm, nvidia bus-ID: 01:00.0 chip-ID: 10de:0ffc 
  class-ID: 0300 
  Device-3: Chicony Integrated Camera [ThinkPad] type: USB driver: uvcvideo 
  bus-ID: 1-1.6:4 chip-ID: 04f2:b2ea class-ID: 0e02 
  Display: server: X. org 1.20.11 compositor: gnome-shell driver: loaded: intel 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 21.0.3 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 
  class-ID: 0403 
  Device-2: NVIDIA GK107 HDMI Audio driver: snd_hda_intel v: kernel 
  bus-ID: 01:00.1 chip-ID: 10de:0e1b class-ID: 0403 
  Sound Server-1: ALSA v: k5.9.16-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.26 running: no 
  Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e 
  v: kernel port: 7080 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi 
  v: kernel port: efa0 bus-ID: 03:00.0 chip-ID: 8086:0085 class-ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Message: No bluetooth data found. 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 689.33 GiB used: 53.26 GiB (7.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDA240G 
  size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 30RL scheme: MBR 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital 
  model: WD5000LPCX-24VHAT0 size: 465.76 GiB block-size: physical: 4096 B 
  logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A02 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 223.57 GiB size: 219.06 GiB (97.98%) 
  used: 53.26 GiB (24.3%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 28550f19-1cd5-413d-afc9-360fa35ee0e7 
  Alert: No swap data was found. 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 3 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900 
  Device-1: 1-1.6:4 info: Chicony Integrated Camera [ThinkPad] type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 200mA 
  chip-ID: 04f2:b2ea class-ID: 0e02 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 3-0:1 info: Full speed (or root) Hub ports: 3 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-5: 3-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900 
  Device-1: 3-1.5:3 info: Maxxter Wireless Receiver type: Mouse,Keyboard 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 50mA 
  chip-ID: 248a:ff0f class-ID: 0301 
  Hub-6: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 48.0 C mobo: 0.0 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 270 Uptime: 1h 14m wakeups: 3 Init: systemd v: 247 
  tool: systemctl Compilers: gcc: 10.2.0 Packages: 1395 pacman: 1372 lib: 445 
  flatpak: 12 snap: 11 Shell: Zsh v: 5.8 running-in: io.elementary.t 
  inxi: 3.3.04

When pasting terminal output, highlight it and use the Preformatted text </> button, not the Quote " button.

Alternatively, add three backticks ` above and below the text:


Please edit your post accordingly.

Your issue may be with GDM / Plymouth. See:

1 Like

thanks, that looks better indeed.

this did work! thanks a lot!
gnome terminal still doesn’t start, but i’ll check out those topics…

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.