Black Screen Issue on Dell Latitude 5400 with Kernel 6.1.53-1, Only Boots with initframes

I am experiencing an issue with my Dell Latitude 5400 that I hope someone can help me with. After upgrading to kernel version 6.1.53-1, I am encountering a persistent black screen during boot, even after removing the “quiet” parameter from the GRUB configuration. The system only successfully boots when I use “initframes.”

Here are some additional details:

  • System: Dell Latitude 5400
  • Kernel: 6.1.53-1 (I have also tried downgrading to kernel 5.10)
  • Graphics Drivers: Linux video
  • Dual Boot Configuration

I have tried various troubleshooting steps, including removing “quiet” from GRUB, but the issue persists. The Caps Lock key also appears to be locked when the black screen occurs.

Any guidance or suggestions would be greatly appreciated. Thank you!

what were you doing prior to this issue? updating/installing/uninstalling/modifying something?
does it work with other kernels?
provide full system info:
inxi -zav7