Black screen before pw input for decrypting the master key

first of all, hello fellow manjaro users!
im new to the club, so please go easy on me.
so im dualbooting windows and manjaro and just got the 390xx driver for my gtx 980 to work.
while installing i have decided to encrypt my manjaro harddrive, which makes me input two passwords to boot: one time to decrypt the master key, and one time to actually log into manjaro.
While i am in my manjaro desktop environment my dual screen setup works perfectly fine, its running on 165hz, nvidia-smi shows normal things and my fans are definitly regulated down to low rpms. im pretty sure the driver is working. but when starting my pc both my screens dont turn on and my fans are definitly spinning too much for idle. When i enter my decryption key while the displays are off and wait a bit my screens turn on for the actual login for manjaro. the problem is, i skip the bootmanager which i need to boot into windows. so it seems the driver is not active before manjaro actually boots. do you guys know how i could actually see and use my bootloader? im really new to linux, so please bear with me. thanks

so, ive got new data. i have one monitor plugged in via hdmi, one monitor through displayport.
if i unplug the dpmonitor everything boots fine, hdmi display turns on, i can plug in the second monitor and everything works fine, its just a hassle.
if i unplug the hdmi screen and boot, the dp screen does not turn on until i type my pw once blindly.
if i swap to other dp ports it doesnt change the described behaviours.

the thing that bugs me the most is that i dont even see my motherboard posting on the screens. could it be some weird new uefi feature of the mainboard that causes this weirdness? got an msi b550 something something tuf.


Why using legacy driver? You can safely install the latest video-nvidia driver for that GPU.
Once you install the latest driver maybe enable early KMS in /etc/mkinitcpio.conf and see if that helps. Make the line:


to be

MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)

then from terminal run:
sudo mkinitcpio -P
sudo update-grub

hey, thank you for your answer.
i uninstalled the 390xx driver and installed by sudo mhwd -a pci nonfree 0300.
The same problem exists. Then i edited the config like you recommended, that did not help either.
i honestly am starting to think that this problem is a lower level problem,i dont think this has anything to do with linux. Because like i said, i use an hdmi screen and a dp screen. if i only use hdmi everything is fine, if i only use dp my screen does not even turn on, and if i use both both dont turn on. the problem seems to have something to do with displayport. My screen uses displayport 1.4, my gpu released with 1.2. i bet the problem has something to do with that.

after rebooting a few times it worked, im pretty sure the firmware update of my gpu fixed it.
Nvidia seems to have had problems with new Displayport versions, they have released a firmware updater for that.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.