Black screen and freeze on suspending

After suspending my system, the screen immediately goes black and my auxiliary HDD stops spinning, and that’s pretty much it. This stays for hours and never truly sleeps the computer, and my case fans continue on spinning at their lowest rpm. The keyboard lights go dim and no shortcuts seem to work (such as switching to another tty), the monitor enters a power saving mode, and I’m left with either shutting down or doing a hard-reset.

I tried both suspend and systemctl suspend, same issue happens with both. I tested it previously on kernel 5.9 and switching to 5.10 with the latest update didn’t really help the problem. I wouldn’t be surprised if it was due to my Nvidia GPU as suspending works fine on my laptop running Manjaro KDE aswell, only with Intel graphics. Unluckily for me, my awesome new Ryzen processor has no integrated GPU, so I’m left to the mercy of Nvidia drivers.

I know there are several similar topics, and I went through all that I could find, but they are either unresolved or for a slightly different situation.

System information (first time creating a support topic here, sorry if I forgot to include something valuable):

inxi -Fazy
journalctl for the last suspend

Hi Hyperion,

I had this behavior when upgrading to 5.10 with the old NVIDIA driver 340 from AUR but not having a xorg.conf generated by the NVIDIA tool. It booted fine but on suspend or if the screen was locked and go off the system stuck.

I’m on the video-nvidia driver since the last update and uninstalled the other nvidia drivers. Just noticed that my old .conf file was generated for my older monitor setup, so I generated a new file from nvidia-settings, saved it as nvidia.conf and ran sudo mhwd-gpu --setmod nvidia --setxorg /etc/X11/mhwd.d/nvidia.conf (according to a Manjaro wiki article). I restarted the computer and tried a suspend afterwards, but that didn’t help.

Also, I just noticed that my PowerMizer setting (preferred mode: auto/adaptive/maximum performance) keeps reverting to auto whenever I restart, despite saving the configuration to ~/.nvidia-settings-rc. It seems to be a known, and probably another unresolved issue, discussed here:

But that seems to be an issue for another topic.

Just a guess, but is /etc/X11/mhwd.d/nvidia.conf automatically included or does mhwd put another file into /etc/X11/xorg.conf.d? I’ve put my configuration into xorg.conf.d.

There is a BUG in Nvidia driver, which prevent card from PCI D3, because of change in 5.10 kernel.

I have a /etc/X11/xorg.conf.d/90-mhwd.conf symlink to /etc/X11/mhwd.d/nvidia.conf. The X11/xorg.conf file has outdated information, but I guess it’s not needed anymore as mhwd-gpu --status points to the nvidia.conf file. Not sure if it’s automatically included, but it should be included either way now.

I don’t think it’s necessarily caused by a bug in 5.10 kernel, as the same behaviour occured with 5.9.

So does everyone on proprietary Nvidia drivers have such issues with suspending and is there nothing to be done about it or is it only caused by GTX 960 + proprietary drivers?

Issue persists after newest Manjaro update. I tried these commands:

sudo systemctl enable nvidia-hibernate.service
sudo systemctl enable nvidia-suspend.service
sudo systemclt enable nvidia-resume.service

but after passing status instead of enable, they all read

Loaded: loaded (/usr/lib/systemd/system/nvidia-suspend.service enabled; vendor preset: disabled)
Active: inactive (dead)

I tried passing start instead fo the nvidia-suspend.service, which caused something different than systemctl suspend. My screen turned all black and the fans ramped up a bit for some reason. But this stayed on for a couple of minutes so I had to hard-shutdown my PC again.

1 Like

After enabling the Nvidia suspend service and updating to the newest Manjaro KDE version and kernel 5.11, my journalctl looks like this:

There are mentions of nvidia-suspend.service but the don’t seem to be indicating any error at all! :confused: