Black screen after update. Not able to enter in tty

Hello. Hope this community can help me.

I have a problem with my computer. It’s a Lenovo ThinkPad 13, with Intel graphics integrated. I updated Manjaro a few days ago, and it was a huge update. The system didn’t let me update my packages for a few weeks (for some reason, there was nothing to update even updating the pacman mirrors) and when I rebooted the system, after Lenovo’s logo, the screen went black (is active, but black, since I can see some dim) and I’m not able to fix it. I have tried some things.

  • Reinstalling Linux kernel 5.15

  • Upgrading grub

  • Reinstalling intel drivers

  • Checking the journalctl from the last boot. Here I do not find any real problem. Maybe some yellow (warnings?) about eventcalendar plasmoid. Repeated a lot through the journal. But almost nothing in red.

  • Mounting different folders with grub or UEFI.

  • Updating Manjaro mirrors with

    sudo pacman-mirrors -f5

The output to: manjaro-chroot -a is:

grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your
==> Mounting (ManjaroLinux) [/dev/sda2]
--> mount: [/mnt]
--> mount: [/mnt/boot/efi]

Here is some info about my logs while I`m chrooted:

Currently running: 6.1.7-1-MANJARO (linux61)

The following kernels are installed in your system:

  • Linux 5.10
  • Linux 5.15

the output to mhwd is:

> 0000:00:02.0 (0300:8086:5916) Display controller Intel Corporation:
video-linux 2018.05.04 true PCI
video-modesetting 2020.01.13 true PCI
video-vesa 2017.03.12 true PCI

Maybe someone can help me with this. I’m a little bit out of ideas right now.

Have you tried booting in Linux 5.10 yet? (No mention of that anywhere in your question)


I’ve been checking the journalctl --boot-list dates and the last one is from the 24th. The day I rebooted for the last time.

-1 9b89c3809f4c491fac0244a0ebcf6730 Wed 2023-01-11 19:49:29 CET Tue 2023-01-24 19:56:44 CET
0 667360f34bd347c799458c0f7d7c34f5 Tue 2023-01-24 19:57:10 CET Fri 2023-01-27 16:45:54 CET

Seems like it’s not creating new journals either. Yesterday I had my computer on blackscreen for 1 hour just in case.

Hmm - you did respond, but you didn’t even touch the question @Fabby asked.

My observation and comment on this:

We can’t see whether the chroot was successful - it probably was, but we don’t know.
just chroot will not do anything


this will, of course, be the currently running kernel - the one from the live ISO you used to boot and then to chroot
not necessarily the one that your defunct system will be using
because that is not the one that is running

it may be installed in your system, too
(it is not)
but that is not what is currently running

You are a legend. I’ve been trying to debug this problem for the last 6 days. Linux 5.10 works. I managed to reboot with grub changing the grub file.

vim /etc/default/grub

Changed to


and commented


Then when I restarted I had the option to reboot with manjaro (black screen) linux5.10 or 5.15. They all seem to work but the first one keeps crashing on blackscreen.

Also @Fabby seems like my pacman is not giving me anything more to update again. I’ve done some commands like:
sudo pacman-mirrors --fasttrack 10 && sudo pacman -Syyu
sudo pacman-mirrors --geoip
sudo pacman-key --refresh-keys

But when I do a pacman -Syyu there is nothing to update. Any advice on this??

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.