Black screen after selecting boot option

Hey there,
so I was just booting up my PC and after selecting Manjaro linux (it’s dual-booted with Windows 11) I just get nothing… Just a black screen, no cursor, no text, nothing.
Trying Ctrl + Alt + F2 to get into a shell doesn’t work, neither does ssh. I don’t remember what I did what caused it, If it was updating my system, or hibernating it or maybe I set it to sleep, I can’t remember.
I hope someone here can help me, I wasn’t yet able to find any helpful threads.

when did it start happening? there was a update 1-2 days ago, did you updated your system? was it working normally before the update?

It was working normally before the update. But it happened like a week ago or so, so it isn’t caused by any recent updates.

still getting the black screen? can you switch kernels in grub menu and try?

Tried that (5.15 and 4.14 are installed, tried the normal versions and fallback) but got the same result… I thought I had an LTS kernel too but I don’t…

then youll probably have to chroot.
boot into a live usb of manjaro, open terminal and run this command:
sudo manjaro-chroot -a - you can not use this command if you using btrfs file system, when in chroot run this command:
pacman-mirrors -f 5 && pacman -Syyu - if you get some dependency issues with this command run this instead:
pacman-mirrors -f 5 && pamac update
then uninstall/ reinstall kernels, run this command:
mhwd-kernel -r linux515
then install again the 5.15 with this command:
mhwd-kernel -i linux515
then run these command:
mkinitcpio -P
systemctl reboot

You can use maxi

from chroot to take inventory of the boot files. After that, it’s easier to decide how to proceed.

collect information about the boot process. This works,

  • when you are in your running system (with CTRL+ALT+F2).
  • And also in a live environment (with or without chroot)
maxi -efkvgp

Okay so I’ve tried some things out…

Reinstalling my Kernel is not possible because the system won’t let me remove the running Kernel. (Error: You can't remove your current kernel. )

I also tried maxi and this is the output of the maxi -efkvgp command. (Ran it in chroot)

Currently running: 5.15.28-1-MANJARO (linux515)
 linux414 <vmlinuz missing>   <initrd missing>= fallback=27M kver:4.14.275-1-MANJARO
 linux515 vmlinuz-5.15-x86_64 <initrd missing>= fallback=33M kver:5.15.32-1-MANJARO
Info about: /etc/default/grub
 GRUB_DEFAULT              =saved
 GRUB_TIMEOUT              =5
 GRUB_TIMEOUT_STYLE        =hidden
 GRUB_DISTRIBUTOR          ="Manjaro"
 GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=1e522e9c-0fb6-4947-8e97-7268b622951b udev.log_priority=3 amd_iommu=on iommu=pt video=efifb:off"
 GRUB_SAVEDEFAULT          =true
 GRUB_PRELOAD_MODULES      ="part_gpt part_msdos"
 GRUB_THEME                ="/usr/share/grub/themes/manjaro/theme.txt"
Info about: efi bootloaders
 /boot/efi/EFI/Manjaro/grubx64.efi 136K
 /boot/efi/EFI/boot/bootx64.efi    136K
 /boot/grub/x86_64-efi/core.efi    136K
 /boot/grub/x86_64-efi/grub.efi    136K
Info about: efi vars (needs efibootmgr)
 Boot0002* Generic Usb Device   VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)                                                   
 Boot0003* CD/DVD Device        VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)                                                   
 Boot0004* Fedora               VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)                                                   
 Boot0005* Windows Boot Manager VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)                                                   
 Boot0007* XeroLinux-KDE        VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)                                                   
 Boot0008* GRUB                 VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)                                                   
 Boot0009* Garuda               VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)                                                   
 Boot000A* Linux Boot Manager   VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)                                                   
 Boot000C* Manjaro              HD(1,GPT,f72802e8-5d32-0342-8b94-8cba05699710,0x1000,0x96000) \EFI\MANJARO\GRUBX64.EFI        
 Boot000D* Windows Boot Manager HD(1,GPT,e0d8e492-d5b6-4f2b-95e4-08280e73b7e4,0x800,0x32000)  \EFI\MICROSOFT\BOOT\BOOTMGFW.EFI
 Boot0011* Linux Boot Manager   VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)                                                   
 Boot0022* UEFI OS              HD(1,GPT,f72802e8-5d32-0342-8b94-8cba05699710,0x1000,0x96000) \EFI\BOOT\BOOTX64.EFI            ..BO
Info about: visible partitions (needs lsblk)
Authorization required, but no authorization protocol specified
Exception in thread "main" java.awt.AWTError: Can't connect to X11 window server using ':0' as the value of the DISPLAY variable.
        at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)
        at sun.awt.X11GraphicsEnvironment.access$200(
        at sun.awt.X11GraphicsEnvironment$
        at Method)
        at sun.awt.X11GraphicsEnvironment.<clinit>(
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(
        at java.awt.GraphicsEnvironment.createGE(
        at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(
        at sun.awt.X11.XToolkit.<clinit>(
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(
        at java.awt.Toolkit$
        at java.awt.Toolkit$
        at Method)
        at java.awt.Toolkit.getDefaultToolkit(
        at de.uhingen.kielkopf.andreas.maxi.ClipboardSupport.transfer(
        at de.uhingen.kielkopf.andreas.maxi.Maxi.start(
        at de.uhingen.kielkopf.andreas.maxi.Maxi.main(
1 ==>./maxi needs a java runtime with at least version 1.8

Maxi is made for manjaro linux only
This is version 0.6.9 from 26.3.2022

./maxi [OPTIONS]

 -h --help         help
 -c --color        colorize output unconditionally
 -k --kernel       installed kernels, initrd, chroot
 -l --list-all     all kernels (not only installed)  
 -v --kver         kernelversion (includes -k)
 -m --modules      list modules and extramodules    
 -s --shasum       produce short hash to compare kernel & modules
 -w --watch [100]  watch how everything changes over time 
 -g --grub         /boot/grub/grub.cfg, /etc/default/grub
 -i --mkinitcpio   /etc/mkinitcpio.conf
 -e --efi          efi bootloaders 
 -f --forum        frame with backticks and [details] and copy to clipboard
   default equals to: -km
   compare sha256sum ./maxi at:
  • Then try installing another kernel like 5.10. this will succeed.
  • Reboot stopping grub (with ESC). And select 5.10
  • Try to get into konsole (with CTRL+ALT+F2).

If you did this in chroot, then this kernel seems to be missing.

It seems you need to be root to get infos about partitions. In my manjaro this works without additional privileges. :man_shrugging:

Or is lsblk missing ? :thinking:

Which entry did you try ?

Boot000C* Manjaro ---> \EFI\MANJARO\GRUBX64.EFI

which seems to be /boot/efi /EFI/Manjaro/grubx64.efi 136K

Boot0022* UEFI OS ---> \EFI\BOOT\BOOTX64.EFI

which seems to be /boot/efi /EFI/boot/bootx64.efi 136K

I always only tried the entry titled “Manjaro”. And by the way I’ve installed the 5.10 Kernel and updated GRUB and I will reboot and try that kernel. Or is there anything besides updating GRUB that I have to do for the kernel to work?

And I also get this message when updating GRUB /usr/bin/grub-probe: warning: unknown device type nvme0n1.

1 Like

This only says that grub could not read your SSD (maybe you have raid enabled, or other special things in UEFI). But it is “only” a warning, no error.

Or you may have to disable hibernation and fastboot in Windofs

You can find similar posts allover the forum :slight_smile: Please search for “ntfs” and fastboot

Dual boot with windows:

No, that should be enough. Otherwise just try the other boot entry in UEFI.

Sorry but time is up for me now :wink:

Okay then I don’t need to worry about my SSD where Manjaro is installed being unrecognizable I guess…
Anyways I just rebooted and I wanted to boot into Manjaro and select the 5.10 Kernel in the GRUB Menu. As it turned out thought, I have somehow dialed that while trying to fix the other issue or so. Now when I boot it just shows me the OEMs logo and then goes straight to the balck screen. I guess I will have to manually update Grubs cinfig file but I don’t know what I needed to change which option to and gladly take some help there.

Okay nevermind I figured things out.

I was able to boot into the newly installed 5.10 kernel and after a few seconds my system booted up. But while in chroot I also removed a drive from fstab file so maybe that was the issue all along…

Anyways thabnks for the help to you two :slight_smile:

i would recommend also to go to system settings/ kernel and uninstall all installed kernels (except the one youre running) since there was some issues acording to the maxi thing, and install again the 5.15, reboot into it and run it like you did before the black screen

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.