Black screen after mobo upgrade

Hello everyone!
Today I swapped my motherboard a gigabyte gaming b350 for an asrock b450 steel legend. Currently, the board detects my nvme drive where linux is installed and goes to grub so I can choose which OS I I want but as I chose Manjaro it just goes black and then stays like that.
I run a dual boot system and when I plugged my Windows drive back in it immediately booted into Wjndows 10. I’m also unable to get any linux usb to load at all. I’ve tried Manjaro, Ubuntu, and a few others but nothing works.
Any help to troubleshoot this matter would be greatly appreciated!

Current specs
Ryzen 7 1700
16gb 3200mhz 2x8gb
Asrock Radeon RX 5700
Asrock b450 steel legend

Make sure the BIOS is up to date and fast boot and secure boot is disabled.


1 Like

Hello and welcome!

If you are using ASmedia controller like this one on your asrock board:

0c:00.0 SATA controller: ASMedia Technology Inc. ASM1062 Serial ATA Controller (rev 02)

then you must probably disable it:

1 Like

Hey Storm,
Fast boot and secure boot are turned off by default and the board shipped with the latest bios version P3.40.

My drive configuration is this:
Nvme: primary boot drive containing Manjaro
WD250: secondary Windows build

I’m using GRUB2 as the bootloader. When the system boots up, it successfully loads grub showing me my choices of Manjaro or Windows. Windows loads perfectly fine but when I choose Manjaro it just goes black and stays that way.

Hey megavolt,

That controller doesn’t appear at all in storage configuration.


I’ve managed to get a usb with Manjaro XFCE loaded up. I’m going to work on getting access to my nvme drive so I can back up my data and then do a clean reinstall.

When you boot to a black screen, are you able to change to a text console with CTRL+ALT+F3 ?

Did you do anything special to boot Manjaro XFCE from the USB?

Hey cinnberg,

When it boots to a black screen there’s no signal being sent to my monitor. I did try CTRL+ALT+F3 but with no success.
The usb I was using had some older versions of linux (about six months old) but I had a newer version of XFCE from doing testing on my brother’s new pc. I plugged that in and the board booted automatically to that one.
I’m wondering if the installation of Manjaro is not being detected at all but grub loads without issue.

What kernel comes with that USB? What kernel were you using in your Manjaro? You can use the LiveUSB to chroot to your system and update the kernel if necessary. If you are unsure how to do it, you can get help from here

Grub’s configuration comes from your Manjaro’s partition, so at least that it’s detecting. I’m guessing more of a kernel driver problem with the current kernel of your Manjaro

Kernal 5.6.15-1 comes up. I’ve never had to do a kernal update from a live usb. :frowning:

It’s not so difficult. Boot up from the Live USB. Check that you have Internet and open a console and chroot to your Manjaro with:

manjaro-chroot -a

(If it asks you to select your Manjaro system, select number 1)

Just in case, update your system with:

pacman -Syyu

After that you can check what Kernel you have installed with:

mhwd-kernel -li

You can see a list of available kernels with:

mhwd-kernel -l

And you can install a kernel with:

mhwd-kernel -i linux56

You can just select the one you want changing the name linux56. You can also install multiple kernels repeating the command with different kernels.

After that you can exit chroot with:


And reboot to check if some other kernel works.

I keep getting a no targets specified.
I’m trying to use

mhwd-kernel -i linux59

I’m not sure why you are getting that. But you can also install a kernel with

pacman -S linux58

I don’t recommend to install the 5.9 branch as it’s not stable enough yet


That worked perfectly! I’ve now booted in and backing up my data. lol

Thank you to everyone for helping with this issue. :slight_smile: