Black Screen after login after system update (Nvidia)

Yesterday I performed system update with 90 or so package updates. Today I basically cannot get past the login anymore

  • LightDM works fine
  • Logging in with "Cinnamon (Software Rendering)" as DM also works fine
  • Using "Cinnamon" proper just produces a black screen with a mouse pointer which I can move around, but nothing else happens
  • I am using the nvidia drivers, which I tried reinstalling with mwhd which did not change anything
  • I might have done

Here is my inxi output:
https://bin.privacytools.io/?acd5b568f74e0e75#ohrVwOJOJWx0Y8BAi/cAk8inAMpvv0yKG9dt0rNiNLs=

Here is an Xorg log from a failing launch, in which I cannot find anything of value:
https://bin.privacytools.io/?566417d409848275#G0lLqt9XWMTPdOJGtDg1R3zJqeLip78S1DBIdMVuVNQ=

Here is the pacman.log from yesterday:
https://bin.privacytools.io/?51fae4adf56850f3#1VD0R7Je5wwXAgsarHhZge6NPc+5nDND7qe/k1LzWAo=

I'm not sure if there is anything else I should post. If so, please let me know

After adding another user account, logging in with that, logging out again and logging in with the original account the issue suddenly seems to have resolved itself. This does not make any sense to me, but i will take it

1 Like

gremlins, it's always gremlins.

this happens sometimes after an nvidia update or after installing nvidia drivers and for some reason unknown to me it takes 2 reboots for them to start working which, like you said makes no sense. :man_shrugging:

Unfortunately the same thing came up again the next day. Since I did not have a whole lot of configuration I just took the plunge and reinstalled the whole OS from scrath. So everything worked fine for yesterday evening again and today the issue reoccurs

So this is pretty disheartening to say the least. Does anyone have any idea what else could be done about it or what I should look at?

Also I rebooted A LOT more than 2 times, so i dont think that is the proper solution

it's hardly a solution even if it did work :sweat_smile:.

which kernel are you using?
have you tried others?
sudo mhwd-kernel -i linux52
reboot after, select new kernel from grub advanced menu. if it still happens, post new outputs here of:

inxi -Fxxxz
mhwd -li
pacman -Qs | grep -Ei 'nvidia|xrandr|xf86-video'
ls -laR /etc/X11
cat /etc/X11/xorg.conf.d/*.conf
xrandr --prop

just use the </> button when pasting so it's formatted properly

I was using Kernel 4.19. Tried to upgrade to 5.1 (not feeling like using any experimental builds right now tbh) but that didnt do anything.

Unfortunately I dont have much time right now, so I am just falling back to the free drivers, which also work fine. Will update the topic sometime within the next week

Thanks for your help so far

1 Like

a conflicting xorg configuration is a very common issue. next time, uninstall video-linux first and make sure there are no mhwd/video related .conf files in any of these directories before installing the nvidia drivers.

/etc/modprobe.d/
/etc/modules-load.d/
/etc/X11/mhwd.d/
/etc/X11/xorg.conf.d/

if there are, just delete them first and then install nvidia drivers

sudo mhwd -a pci nonfree 0300

That all makes sense. Unfortunately that didn't change anything either.
In an even weirder turn of events it seems like I can actually open menus on the desktop when right-clicking on select areas of the screen. Just the rest of the Desktop won't ever render (see picture)

Here is the output from the various commands you gave me

inxi -Fxxxz

System:    Host: LongSeason Kernel: 5.1.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Console: tty 2 
           dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: X370 GAMING PRO CARBON (MS-7A32) v: 1.0 serial: <filter> 
           UEFI: American Megatrends v: 1.H0 date: 07/27/2018 
CPU:       Topology: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+ rev: 2 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86425 
           Speed: 1945 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 1887 2: 2069 3: 2686 4: 2709 5: 1887 
           6: 2047 7: 1887 8: 1898 9: 2335 10: 2339 11: 4073 12: 4109 
Graphics:  Device-1: NVIDIA GM206 [GeForce GTX 960] vendor: Gigabyte driver: nvidia v: 430.26 bus ID: 1d:00.0 
           chip ID: 10de:1401 
           Display: tty server: X.org 1.20.5 driver: nvidia tty: 128x48 
           Message: Advanced graphics data unavailable in console. Try -G --display 

[At this point the command just froze and i had to kill it, here is the output of -G --display]

Graphics:  Device-1: NVIDIA GM206 [GeForce GTX 960] driver: nvidia v: 430.26 
           Display: tty server: X.Org 1.20.5 driver: nvidia resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 430.26 

mhwd -li

e[1me[31m> e[mInstalled PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
          video-nvidia            2018.08.09               false            PCI


e[1me[31mWarning: e[mNo installed USB configs!

pacman -Qs | grep -Ei 'nvidia|xrandr|xf86-video'

local/lib32-nvidia-utils 1:430.26-1
    NVIDIA drivers utilities (32-bit)
    Nvidia VDPAU library
local/libxrandr 1.5.2-1
local/linux419-nvidia 1:430.26-5 (linux419-extramodules)
    NVIDIA drivers for linux.
local/linux51-nvidia 1:430.26-7 (linux51-extramodules)
    NVIDIA drivers for linux.
local/mhwd-nvidia 1:430.26-1
    MHWD module-ids for nvidia 430.26
local/mhwd-nvidia-340xx 340.107-1
    MHWD module-ids for nvidia 340.107
local/mhwd-nvidia-390xx 390.116-1
    MHWD module-ids for nvidia 390.116
local/nvidia-utils 1:430.26-1
    NVIDIA drivers utilities
local/xorg-xrandr 1.5.0-2 (xorg-apps xorg)

ls -laR /etc/X11

/etc/X11:
total 36
drwxr-xr-x  5 root root 4096 14. Jul 17:46 .
drwxr-xr-x 90 root root 4096 14. Jul 17:46 ..
drwxr-xr-x  2 root root 4096 14. Jul 17:45 mhwd.d
drwxr-xr-x  3 root root 4096 20. Mär 22:10 xinit
drwxr-xr-x  2 root root 4096 14. Jul 17:45 xorg.conf.d
-rw-r--r--  1 root root 1222 14. Jul 17:46 xorg.conf
-rw-r--r--  1 root root    0 12. Jul 19:16 xorg.conf.nvidia-xconfig-original

/etc/X11/mhwd.d:
total 16
drwxr-xr-x 2 root root 4096 14. Jul 17:45 .
drwxr-xr-x 5 root root 4096 14. Jul 17:46 ..
-rw-r--r-- 1 root root 1499 14. Jul 17:45 nvidia.conf

/etc/X11/xinit:
total 28
drwxr-xr-x 3 root root 4096 20. Mär 22:10 .
drwxr-xr-x 5 root root 4096 14. Jul 17:46 ..
drwxr-xr-x 2 root root 4096 12. Jul 19:11 xinitrc.d
-rw-r--r-- 1 root root  739  4. Mär 19:31 xinitrc
-rw-r--r-- 1 root root   45  4. Mär 19:31 xserverrc

/etc/X11/xinit/xinitrc.d:
total 20
drwxr-xr-x 2 root root 4096 12. Jul 19:11 .
drwxr-xr-x 3 root root 4096 20. Mär 22:10 ..
-rwxr-xr-x 1 root root  318  9. Nov 2018  40-libcanberra-gtk-module.sh
-rwxr-xr-x 1 root root  203  2. Jul 07:20 50-systemd-user.sh

/etc/X11/xorg.conf.d:
total 16
drwxr-xr-x 2 root root 4096 14. Jul 17:45 .
drwxr-xr-x 5 root root 4096 14. Jul 17:46 ..
-rw-r--r-- 1 root root  266 12. Jul 18:28 00-keyboard.conf
lrwxrwxrwx 1 root root   27 14. Jul 17:45 90-mhwd.conf -> /etc/X11/mhwd.d/nvidia.conf

cat /etc/X11/xorg.conf.d/*.conf

# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "de"
        Option "XkbModel" "pc105"
EndSection
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 430.26


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Coolbits" "4"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "COMPOSITE" "Enable"
EndSection

 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

xrandr --prop

Can't open display 

[I ran this from a terminal that I opened with Ctrl+Alt+F2]

this is a new one for me and i read a lot of nvidia issues. kde starts, your able to right click on a desktop and a menu comes up.

when you boot does SDDM come up fine? then after entering password you get to a black desktop?

post:

systemctl status sddm
cat /etc/sddm.conf   
cat /var/log/Xorg.0.log | grep -E "(EE)|(WW)|error|failed|Time"

i think you should try creating a new user and log in with that. you can always remove it later if need be. this doesnt seem like a driver issue, at least not like any i've seen before.

sudo useradd -mG lp,network,power,sys,wheel <username>
sudo passwd <username>

when you boot does SDDM come up fine? then after entering password you get to a black desktop?

It's cinnamon and LightDM, but apart from that, yeah, that's exactly what happens. Also I can login fine with cinnamon in software rendering mode

I posted an Xorg.log in my initial post and nothing of relevance is in there, as far as i can see

I was also not sure if this was a driver issue, but the fact that every other configuration but the one that uses the nvidia-driver works, suggests to me that it is

I also added another user once which solved the issue for a day and then it came back. I also reinstalled Manjaro from scratch with the outcome that it also worked again for one evening. So this is not a process I am really willing to repeat anymore, tbh

Thanks for all your help in any case, i will need to evaluate now if there is any way to salvage this i guess

but the nvidia gpu works when using the nouveau drivers?

you can also try using the 390 drivers which are also suppose to work with the gtx960.

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

reboot and see if it works.

if this alone makes everything work, i would look into what you change from the time it works to the time it stops.

check this output and make sure nothing could be interfering with the nvidia driver.

cat /etc/modprobe.d/*.conf 
cat /etc/modules-load.d/*.conf

if everything looks fine, try removing 90-mhwd.conf with a basic nvidia configuration.
(example)


Section "Module"
    Load           "glx"
EndSection


Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    BoardName      "GeForce 960"
EndSection


Section "Extensions"
    Option         "Composite" "Enable"
EndSection

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by