Black screen after I configured the Nvidia drivers

To get my external monitor worked, I followed the instructions in https://archived.forum.manjaro.org/t/howto-set-up-prime-output-offload-with-nvidia-proprietary-driver/40225
But when I reboot my laptop, I cannot go into the graphic interface. What can I do to restore the system? For now, I can get into tty but don’t know what to do.
Thanks a lot.

With this amount of information, the only recommendation i can give you is to, in the tty, remove all the installed configs and then reinstall the config you wanted. As a T0 user cannot post links uploading output of tty is sadly at best a cumbersome option.
You can list all the installed configs with mhwd -li and remove configs with mhwd -r pci *name_of_config*.
For example mhwd -r pci video-hybrid-intel-nvidia-440xx-prime
After you have done that reinstall the configuration you wanted with mhwd -i pci *config_name*.

1 Like

It seems that you can send link inside two “``” marks, because I’m also a T0. Just like this https://www.google.com Could you please send the link, actually I’m realy unfamilier with manjaro.

I just reinstalled the drive but still can’t solve the problem.
When I try to remove the driver, the error message is:
pacman failed!
script failed!

Ok, Then please send the links for the output. You can upload the output of any command “easily” by adding
| curl -F 'f:1=<-' ix.io to the end. For example inxi -Fazy | curl -F 'f:1=<-' ix.io .
We would need the output of you trying to uninstall the driver and also the output of mhwd -li and inxi -Gazy .

Thank you friend. The output of mhwd -li is http://ix.io/2vfH ; for inxi -Gazy it is http://ix.io/2vfI ; for mhwd -r pci video-hybrid-intel-nvidia-440xx-prime It is http://ix.io/2vfJ

Ahhh i see now… you seem to have a conflict with the driver configs. To uninstall the drivers you first need to remove the linux-latest package with pacman -R linux-latest-nvidia-440xx . Then uninstall all configs and reinstall the config you wanted, that should get you going.

Yes! After removed the Linux-latest-nvidia-440xx, I successfully uninstalled the hybrid driver whose output is http://ix.io/2vfM then I reinstalled it, which take ages and doesn’t have any output.

Could you post the output of mhwd -li again? I think you still have the normal nvidia config installed. Please remove all driver configurations and then reinstall only the prime driver.

Yeah, it is http://ix.io/2uqH

Please remove the video-nvidia-440xx configuration then reinstall video-hybrid-intel-nvidia-440xx-prime.

Thx, I successfully reinstalled the video-hybrid-intel-nvidia-440xx-prime and video-modesetting because dependence. Now the output of mhwd -li is http://ix.io/2vfY

So you can get into a Manjaro gui session now?

1 Like

Sadly, still can’t.Thank you very very much all the same !!! (I reached the maximum replies yesterday that I have to reply to you today that I then cancelled all the change I made in that tutorial I quoted and changed it back to the original setting and thank god it worked LOL)

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.