Black screen after Grub following updates

Hi everyone. I’m resorting to writing a post here, since I have so far been unable to find a solution to my issue. Disclaimer: I have already checked the posts regarding similar issues on this forum, and have unfortunately not been able to find a working solution to my own problem. Hence why I’m posting here.

TL;DR: Updated manjaro, getting a black screen after Grub. No TTY access. Also getting no signal on monitor when plugged to my GPU in HDMI. VGA/DVI works fine.

A bit of background/context:
Couple of days ago, I came home after a trip and booted my Manjaro partition. I ran pacman -Syu to update my system, and some error came up. Being lazy, I opened pamac hoping it would give me an easy solution to my updating problem. Which it did. Apparently, and if I remember correctly, what needed to be done was to remove a version of nivida-utils (really can’t remember what precise version, and I’m not even sure it was nvidia-utils, just didn’t pay that much attention to it all because I was exhausted). And so I did, ran the command to remove the exact package pamac was telling me to, then ran pacman -Syu again to be done with the updating. Manjaro worked just fine, until the next reboot, after which it didn’t.

What the issue is:
I’m getting a black screen after selecting Manjaro in Grub. I have tried blindly entering my password, in case I was just not seeing the login screen, but this did not seem to make anything happen. I have no access to TTY (or at least, the shortcut gives no output on screen). I have tried selecting the fallback kernel version in Grub but the outcome was no different. I also tried selecting the only other kernel I have installed (linux414) which returns a kernel panic message (something VFS related)

What I have tried so far:
I have a USB drive with the Manjaro ISO on it. I have tried booting live on it and chrooting in my installation, and from here, I have tried:

  • updating the system
  • reinstalling the kernel (or at least that’s broadly what I think this command does. sorry if the terms i use aren’t exact) with pacman -S linux
  • running mkinitcpio -p linux414 and mkinitcpio -p linux511 to try and fix the fallback image. In the first case, the command returned no output, even with the verbose option, and in the second, the command returned successful output, but the main issue remained
  • updating grub
  • Running pacman -S nvidia nvidia-utils and modprobe nvidia
    the first command reinstalled the drivers succesfully, but gave me this odd message at the end:
==> Warning:
         -> This computer hasn't been restarted for a while.
         -> You are running an old kernel. In order to use a
         -> new version of the kernel, please restart your
         -> computer as soon as possible.

The modprobe command returns this:
modprobe: FATAL: Module nvidia not found in directory /lib/modules/5.10.42-1-MANJARO

  • Here’s the output of mhwd-kernel -li:

The following kernels are installed in your system:

  • linux414
  • linux511
  • I have also tried installing a different kernel. Here’s the ouput of mhwd-kernel -i [any other kernel]:
    error: no targets specified (use -h for help)

  • The error update-grub returns:

grub-probe: error: cannot find a GRUB drive for /dev/sde1. Check your
grub-probe: error: cannot find a GRUB drive for /dev/sde1. Check your

I hope to have provided enough information.
As you can probably guess I’m getting a little desperate and I would very much like to not have to reinstall Manjaro, hence I would appreciate it greatly if someone knew how to help me!
Here are my specs

OS: Manjaro Linux x86_64
Kernel: 5.10.42-1-MANJARO
Uptime: 1 hour, 26 mins
Packages: 1531 (pacman)
Shell: sh
Resolution: 1920x1080
WM: KWin
Theme: [KDE5], Breath [GTK2/3]
Icons: [KDE5], breath2 [GTK2/3]
CPU: Intel i5-7600 (4) @ 4.100GHz
GPU: Intel HD Graphics 630
GPU: NVIDIA GeForce GTX 1060 6GB
Memory: 3120MiB / 7821MiB
Nvidia driver and nvidia utils version:
linux414-nvidia 470.57.02-1
nvidia-utils 470.57.02-1

Hello! I am far from bringing you the solution, but maybe the fact that you still have the 5.11 kernel installed causes the issue. It is not supported anymore.

I suggest to always read the update announcements (Stable Updates - Manjaro Linux Forum when you are on the stable branch), don’t wait too long with updating, and do not forget to reboot right after bigger updates. In the announcements you can also read about which kernels are current and also you will be notified when a kernel series becomes EOL (end of life).

Thank you, I’ll try to stay informed in the future :slight_smile:

Maybe someone else with more knowledge can help you. Just wait a bit for others to read your post. Good luck :slightly_smiling_face:

You might also find some help here Manjaro Kernels - Manjaro

1 Like

From what you can read in the mkinitpcio manual, “sudo mkinitpcio -P” already updates the images of all installed kernels. There is no need to add “linux414” or “linux511” at the end. It is necessary when using the “-p” modifier (lower case).

I would also update GRUB afterwards with:
sudo update-grub

Oh yeah, I forgot to mention but I already did that as well.
Will edit my post as well as add the output of update-grub.