Black screen after Graphics card upgrade

Ive just updated to a AMD Radeon RX 6800 XT from a Nvidia RTX 2070 Super. And now my system wont boot.

It gets to the point just before the login screen.

I googled the problem and tried a couple of suggestions neither of them worked.

I tried ctl alt F2 then

sudo mhwd -r pci video-linux

sudo mhwd -i pci video-linux

I also tried

sudo mhwd -r pci video-nvidia

sudo mhwd -a pci free 0300

Ive also tried a bunch of other things like re-installing the kernel. Update-grub sudo mkinitcpio -P

Nothing is working still only boots to black screen

post output/picture of:
mhwd-kernel -li && mhwd -l -li
find /etc/X11/ -name "*.conf"
ls /etc/modprobe.d

This is a photo of the output. Sorry for bad quality.

remove the modesetting + the xorg.conf:
sudo mhwd -r pci video-modesetting
sudo rm /etc/X11/xorg.conf

1 Like

did that. Still black screen.

remove also the video linux:
sudo mhwd -r pci video-linux
then check again with:
find /etc/X11/ -name "*.conf"
if the xorg.conf is removed;
and in:
ls /etc/modprobe.d
if the:
is removed, if not remove it; and install again the drivers:
sudo mhwd -a pci free 0300
and enable early loading:
sudo nano /etc/mkinitcpio.conf
and edit the MODULES section to look like this:
save it with ctrl+x, press ‘Y’, then enter, and update it:
sudo mkinitcpio -P


I just rebooted again and its sorted. Thank you so much. I knew it was rescue able as I could get to a TTY but had no idea where to start. Thank you again.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.