Black screen after following the [HowTo] PRIME whit NVidia proprietary drivers

Hi, I followed the guide to use PRIME whit Nvidia proprietary drivers instead of Bumblebee and after the reboot i only get the marvelous black screen. A took some screenshots whit my phone (I know it’s not the best and if necessary i can write all the logs).



Thanks in advance for any help

did you follow a video tutorial or @jonathon 's tutorial? the video for no good reason tells you to install both gdm and lightdm. if you followed the tutorial you have listed in the title you may want to read through it very carefully and make sure you did every step including each drop down, removing/creating correct config’s .
if that doesnt work, you’ll probably want to use a livecd/usb and chroot in so you can give the needed requested info to whoever is capable of helping you. i have my optimus laptop set up the same exact way as that tutorial and it works great but im not experienced and dont want to give you the wrong info

You can post text output from TTY .Follow the tutorial

Post

cat /etc/modprobe.d/*.conf
cat /etc/X11/xorg.conf.d/*.conf
systemctl status lightdm

also your lightdm script, verify it’s enabled in lightdm conf and is executable.

I followed the @jonathon [HowTo] in this forum. No video tutorial. And i review all the config’s like 4 times in tty3 and i have all the same as the tutorial. I can reinstall Manjaro but i want to know what happens to learn a little.

How have you imagined you will find and learn?
In order for an answer from another person with no access to your system, you have to help. At least… providing the requested info?

That was the answer to @dgit . I was on the phone and didn’t see your post after send that reply.
Im now on my pc on a live usb trayin to copy what you need.

1 Like

Not from live usb but from your actual installed system using a different TTY.

[manjaro /]# cat /etc/modprobe.d/*.conf
options nvidia_drm modeset=1
blacklist r8169
[manjaro /]# cat /etc/X11/xorg.conf.d/*.conf
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "latam"
        Option "XkbModel" "pc105"
EndSection
Section "InputClass"
	Identifier "Touchpad Options"
	MatchIsTouchpad "on"
	Option "Tapping" "on"
EndSection
Section "Module"
	Load "modesetting"
EndSection

Section "Device"
	Identifier "nvidia"
	Driver "nvidia"
	BusID "PCI:1:0:0"
	Option "AllowEmptyInitialConfiguration"
EndSection

… looking for more usefull info to put here i see mayby what i have wrong. Let me reboot and see.

aaaaaaaaaaaaaaaaaaaaahhhh !!! I’M BACK BABY !!!

all seems to be fine now, Nvidia working good and better than whit Bumblebee.

what was the mistake? (my mistake off course)

when i put

display-setup-script = /usr/local/bin/optimus.sh

i didn’t see that i had to do that in 2 diferent lines in lightdm.conf

Thanks to all for the help!

1 Like

Issue was due to not reading the instructions closely enough. Unlisting to prevent it being indexed and becoming a potential search reference.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.