Black screen after changing refresh rate


Yesterday I was running low on battery so I decided to change the refresh rate from 120hz to 60hz (using the kde system settings) (I’ve done that many times without any issue). It went to a black screen and now I when I log in graphically it only shows a black screen

I read this post about refresh rate, black screen with nvidia drivers, but I wasn’t using nvidia graphics.

  • My laptop is an asus flow x13. It is running only amd graphics. I tried changing to nvidia graphics with optimus-manager but it also shows the black screen.
  • I am running KDE
  • I don’t have any other DE installed. Also, I can’t connect to my wifi from tty with iw because it is WPA2 to update anything (this laptop doesn’t have ethernet…). I know I din’t do the last stable branch update, and I was hoping updating would solve something.

I read the /var/log/Xorg.0.log but I don’t read anything that I would understand as a cause (but my knowledge is very reduced).

What can I do?

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
1 Like

Here is the output:

  Kernel: 5.15.28-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=0eb5b762-52aa-428b-829d-e29fae0cdae4 rw quiet
    udev.log_priority=3 acpi_backlight=vendor
  Console: tty 3 DM: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: ROG Flow X13 GV301QH_GV301QH v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: GV301QH v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: GV301QH.407 date: 05/31/2021
  ID-1: BAT0 charge: 36.4 Wh (60.1%) condition: 60.6/62.0 Wh (97.8%)
    volts: 15.9 min: 15.9 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: not charging
  Device-1: hid-0018:04F3:2C82.0005-battery model: ELAN9008:00 04F3:2C82
    serial: N/A charge: N/A status: N/A
  RAM: total: 15.1 GiB used: 1.09 GiB (7.2%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 7 5800HS with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1444 high: 2161 min/max: 1200/3200 boost: disabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 2161 2: 1397
    3: 1397 4: 1397 5: 1397 6: 1397 7: 1396 8: 1397 9: 1397 10: 1397 11: 1396
    12: 1397 13: 1397 14: 1396 15: 1397 16: 1397 bogomips: 102243
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists erms extapic
    extd_apicid f16c flushbyasid fma fpu fsgsbase fsrm fxsr fxsr_opt ht
    hw_pstate ibpb ibrs ibs invpcid irperf lahf_lm lbrv lm mba mca mce
    misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl npt
    nrip_save nx ospke osvw overflow_recov pae pat pausefilter pclmulqdq
    pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pku pni popcnt
    pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sha_ni
    skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor
    svm svm_lock syscall tce topoext tsc tsc_scale umip v_spec_ctrl
    v_vmsave_vmload vaes vgif vmcb_clean vme vmmcall vpclmulqdq wbnoinvd wdt
    xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK
    driver: nvidia v: 510.54 alternate: nouveau,nvidia_drm pcie: gen: 1
    speed: 2.5 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1f9d class-ID: 0302
  Device-2: AMD Cezanne vendor: ASUSTeK driver: amdgpu v: kernel pcie:
    gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 04:00.0 chip-ID: 1002:1638
    class-ID: 0300
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 3-4:3 chip-ID: 13d3:56dd class-ID: 0e02 serial: <filter>
  Display: server: v: driver: X: loaded: modesetting
    gpu: amdgpu tty: 240x75
  Monitor-1: eDP-1 model: Sharp LQ134N1JW52 built: 2020 res: 1920x1200
    dpi: 169 gamma: 1.2 size: 288x180mm (11.34x7.09") diag: 340mm (13.4")
    ratio: 16:10 modes: max: 1920x1200 min: 640x480
  Message: GL data unavailable in console. Try -G --display
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 04:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
    driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x pcie:
    gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.28-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: yes
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp2s0 state: down mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: No WAN IP found. Connected to web? SSL issues? Try enabling dig
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:3
    chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Device-1: luks-a8804b83-f3d4-47c1-ab1a-a7882ae0bb65 maj-min: 254:0
    type: LUKS dm: dm-0 size: 338.87 GiB
  p-1: nvme0n1p6 maj-min: 259:6 size: 338.87 GiB
  Message: No RAID data found.
  Local Storage: total: 506.66 GiB used: 101.85 GiB (20.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN530 SDBPTPZ-512G-1002 size: 476.94 GiB block-size:
    physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
    serial: <filter> rev: 21106000 temp: 34.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Generic
    model: MassStorageClass size: 29.72 GiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: 1536 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No optical or floppy data found.
  ID-1: / raw-size: 338.87 GiB size: 332.48 GiB (98.12%)
    used: 86.52 GiB (26.0%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-a8804b83-f3d4-47c1-ab1a-a7882ae0bb65 label: N/A
    uuid: 0eb5b762-52aa-428b-829d-e29fae0cdae4
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 42.1 MiB (16.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: SYSTEM uuid: F06E-B916
  ID-3: /mnt raw-size: 29.72 GiB size: 29.71 GiB (99.98%)
    used: 15.28 GiB (51.4%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 2FC0-131A
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 117.67 GiB fs: bitlocker
    label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 650 MiB fs: ntfs label: RECOVERY
    uuid: 0A341CBA341CAB29
  ID-4: /dev/nvme0n1p5 maj-min: 259:5 size: 19.5 GiB fs: ntfs label: RESTORE
    uuid: B096E2C196E28766
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: ASUSTek N-KEY Device type: Keyboard
    driver: asus,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 0b05:19b6 class-ID: 0301
  Device-2: 1-4:3 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0029
    class-ID: e001
  Hub-2: 2-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-2:2 info: Genesys Logic SD Card Reader and Writer
    type: Mass Storage driver: usb-storage interfaces: 1 rev: 3.1 speed: 5 Gb/s
    power: 896mA chip-ID: 05e3:0749 class-ID: 0806 serial: <filter>
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-3:2 info: Elan Micro ELAN:Fingerprint type: <vendor specific>
    driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 04f3:0c6e class-ID: 0000
  Device-2: 3-4:3 info: IMC Networks USB2.0 HD UVC WebCam type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 13d3:56dd class-ID: 0e02 serial: <filter>
  Hub-4: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 52.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 3100
  GPU: device: nvidia screen: :0.0 temp: 51 C device: amdgpu temp: 51.0 C
  Processes: 335 Uptime: 27m wakeups: 4 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: 1456 pacman: 1424 lib: 380
  flatpak: 32 Shell: Bash (login) v: 5.1.16 running-in: tty 3 inxi: 3.3.14

Reading this part

especially the line with DP-1,DP-2,HDMI-A-1 bus-ID made me think that right know, I could connect it to an external HDMI display. So I went to the tv on the living room, connected it, opened system settings and change the laptop display to 120fps, and voilà!

But now I don’t understand why changing it to 60fps makes it go black. This didn’t use to happen!

What should I try to check what error is happening?

EDIT: I tried again selecting 60fps and it goes black indeed. Only, this time I didn’t panic and shut down and it reverted to 120fps. Where is this change supposed to be written on the system?

1 Like

either the file there,
or the one in the directory /.local/share/kscreen/outputs

Both have the refresh rate in them.
I was going to recommend to delete this directory or just the two files
but you had found another way in the meantime.

1 Like


I understand those are where KDE saves the values. And, for what you say, that deleting them would make it default to 120hz.

Now we would need to understand why selecting 60 hz doesn’t work.

From those files, I see the 60hz option is:

"refresh": 60,

whereas in the 120hz option it says

Could it be the lack of “decimals”?

I followed this Arch Wiki article and added a new mode:

  1. Get the modeline for the resolution: cvt 1920 1200 60.

  2. created a new mode: xrandr --newmode "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync

  3. listed my monitors, it was eDP-1

  4. added it xrandr --addmode eDP-1 1920x1200_60.00

  5. selected it xrandr --output eDP-1 --mode 1920x1200_60.00, and bum! black screen again.

So it doesn’t seem that KDE is doing anything wrong… don’t you think? :thinking:

I don’t think so
but I actually do not know.
… I just looked for and found the place where the refresh rate was mentioned and specified …

(I was updating the reply, sorry. Check my new try)