Black screen after booting the installation



Thank you for your answers, but, eugen-b, I searched mhwd-tui on the forum, but I did not found anything that helped me with the installation. I tried some things I saw on some posts, but nothing resolved my problem. Could you provide me more details, maybe I missed something?
And gionno, thank you but I don’t care very much if my computer is still on Windows 8.1, I don’t especially want to upgrade it to 10, I use it only for playing, and I don’t think it could help me to install Manjaro.

EDIT : I tried to boot with the free drivers, but same results. I tried to install Manjaro on a virtual machine, and it worked.


So, you cannot boot the live install medium. I misunderstood your post.

Then I remmber that some people with Nvidia had to disable the card in BIOS, install with free drivers and then they were able to add Nvidia drivers later on the installed system.


No, sorry, there is no option in my uefi to disable my graphic card. I tried to boot with the integrated graphics instead of my graphic card, but it did not worked, the same bug happen.


You could try boot parameters nouveau.modeset=0 nv.modeset=0 nvidia.modeset=0 i915.modeset=1 modprobe.blacklist=nouveaufb modprobe.blacklist=nvidiafb

If the above options don’t work I would then recommend to try a different Manjaro ISO, a newer one maybe.


The options did not work, so I tried with the gnome and xfce isos, version 17.0.2, but same result. I even tried with an old version (15.12), and same result.


In some cases I recommended to use manjaro-architect. But I don’t know if you would like to use a terminal based installer. You would need to add the boot parameter 3 (literally write 3) to boot to command line environment TTY. Then run nmtui if on WiFi, install manjaro-architect and launch it. (Or use the dedicated Manjaro-Architect ISO.) Follow this guide:


Are you using a display port connection from your video card to the monitor by any chance? I have had very similar “black screen” issues when installing just about every linux disto. Linux just does not initialize the display port correctly on the first boot for some reason. I believe in my case selecting the nvidia driver with Manjaro’s install worked, but with other distributions I had to edit the boot parameters and force the video mode.


ControlID, thank you for your answer, but I already tried it when I tried to disable my graphic card. And for the boot on the tty with the architect iso, I tried the parameter 3, but it did not work, ending with the same problem. Maybe it is not the graphic drivers, because the keyboard and the mouse are shut down when the bug happen.

And don’t worry, I can use a terminal based installer, if I have enough explanations.


how did you create you USB Key ?


I was using a DVD to install Manjaro, but I tried with a usb key, the problem is still here. It don’t come from a problem with the files because it works with an another computer.


There is no other solution? I tried with an Arch Linux iso, and the same problem happened. Maybe this could help you?


I just tried with two other distributions, Kubuntu and Linux Mint.
Kubuntu have the same problem, but it prints a log instead of a black screen.
Linux Mint don’t have the problem, but I noticed something.
In the two logs, there is one line. Kubuntu crashes after that line :
acpi PNP0A08:00: Bus 0000:00 not present in PCI namespace
Maybe it is useless, maybe that can help you, I don’t know. Is there a way to print the boot log on Manjaro (If there is one)?


Is this a Clevo laptop by chance?


No, it is an Asus. And it is not a laptop but a desktop computer.


You have Linux Mint on that machine, you could try to boot the ISO from the HDD with Mint’s Grub. Edit the file etc/grub.d/40_custom and append put this code there (with the correct path to the ISO file on the HDD and free or nonfree for the drivers):

menuentry "Manjaro Cinnamon 17.0.2 ISO" {
    set isofile="/ISO/manjaro-gnome-17.0.2-stable-x86_64.iso"
    set archi="x86_64"
    set dri="free"
    search --no-floppy -f --set=root $isofile
    probe -u $root --set=abc
    set idev="/dev/disk/by-uuid/$abc"
    loopback loop $isofile
    probe -l (loop) --set=mlabel
    linux  (loop)/boot/vmlinuz-$archi  img_dev=$idev img_loop=$isofile  misobasedir=manjaro misolabel=MJRO1702 nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 logo.nologo driver=$dri
    initrd  (loop)/boot/intel_ucode.img (loop)/boot/initramfs-$archi.img

Then run sudo update-grub and reboot to try the new Grub menu entry.
But I’m not very optimistic that it would make a difference.


I tried, and the same problem appeared, but with a difference : The screen was not black, but prints the message :
error : file “/boot/intel-ucode.img” unavailable
(I translated the message from French, because my computer’s language is French, so it must not match exactly the English message.)
I hope it will help.


Oh, that might be a syntax error in my code, I will check. Edit, yes it is intel_ucode. I corrected the code above.


I fixed the code and, like you predicted, it did not make a difference. The screen was black and the keyboard and the mouse were shut down.


No other solutions?


It seems that there is no solution… Thank you anyway for having tried to help me!