Black screen after booting SD card containing Manjaro-ARM-i3-pinebook-20.04.1

I bought a used PineBook with some Ubuntu 16.04 on EMMC which boots ok. I would like to switch to Manjaro and dd'ed the above image to a 64 GB SD card. I turned the PineBook on (with SD card inserted), it recognized the SD card and briefly showed that it will boot from SD card. Then only a black screen, I gave up after 15 minutes. What should I try next? (This is my first try of Manjaro ARM, so I apologize for asking stupid things :slight_smile: )

If you are using DD to flash the SD card, did you remember to uncompress the .img.xz before hand?

Yes. After dd, I used fdisk -l and this showed 2 partitions on the SD card.

2 things I can think of.

  1. Make sure it's the correct image you downloaded. There are i3 images for both Pinebook and Pinebook Pro.
  2. Try downloading the latest (20.04.2) and verify that the download completed by comparing the checksums.

Can't remember if the Ubuntu image supports booting from SD card. You will have to check that.

Yes, I double checked that it is for the Pinebook.

Is there one for the Pinebook? lists only 20.04.1.

This is a very old image. So, it could be missing this feature. If so, what OS image should I install to EMMC (?) first that supports booting from SD card? Or some other approach?

Hm. Oberon might have only updated the Pinebook Pro image then. :slight_smile:

You can install Manjaro directly to the eMMC, if you have an eMMC adapter. If you don't you have to get the current OS to be able to boot from SD.
Maybe it can be updated?

I managed to install (on SD card) several old images: Manjaro 19.02 lxqt (via Pine64-Installer) and Armbian 20.02.1 (via dd). Is this an indication that Manjaro-ARM-... should work too?

I tried older versions from i3-20.04, i3-20.03, xfce-19.10: all boots are stuck in a black screen after some seconds.

I am using these SD cards: 8 GB Sandisk Class 4, and 64 GB Transcend Class 10. Are these suspicious? Are there rock solid SD card recommendations? I am asking because when turning on the Pinebook one of the first output lines is sometimes:

Loading Environment from FAT... in serial

and sometimes (without changing anything in the setup):

Loading Environment from FAT... *** Warning - bad CRC using default environment

Do Manjaro images differ for the 11 inch and the 14 inch version of the Pinebook? (Mine is a 14 inch.)

I found out that despite the black screen I can ssh into the Pinebook as root over Ethernet (tested with Manjaro kde-plasma 19.10). This will trigger the installation dialog and succeeds. But after reboot, there is only the black screen again, only ssh from outside is possible.

I am having this same issue trying to boot from a previously working Manjaro install.

I have the OG Pinebook (14"with 1366x768 IPS)... They were later shipped with 1920x1080 screens (of note as of days ago the new OG pinebook will be black with 1366x768 screens again)

It is my suspicion that this build was made for the 1080p screen.

I'm not sure 100% how to fix this myself but would you be able to tell me what resolution your screen is to confirm?

They are. They where tested by community members with 720p Pinebooks in old releases where they worked, so I would assume that it would still work.
But we will have to see, when we get a chance to try the new 720p ones. :slight_smile:

I managed to solve the issue for me by first installing the 19.10 KDE Plasma emmc build, then installing 20.03 i3 build over that.

My 14 inch Pinebook also has a 1366x768 display.

Has anybody an idea why the solution mentioned by @cannafodder works? Should I try it too or better try some other way (in order to collect some more data about the problem)?

I had the same problem installing i3-20.06 on my Pinebook 11.6" but after reading here I was able to boot the image by doing the following:

1.) write the i3-20.06 image to a sdcard
2.) mount the 1st partition (BOOT_MNJRO) of the freshly created sdcard . Note: it's the FAT32 (vfat) partition.
3.) with the FAT32 partition mounted, open the file extlinux.conf in the extlinux/ directory on the FAT32 partition you've just mounted.
4.) in the file extlinux.conf in the APPEND line change the screen resolution from 1920x1080@60 to 1366x768@60 for both, video=eDP-1: and video=HDMI-A-1:

So the line should look like this:
APPEND initrd=/initramfs-linux.img console=tty1 console=ttyS0,115200 root=LABEL=ROOT_MNJRO rw rootwait video=eDP-1:1366x768@60 video=HDMI-A-1:1366x768@60 bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash

5.) save your changes and exit the editor
6.) unmount FAT32 partition
7.) insert sdcard into pinebook 11.6 inch and boot

I did the changes on the sdcard on my primary linux workstation but you can also write, mount and modify the sdcard using your current system on the pinebook itself

My suggestion would be to set the resolution for the pinebook (not the pinebook pro) to 1366@768 during installation for future releases, so that both, the very first editions as well as the 1080p edition of the "classic" pinebook can boot from the same image.


@lodger Thanks for your solution which works perfectly for my old Pinebook 14'' with 1366x768 resolution.
@Strit I think his suggestion (last paragraph) is a good one!

I don't think that the 1080p pinebook can actually use any other resolution than the 1920x1080.
But when I get my hands on a 720p pinebook I will test what we can do. :slight_smile:

Maybe I can chip in here a bit as well. I own a 14inch Pinebook (1366x768 res). I have tested the last two releases (20.06 i3 and 20.04.1 i3) and unfortunately both show blank screen.
I also tried using Manjaro installer (with both i3 and minimal) but had no success.
I tested also with 20.03 i3 and worked perfectly. After fixing the broken repositories I managed updating it all the way to 20.06.

I however have NOT tested 20.04 i3. So I'm guessing either the bug started in 20.04 or 20.04.1.

If any patches applied, I am willing to test it.


This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by