Black glitched screen with cursor (kde) (manjaro 20.1.1)

Backstory :-

Earlier I was using manjaro “lysa”

One day,I got a glitched kde interface after logging in, my pc was lagging and hard drive was spinning at full speed.

(Idk what caused that)

So I decided to reinstall manjaro
I formatted the manjaro partition and deleted grub

Main Story :-

Then I downloaded latest manjaro 21.1.1 minimal
Then I verified the checksum
And then I flashed it to a usb using rufus

One thing I noticed that this time Rufus detected it as a DD image only
(in earlier versions of manjaro it used to detect it as a iso hybrid image)

When I booted from it, grub was normal,booting was also normal (everything was green OK)

But then I got a black screen and a cusor

When I moved the cursor fastly then a glitching taskbar would appear

Start menu is not working but the pinned icons were working (ie: dolphin and firefox)

But only the outline of app window was visible
The app itself is not visible

Please help me now :pray:

My PC Specs :-

  • Intel Pentium G3450 @3.4ghz
    (dual core)(4th gen)
  • 6GB DDR3 Ram
  • 456GB HDD
  • No dedicated GPU
  • Monitor Resolution = 1366×768

Solutions I Have Tried :-

  • Using Free and Non-free drivers
  • Verifying checksum of ISO file
  • using several different tools to make bootable USB
  • using a different usb drive
  • enabling and disabling CSM

BTW when I ran the image in virtualbox it ran fine.

Thanks in advance :innocent:
(Tell me if you need any photo/video of black screen)

Welcome to the forum! :slight_smile:

Unfortunately, it would appear that the 5.8 kernel is too new for your system. I would recommend that you install the 5.4 LTS kernel instead.

No
That’s not my problem
That was just the part of story on why I updated to Manjaro 21.1 from manlaro lysa

Please read the complete post

My problem is with manjaro 21.1 bootable usb

And what kernel do you think Manjaro 20.1.1 uses?

Oh! Maybe that’s the problem

But I wonder why it booted successfully in virtualbox with just 1/3rd of resources allocated to it ?

So how do I install old kernel version hen I can’t even reach the terminal ?
Or will I have to stay in lysa ?

Boot up from the Lysia USB stick in live mode. Once you’re booted up, open up a terminal window and issue… :arrow_down:

su -

Then, issue the following commands…

manjaro-chroot -a
mhwd-kernel -i linux54
update-grub
exit

The above will chroot into your installed system and install the 5.4 LTS kernel into it, along with all the drivers it needs.

After this, it should be safe to reboot ─ make sure you remove the USB stick. Then, at the GRUB menu, choose “Advanced options for Manjaro Linux” and select the 5.4 kernel. GRUB will remember that choice for the next time you boot up again.

Use the Manjaro 20.1.1 iso with 5.4 lts kernel…it is available for download on osdn manjaro website

  • I don’t have manjaro installed
  • Neither do I have lysa installer and I didn’t wanted to download again
  • But still thanks for your time

Edit : I found a solution.

  • Firstly I ran mikah in virtualbox
  • Then i installed 5.4 kernel from settings
  • then copied the kernel files to my real pc
  • Then I edited the ISO file of mikah and replaced the kernel with old version