Black flickering (Plasma + Nvidia card & drivers) SOLVED (kind of)

Hi!
My system is "sick". It suffers from "black flickering".
I have investigated a lot and find out what triggers this problem ...
It happens if you have a Nvidia card, KDE Plasma and Nvidia drivers.
When there's a change in the compositing the result is this ...
https://www.youtube.com/watch?v=jiUl26o0hcQ
I have tried every solution I've read, for example ...

Compositor settings
Allow applications to block compositing=false
This doesn't fix it.

Change Window decorations
Some people say you shouldn't use Oxygen for Window Decorations.
I have Oxygen selected. I've tried selecting others and ... this doesn't fix it.

Changing files ~/.config/plasmashellrc and ~/.config/kwinrc adding the lines

[QtQuickRendererSettings]
GraphicsResetNotifications=true

This doesn't fix it.

Using XRender
Rendering backend = XRender
This solves the flickering but then the computer doesn't use OpenGL so it's not a good solution.
It also adds a vsync problem.

Using free drivers
I can use free drivers instead of video-nvidia-440xx.
This solves the problem but then the performance is really poor.
For example, this way I can't play 4K videos, ... so it's not a good solution at all.

The only good solution I can think of is buying a videocard from AMD.
I could also wait for Nvidia to make better drivers.
I could also wait for better Mesa drivers for Nvidia cards.

Any other ideas?
Thanks in advance!

For the proprietary driver, you could try setting the compositor vsync to full screen repaints.

On a side note:
Video rendering on the nouveau+mesa driver stack relies on special drivers for hardware decoding (libva-mesa-driver and mesa-vdpau).

It also requires the firmware for your card to be loaded into ram (nouveau-fw from the AUR), something the proprietary driver does automatically.

Reference: https://wiki.archlinux.org/index.php/Hardware_video_acceleration#NVIDIA

I had this issue. I posted this yesterday on another thread. The only thing that worked for me was;

Adding Option "TripleBuffer" "True"
Under;
/etc/X11/xorg.conf.d/20-nvidia.conf
In the Nvidia section.

That was using the opengl compositing 3.1 in the System Settings.

Hi there! This solution helped me:


(similar to rodneyck's proposal)

1 Like

I also followed bogdancovaciu's suggestion regarding adding kwin.sh found here;

Not sure if it is really needed, as my suggestion in the previous post actually fixed it, but I did it all the same for good measure.

I have done every single thing I have read from your answers.
Now it seems the problem happens hardly ever.
I don't know what triggers this flickering but I still see it from time to time.
I used to be able to trigger it very easily.

As my Nvidia card is very cheap and I was needing a better one I have finally decided to sell it and buy a better one with an AMD chip. It will arrive in a few days.
I hope that will solve everything.

Thanks A LOT for all your answers!!

My new AMD graphics card has arrived and I have already installed it.
I have uninstalled all the private drivers of the previous nVidia card.
Everything works perfect now.
Greetings!

1 Like

It can also be caused by a desktop theme. I installed Hello on my system, and found this to be the culprit. Everything was fine once I removed it.

Thanks. I didn't know that.
I use:

  • Global Theme Oxygen
  • Plasma Style Air
  • GTK themes Breeze
  • GTKicon theme Oxygen
    Quite common, I guess.

One more thing.
I uninstalled the nVidia drivers, I think.
But when I updated the system today I saw several lines about packages with this name ... mhwd-nvidia.
I selected them to uninstall them but then I saw dependencies about mhwd-amd and mhwd-ati.
I guess I shouldn't uninstalled anything.
Am I right?
Thanks in advance!

Forum kindly sponsored by