Black Desktop after sleep or screensaver

Hi folks,

I am hoping someone can at least point in some sort of direction to investigate and ultimately solve my problem with KDE. The majority of the time, after sleep / hiberate / suspend or even just come from the screensaver running my desktop will go black, but the active windows are visible. I even tried switching workspaces with the mouse scroll wheel, no change…actually no workspace switching period. I have also tried CTRL+ALT F1 through to F7 with no success. What is strange is sometimes even with sleep/screensaver modes disabled I can move between workspaces and this will happen.

I tried turning off sleep, and screensaver, and even switched from open source to proprietary drivers will no luck.

Any thoughts? Reinstall?

[nexxsys@manjaro ~]$ inxi -Fxzc0
System:    Host: manjaro Kernel: 4.9.20-1-MANJARO x86_64 (64 bit gcc: 6.3.1)
           Desktop: KDE Plasma 5.9.4 (Qt 5.8.0) Distro: Manjaro Linux
Machine:   Device: desktop Mobo: ASUSTeK model: M5A97 R2.0 v: Rev 1.xx
           UEFI: American Megatrends v: 2501 date: 04/07/2014
CPU:       Hexa core AMD FX-6300 Six-Core (-MCP-) cache: 12288 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 42152
           clock speeds: max: 3500 MHz 1: 1400 MHz 2: 1400 MHz 3: 1400 MHz 4: 1400 MHz
           5: 1400 MHz 6: 1400 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Pitcairn XT [Radeon HD 7870 GHz Edition]
           bus-ID: 01:00.0
           Display Server: X.Org 1.17.4 driver: fglrx
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: AMD Radeon HD 7800 Series
           GLX Version: 4.5.13399 - CPC 15.201.1151 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Card-2 Advanced Micro Devices [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]
           driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.9.20-1-MANJARO
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8168 v: 8.043.02-NAPI port: d000 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1750.4GB (45.1% used)
           ID-1: /dev/sda model: ST31000528AS size: 1000.2GB
           ID-2: /dev/sdb model: WDC_WD5001AALS size: 500.1GB
           ID-3: /dev/sdc model: Samsung_SSD_840 size: 250.1GB
Partition: ID-1: / size: 212G used: 15G (8%) fs: ext4 dev: /dev/sdc2
           ID-2: swap-1 size: 18.40GB used: 0.00GB (0%) fs: swap dev: /dev/sdc3
Sensors:   System Temperatures: cpu: 4.6C mobo: N/A
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 273 Uptime: 23:53 Memory: 2049.8/15952.3MB
           Init: systemd Gcc sys: 6.3.1 Client: Shell (bash 4.4.121) inxi: 2.3.8
```
Here is a screenshot of what I see.
<img src="/uploads/default/original/2X/d/dde4e8cecb01c53ff215f75ecda523b0dbfeab79.png" width="690" height="388">

Thanks in advance!

Looks like plasmashell has crashed. Press alt+f2 - if it works - type plasmashell press enter.

Not a fix, just a work round.

Hi,
I have had many issue with black screen after locking or sleep (which inducces locking) on Manjaro-XFCE.
I had to use CTRL+ALT+F2 (F2-F6) to open a tty login session and run the 2 commands below to get the unlock screen back
$ sudo loginctl list-sessions
$ sudo loginctl terminate-session <session - e.g. c3>
CTRL+ALT+F7 to return to thje X session
I ended up disabling automatic inactivity based lock all-together in setting/powermanager,

Same issue here, on Xfce.

Specs: Dump your inxi -Fxzc0 here and bookmark it

Having same problem with KDE. Mine just goes black for no reason, while I am still active on the desktop. Started with last system upgrade few days ago. Currently open windows showing on black desktop. Panel also gone.

Thanks everyone, I will try your suggestions to at least get around the problem.

You probably dont want to be using fglrx/catalyst. You can try
Manjaro Settings Manager > Hardware Configuration > and select The open-source Radeon driver.
Soon enough you might be able to run AMDGPU as well. But try that and lets see if it clears some things up.

Thanks, I have switched from open-source to proprietary, with no change.

My other thought is that it is Lock or lightdm related … can you experiment turning off screen-locking ?

It appears to be the case. I disabled screen locking and so far no blackouts today.

Worked like a charm!

Glad this worked for you. Wish it had for me.

Wow, just finished the previous post and mine crashed, and this tip worked perfectly! Thank you very much.

Just an update from what I have found. Switching from OpenGL 2.0 to OpenGl 3.1 for the rendering backend (Displays–>Compositor) seems to have done the trick for me.

This problem is still present. None of the suggestions in the thread work.

Has anyone found a fix for this issue? I am trying to move my daily driver to Manjaro and this is a real blocker.

Forum kindly sponsored by