Bitte um Hilfe nach missglückter Radeon Treiber Installation


#21

Für den bösesten Fall der Fälle mal über ein Backup nachdenken.
Ich nutze da Timeshift aber es gibt auch anderes.


#22

Wenn wieder alles so funktioniert wie früher musst du nichts mehr machen.
Über Backups kann man immer nachdenken. Gerade hier hätte ein Timeshift Snapshot auf der selben Festplatte, wiederhergestellt vom der tty, dir viel Zeit erspart.


#23

mir sind gerade noch 2 sachen aufgefallen:

  1. mein clipboard-manager nimmt keine sachen mehr, die gerade kopiert wurden (ist also immer leer)
  2. unter Manjaro Einstellungen ist jetzt eine Einstellung anders (siehe Anhang, der Haken bei installiert war vorher nicht)

desweiteren ist z.B. der Hintergrund hier noch weiss trotz meines Themes; kann das alles mit dem gdm zu tun haben, was gefehlt hatte >>> muss ich da noch was nachinstallieren ?


#24

Das ist schwierig zu sagen. Schau in /var/log/pacman.log nach was alles zur selben Zeit entfernt wurde wie GDM. Da wird auch der ganze Catalyst Kram sein. Den bitte nicht wieder installieren.

Hast du früher Gnome mit Wayland oder mit Xorg benutzt. Die können sich ein wenig anders verhalten. Beim log-in kannst du die Session/Sitzung auswählen. Normal in neueren Versionen ist Wayland, dass war früher aber mal genau anders herum. Die GDM Neuinstallation könnte das verändert haben.

Die Haken im MSM sind richtig verteilt. Video-linux ist installiert und wird verwendet und video-vesa ist normalerweise immer installiert.


#25

… bei mir war alles anscheind mit xorg:

[2018-12-11 14:22] [ALPM] transaction started
[2018-12-11 14:22] [ALPM] removed xf86-input-elographics (1.4.1-8)
[2018-12-11 14:22] [ALPM] removed xf86-input-evdev (2.10.6-1)
[2018-12-11 14:22] [ALPM] removed xf86-input-keyboard (1.9.0-3)
[2018-12-11 14:22] [ALPM] removed xf86-input-libinput (0.28.1-1)
[2018-12-11 14:22] [ALPM] removed xf86-input-mouse (1.9.3-1)
[2018-12-11 14:22] [ALPM] removed xf86-input-void (1.4.1-4)
[2018-12-11 14:22] [ALPM] removed xorg-server-common (1.20.3-1)
[2018-12-11 14:22] [ALPM] removed xorg-server-xvfb (1.20.3-1)
[2018-12-11 14:22] [ALPM] removed xorg-server-xwayland (1.20.3-1)
[2018-12-11 14:22] [ALPM] removed xorg-server (1.20.3-1)
[2018-12-11 14:22] [ALPM] removed xf86-video-ati (1:18.1.0-1)
[2018-12-11 14:22] [ALPM] transaction completed

#26

Das kann es eigentlich nicht sein, denn dort wurde kein GDM entfernt. Das sieht eher nach dem Schritt aus wo du aus versehen video-linux mit mhwd entfernt hast. GDM muss noch früher deinstalliert worden sein.


#27
[2018-12-11 09:47] [ALPM] running 'update-desktop-database.hook'...
[2018-12-11 14:22] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /etc/pacman.conf --root / -Rdd xf86-input-elographics xf86-input-evdev xf86-input-keyboard xf86-input-libinput xf86-input-mouse xf86-input-void xorg-server-common xorg-server-xvfb xorg-server-xwayland xorg-server xf86-video-ati'
[2018-12-11 14:22] [ALPM] transaction started
[2018-12-11 14:22] [ALPM] removed xf86-input-elographics (1.4.1-8)
[2018-12-11 14:22] [ALPM] removed xf86-input-evdev (2.10.6-1)
[2018-12-11 14:22] [ALPM] removed xf86-input-keyboard (1.9.0-3)
[2018-12-11 14:22] [ALPM] removed xf86-input-libinput (0.28.1-1)
[2018-12-11 14:22] [ALPM] removed xf86-input-mouse (1.9.3-1)
[2018-12-11 14:22] [ALPM] removed xf86-input-void (1.4.1-4)
[2018-12-11 14:22] [ALPM] removed xorg-server-common (1.20.3-1)
[2018-12-11 14:22] [ALPM] removed xorg-server-xvfb (1.20.3-1)
[2018-12-11 14:22] [ALPM] removed xorg-server-xwayland (1.20.3-1)
[2018-12-11 14:22] [ALPM] removed xorg-server (1.20.3-1)
[2018-12-11 14:22] [ALPM] removed xf86-video-ati (1:18.1.0-1)
[2018-12-11 14:22] [ALPM] transaction completed
[2018-12-11 14:22] [ALPM] running 'systemd-update.hook'...
[2018-12-11 14:22] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /etc/pacman.conf --root / --needed -Sy catalyst-input catalyst-video catalyst-server catalyst-utils lib32-catalyst-utils linux419-catalyst'
[2018-12-11 14:22] [PACMAN] synchronizing package lists
[2018-12-11 14:22] [ALPM] transaction started
[2018-12-11 14:22] [ALPM] installed catalyst-input (2016.09-1)
[2018-12-11 14:22] [ALPM] installed xorg-util-macros (1.19.2-1)
[2018-12-11 14:22] [ALPM] installed catalyst-server (1.17.4-5)
[2018-12-11 14:22] [ALPM] installed catalyst-video (2016.09-1)
[2018-12-11 14:22] [ALPM] installed catalyst-utils (1:15.201.1151-12)
[2018-12-11 14:22] [ALPM-SCRIPTLET] e[37;44me[1m---------------- I/O BUG ---------------------------------------e[0m
[2018-12-11 14:22] [ALPM-SCRIPTLET] There's a bug in fglrx found by lano1106 which generates
[2018-12-11 14:22] [ALPM-SCRIPTLET] great amount of unneeded I/O operations
[2018-12-11 14:22] [ALPM-SCRIPTLET] 
[2018-12-11 14:22] [ALPM-SCRIPTLET] To activate workaround enable systemd service:
[2018-12-11 14:22] [ALPM-SCRIPTLET] systemctl enable temp-links-catalyst
[2018-12-11 14:22] [ALPM-SCRIPTLET] systemctl start temp-links-catalyst
[2018-12-11 14:22] [ALPM-SCRIPTLET] 
[2018-12-11 14:22] [ALPM-SCRIPTLET] More infos:
[2018-12-11 14:22] [ALPM-SCRIPTLET] https://bbs.archlinux.org/viewtopic.php?pid=1279977#p1279977
[2018-12-11 14:22] [ALPM-SCRIPTLET] https://bbs.archlinux.org/viewtopic.php?pid=1280193#p1280193
[2018-12-11 14:22] [ALPM-SCRIPTLET] e[37;44me[1m----------------------------------------------------------------e[0m
[2018-12-11 14:22] [ALPM] installed lib32-catalyst-utils (1:15.201.1151-6)
[2018-12-11 14:22] [ALPM] installed linux419-catalyst (1:15.201.1151-6)
[2018-12-11 14:23] [ALPM-SCRIPTLET] In order to use catalyst module, reboot the system.
[2018-12-11 14:23] [ALPM] transaction completed
[2018-12-11 14:23] [ALPM] running '60-linux419.hook'...
[2018-12-11 14:23] [ALPM] running 'systemd-daemon-reload.hook'...
[2018-12-11 14:23] [ALPM] running 'systemd-udev-reload.hook'...
[2018-12-11 14:23] [ALPM] running 'systemd-update.hook'...
[2018-12-11 14:23] [ALPM] running 'update-desktop-database.hook'...
[2018-12-11 14:29] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /etc/pacman.conf --root / -Rs libva-mesa-driver libva-vdpau-driver mesa-vdpau lib32-libva-vdpau-driver lib32-mesa-vdpau'
[2018-12-11 14:29] [ALPM] transaction started
[2018-12-11 14:29] [ALPM] removed lib32-mesa-vdpau (18.2.6-0)
[2018-12-11 14:29] [ALPM] removed lib32-libva-vdpau-driver (0.7.4-6)
[2018-12-11 14:29] [ALPM] removed lib32-libvdpau (1.1.1-3)
[2018-12-11 14:29] [ALPM] removed lib32-libva (2.3.0-1)
[2018-12-11 14:29] [ALPM] removed mesa-vdpau (18.2.6-0)
[2018-12-11 14:29] [ALPM] removed libva-vdpau-driver (0.7.4-3)
[2018-12-11 14:29] [ALPM] removed libva-mesa-driver (18.2.6-0)
[2018-12-11 14:29] [ALPM] transaction completed
[2018-12-11 14:29] [ALPM] running 'systemd-update.hook'...
[2018-12-11 14:38] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /etc/pacman.conf --root / -Rs catalyst-input catalyst-video catalyst-server catalyst-utils lib32-catalyst-utils linux419-catalyst'
[2018-12-11 14:42] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /etc/pacman.conf --root / --needed -Sy xf86-video-ati xf86-video-amdgpu xf86-video-intel xf86-video-nouveau vulkan-intel vulkan-radeon libva-mesa-driver libva-vdpau-driver mesa-vdpau lib32-vulkan-intel lib32-vulkan-radeon lib32-libva-vdpau-driver lib32-mesa-vdpau'
[2018-12-11 14:42] [PACMAN] synchronizing package lists
[2018-12-11 14:56] [PACMAN] Running 'pacman -R catalyst-server'
[2018-12-11 15:02] [PACMAN] Running 'pacman -R catalyst-utils'
[2018-12-11 16:48] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /etc/pacman.conf --root / --needed -Sy xf86-video-ati xf86-video-amdgpu xf86-video-intel xf86-video-nouveau vulkan-intel vulkan-radeon libva-mesa-driver libva-vdpau-driver mesa-vdpau lib32-vulkan-intel lib32-vulkan-radeon lib32-libva-vdpau-driver lib32-mesa-vdpau'
[2018-12-11 16:48] [PACMAN] synchronizing package lists
[2018-12-11 16:57] [PACMAN] Running 'pacman -S video-ati'
[2018-12-11 16:57] [PACMAN] Running 'pacman -S xf86-video-ati'
[2018-12-11 18:31] [PACMAN] Running 'pacman -Syuu'
[2018-12-11 18:31] [PACMAN] synchronizing package lists
[2018-12-11 18:31] [PACMAN] starting full system upgrade
[2018-12-11 18:31] [PACMAN] Running 'pacman -Syu'
[2018-12-11 18:31] [PACMAN] synchronizing package lists
[2018-12-11 18:31] [PACMAN] starting full system upgrade
[2018-12-11 18:34] [PACMAN] Running 'pacman -Rss video-catalyst'
[2018-12-11 18:44] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /etc/pacman.conf --root / -Rs catalyst-input catalyst-video catalyst-server catalyst-utils lib32-catalyst-utils linux419-catalyst'
[2018-12-11 19:23] [PACMAN] Running 'pacman -S xf86-video-vesa'
[2018-12-11 19:23] [PACMAN] Running 'pacman -S xf86-video-vesa'
[2018-12-11 19:23] [PACMAN] Running 'pacman -S xorg-server'

das scheint der ganze Vorgang zu sein, der Rest war heute & vorher war auch nix.
…und da wurde ja doch eine
xf86-video-ati gelöscht. mir kommt es auch vor, als ob jetzt alles ruckliger läuft.


#28

Habe zwar mit diesem Satanszeug nix am Hut aber während Ihr hier rumdoktort habe ich mal wieder mit Inkscape gespielt :smiley:

Terrorizer-sgs Terrorizer-01-sgs


#29

Das pacman.log ist etwas ungewöhnlich.

Zumindest nach diesem Befehl hätte ich ein paar Zeilen erwartet. Ich bin mir nicht sicher ob die Pakete entfernt wurden oder nicht. Zum Beispiel gibt es im Log keinen Hinweis darauf das gdm jemals deinstalliert wurde.

Was ist die Ausgabe von

pacman -Qs catalyst

Wegen dem “Ruckeln”, verwendest du Wayland oder Xorg und was hast du früher verwendest? Du solltest wirklich ausprobieren was passiert wenn du die Session vor dem Anmelden wechselst.


#30

… die Ausgabe ist:

local/mhwd-catalyst 1:15.201.1151-2
    MHWD module-ids for catalyst 15.201.1151
local/mhwd-db 0.6.3-6 (base)
    Manjaro Linux Hardware Detection Database
`

#31

Das ist bei mir genau so. Also kann man davon ausgehen das die Befehle funktioniert haben, nur nicht im Log stehen. Das macht es natürlich ziemlich unmöglich heraus zu finden ob noch zusätzlichen Dinge entfernt wurde.

Ich würde aber erstmal davon ausgehen das alle nötigen Pakte wieder installiert sind.


#32

… vielen dank auf jedenfall noch für deine Geduld, ich forsch dann mal noch ein bisschen !!!


#33

… hab jetzt vor dem Anmelden gewechselt zu “Gnome auf Xorg”

jetzt ist alles so wie es war, es ruckelt nix, sogar die Farben stimmen jetzt >>> was heisst das jetzt für mich ?


#34

Das du vorher auch schon immer Gnome mit xorg verwendet hast. Wayland ist recht modern, hat aber noch Kinderkrankheiten und Funktioniert mit älteren Grafikkarten oft nicht so gut.

GDM sollte sich merken das du als letztes “Gnome auf Xorg” benutzt hast und beim nächsten Login sofort dieses verwenden. Wenn du Wayland ganz deaktivieren willst, kannst du das machen . Editiere dazu /etc/gdm/custom.conf und entferne den Lattenzaun (#) vor

#WaylandEnable=false

Falls du das machst heißt die Session wieder ganz normal Gnome. Das ist aber nicht unbedingt nötig. Früher war es mal genau andersherum, da musst man die Datei verändern wenn man Wayland verwenden wollte.


#35

alles klar, mach ich morgen, nochmals vielen dank >>> dann haben wir es ja endlich geschafft, echt super du hast mich gerettet!!!


closed #36

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.