Bitte um Hilfe nach missglückter Radeon Treiber Installation


#1

… hi,
ich habe versucht den proprietären Treiber für meine Radeon HD 7620G mit: sudo mhwd -a pci nonfree 0300 zu installieren, hat auch alles reibungslos funktioniert; und dann hab ich den free deinstalliert (video-ati); beim booten bleibt er jetzt jedoch mit blinkendem Cursor stehen, dann komme ich aber mit ALT+F2 in die TTY-Konsole, und kann mich dort auch anmelden.
Mit mhwd -li -d --pci sehe ich auch, daß der video-catalyst installiert ist !!!

Wer kann mir helfen, am liebsten würde ich wieder auf den freien Treiber wechseln & es dann so lassen >>> in Zukunft lass ich dann auch die Finger davon … versprochen :wink: ; ansonsten hätte ich halt Pech ???


#2

Das wechseln zum normalen Treiber funktioniert, allerdings sind ein paar mehr Befehle nötig.

Dieser Beitrag sollte dir helfen den free Driver (video-linux) wieder zu installieren.


#3

… danke für die schnelle Antwort;
Aber da kommt direkt nach dem ersten Befehl

sudo mhwd -r pci $(mhwd -li | grep "video-" | awk '{print $1}')

der Fehler:

Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: gdm: das Entfernen von catalyst-server verletzt Abhängigkeit von 'xorg-server'
:: gdm: das Entfernen von catalyst-server verletzt Abhängigkeit von 'xorg-server-xwayland'
Error: pacman failed!
Error: script failed!

#4

Das große Problem mit dem catalyst ist, dass dieser einen sehr alten xorg-server benötigt.

Versuche mit dem zweiten Befehl den catalyst zu entfernen (besonders den catalyst-server) und dann mit dem 3. Befehl den modernden xorg-server zu installieren. Der zweite Befehl entfernt die Pakete ohne auf Abhänigkeiten zu achten.


#5

… das hat jetzt alles funktioniert, beim booten sehe ich aber, daß er die Kernel Modules nicht laden kann und lande direkt in der Konsole >>> ich glaub bald haben wir es !!!


#6

Du musst mit mhwd noch den alten entfernen und dann den freien Treiber installieren. Falls das entfernen nicht klappt muss du es vielleicht von Hand machen. Einfach ausprobieren.


#7

… und wie ???


#8

Welche config ist installiert

mhwd -li

Wenn eine installiert ist, entfernen

sudo mhwd -r pci NAME

Tausche NAME mit dem Namen der installierten config aus. Es könnte sein das es wieder zu Fehlern kommt. Fall mhwd wieder einen Fehler ausgibt, versuche trotzdem den freien Treiber zu installieren.

Du kannst auch überprüfen ob noch Teile vom catalyst über sind.

find /etc/mod* /etc/X11 -type f -execdir grep -i "fglrx" '{}' \; -print

Dann den freien Treiber installieren

sudo mhwd -a pci free 0300

#9

ich hab da ne video-linux, die hab ich entfernt,
dann hab ich da noch ne /etc/X11/xorg.conf.fglrx-0 >>> muss die weg ???


#10

… ich könnte wetten, das ich immer eine video-linux & eine video-ati vor dem Debakel hatte


#11

Kannst du löschen, aber sollte keinen Unterschied machen.

Ist die mhwd Konfiguration für den freien Treiber. Die willst du normalerweise haben. Wenn du

sudo mhwd -a pci free 0300

ausführst bekommst du wieder diese Konfiguration. Starte dein System neu, falls du wieder auf den tty landest. Melde dich an und versuche startx auszuführen.

Falls du beim Starten Fehler siehst, verwende

sudo systemctl --failed

Verwende dann

sudo journalctl -b -u NAME.service

Tausche NAME.service gegen einen nicht funktionierende Service aus um mehr zu erfahren.


edit:
Du musst vielleicht sudo journalctl ... verwenden.


#12

Früher gab es in mhwd für jeden freien Treibe eine eigene Konfiguartion. Zum Beispiel video-ati oder video-nouveau . Diese freien wurden in neueren Version zu video-linux .


#13

video-linux is jetzt installiert, ich lande wieder in der Konsole;
mit startx kommen Fehler, bei dem systemctl-Befehl aber keine angezeigt !!!

… nach startx kommt:
xauth: file /home/terrorizer/.Xauthority does not exist


#14

Die Konfiguration ist dann ok.

Bedeutet aber auch du hast einen Xorg-server installiert. Das ist ein wichtig. Welche DE und welchen DM verwendest du. Was ist die journalctl Ausgabe vom DM? Gibt es weitere Fehler

sudo journalctl -b -p3

oder

sudo journalctl -b -p4 

#15

mit ```
sudo journalctl -b -p3

kommen 
ACPI Bios error: could not resolve \SB.PCI0.VGA.LCD._BCM.AFN7
ACPI ERROR: evaluating _BCM failed (20180810/video-364)

#16

kann ich mich gegen abend wieder melden >>> muss leider mit meinem sohn zur ergo ???

was ist DM & DE ?


#17

Klar.

DM (DisplayManager): lightdm, gdm, sddm
DE (DisplayEnvironment) : XFCE, Gnome, KDE, …


#18

ACHSO: gdm & Gnome >>> hoffentlich bis später !!!


#19

Überprüfe ob gdm noch installiert ist.

sudo pacman -Qs gdm

Fall gdm nicht mehr installiert ist, installiere gdm. Schaue auch im /var/log/pacman.log nach welche Gnome Pakete gegebenenfalls noch deinstalliert wurden.

Was sagt systemd über gdm

sudo systemctl status gdm

Fall gdm nicht mehr vorhanden war, stelle sicher das du es dem Autostart hinzufügst.

systemctl enable gdm 

Dann starte dein System neu.


#20

… du bist der grösste !!!
…läuft wieder, ich lediglich no mit

sudo pacman -S gdm gdm neu installiert & mit
sudo systemctl enable gdm den Autostart hinzugefügt und siehe da >>> bin wieder drin !!! Danke nochmals.

muss ich jetzt noch was beachten oder bearbeiten ???