BIOS not accessible at all

I am running an Acer Swift 3 laptop - model SF314-54 (x86_64) - dual boot [ Win10 / Manjaro Linux ]. Grub failed some weeks ago, and it always boots without issue into Linux.

I have lost all sound, and cannot access BIOS via F2 at boot (this should work). I need to enlarge my root partition but cannot get to BIOS so I can force boot from an install disk, then run gparted.

Research I have done suggests that this is a firmware update problem, but I am far from competent in diagnosing such matters.

One suggested solution I found was to remove the CMOS battery, wait 3 minutes, then reinsert it. This, it was said, would force a reinstall of the factory BIOS, and I could go forward from there.

Suggestions, please?

Hi @tomc :wink:

You should be able to access the UEFI with grub. When booting type fast ESC and choose “Reboot to EFI Firmware” in the grub boot menu or something like that.

That’s a very interesting idea. I didn’t even know that was possible. You talk about accessing the UEFI with grub - I did mention that grub never appears. But maybe it’s just not writing to the screen.

I’ll give it a try and report back.

Just to be clear - manjaro doesnt touch your BIOS.

1 Like

Another method of rebooting into the firmware is from terminal

systemctl reboot --firmware

The Acer laptop series uses F12 for the boot override menu albeit some models requires the menu to be enabled from the firmware.

1 Like

Pressing Esc did give me a Manjaro menu, never seen before, that allowed me to select “UEFI firmware setting”. Here’s the event sequence that followed that: blank screen, power down, power up, “Acer” appeared briefly onscreen, then a blank screen that went nowhere. Deadend, it appears.

I will try some of the suggestions below. Thanks anyway!

Perhaps my memory is failing me, but aren’t there firmware updates that happen from time to time, mixed in with the other updates?

The “systemclt…” command you suggested had no beneficial effect. There was a reboot, but only to the normal Manjaro account signin screen.

I tried booting with f12 pressed, and that produced a screen with maybe 18 lines of output that made no sense to me, and there were no options to select, nor was the keyboard usuable, so I could not copy the screen to show here.

I hope this gives you a bit more information to work with! And thanks for your suggestions.

I had the same problem, and after many hours of googling and banging my head against the wall, I found the problem to be the ACER firmware. After upgrading it worked fine!

I’m not dual booting however, so just want to put information here on how I resolved it, in case someone else finds this thread.

  1. Find the correct Firmware upgrade on the ACER page. Make sure you use the one for your specific model. It is there, but a bit hard to find. I wanted to include a link, but the forum doesn’t let me. I found mine by googling “exact-model-name bios upgrade”.
  2. It comes as an .exe file, so we need Windows to run it. Sigh… If you don’t have any Windows available you can download Hiren’s BootCD.
  3. Boot into Windows and run the .exe file.

After these steps my BIOS magically worked again!