BIOS install won't boot into grub

The issue is that it wouldn’t even boot into grub recovery or OS.

OK, now it made more sense, thanks.
You did pretty well fixing this.
Can you please share your current setup?

sudo parted -l
lsblk -f
cat /etc/fstab
efibootmgr -v

About the installer ISO and why this happened, as it was posted, the ISO should have been booted in UEFI mode from the start. You may have missed this option at UEFI/BIOS boot list. There are usually two options for a USB drive, when both are available, one simple and one with “UEFI: USB drivename”. You may check again with the same USB drive.

1 Like
[jk@jk ~]$ sudo parted -l
Model: ATA ST4000DM000-1F21 (scsi)
Disk /dev/sda: 4001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:  

Number  Start   End     Size    File system  Name  Flags
1      1049kB  4001GB  4001GB  ext4

Model: ATA KINGSTON SV300S3 (scsi)
Disk /dev/sdb: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:  

Number  Start   End    Size   File system  Name  Flags
1      1049kB  560MB  559MB  fat32              msftdata

[jk@jk ~]$ lsblk -f
NAME   FSTYPE LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda                                                                      
└─sda1 ext4         84fece6b-4c94-4c85-91ba-60014fe1f2a9    3.4T     1% /
sdb                                                                      
└─sdb1 vfat   EFI   BBDE-F352                                            
sr0                                                                      
[jk@jk ~]$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=84fece6b-4c94-4c85-91ba-60014fe1f2a9 /              ext4    defaults,noatime 0 1
[jk@jk ~]$ efibootmgr -v
BootCurrent: 0006

Timeout: 10 seconds
BootOrder: 0006,0003,0005,0000,0000
Boot0000* ubuntu        VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0001  CD/DVD Drive  BBS(CDROM,,0x0)..GO..NO........o.A.S.U.S. . . . .B.W.-.1.2.B.1.L.T....................A.
..........................>..Gd-.;.A..MQ..L.6.C.0.D.L.C.7.0.1.7.1.5. . . . . . . . ........BO
Boot0003* Накопитель на жестком диске   BBS(HD,,0x0)..GO..NO........o.K.I.N.G.S.T.O.N. .S.V.3.0.0.S.3.7.A.2.4.0.
G....................A...........................>..Gd-.;.A..MQ..L.0.5.2.0.B.6.2.7.1.4.F.0.6.0.B.1. . . . ......
..BO..NO........o.S.T.4.0.0.0.D.M.0.0.0.-.1.F.2.1.6.8....................A...........................>..Gd-.;.A.
.MQ..L. . . . . . . . . . . . .3.S.0.0.N.G.0.5........BO
Boot0005* CD/DVD Drive  BBS(CDROM,,0x0)..GO..NO........o.A.S.U.S. . . . .B.W.-.1.2.B.1.L.T....................A.
..........................>..Gd-.;.A..MQ..L.6.C.0.D.L.C.7.0.1.7.1.5. . . . . . . . ........BO
Boot0006* UEFI OS       HD(1,GPT,be101300-6f06-4ed4-9af5-48191ed7f084,0x800,0x10a800)/File(\EFI\BOOT\BOOTX64.EFI
)..BO

There is a problem with font (not utf8?), can you repair the output?

At first glance there is no mount for $esp /boot/efi i your fstab. You need it.
More comments after you repair the text… :wink:

1 Like

Some of it is russian. boot003 is HDD. It works all the same without fstab. Can you not read anything, because I don’t know how to fix it.

I suppose because you used --removable with grub-install and did not re-install without the flag, as the linked article explains.
Are both drives internal? Because now your $esp is on the other drive, not on the one with Manjaro installation. If yes, you should remember that for a possible future drive change/resetup.
Of course the proper/best would be to have $esp on the same drive but not obligated.

Note: Have this tutorial in mind for future needs.

1 Like

It’s full of codes/replacements for utf8, you may start another topic to do something about it, since it will bloat this totally different one. It maybe simple or complicated solution, so…

1 Like

[jk@jk ~]$ sudo parted -l
[sudo] password for jk:  
Model: ATA ST4000DM000-1F21 (scsi)
Disk /dev/sda: 4001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:  

Number  Start   End     Size    File system  Name  Flags
1      1049kB  4001GB  4001GB  ext4

Model: ATA KINGSTON SV300S3 (scsi)
Disk /dev/sdb: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:  

Number  Start   End    Size   File system  Name  Flags
1      1049kB  560MB  559MB  fat32              msftdata
2      560MB   240GB  239GB  ext4

[jk@jk ~]$ lsblk -f
NAME   FSTYPE LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda                                                                      
└─sda1 ext4         84fece6b-4c94-4c85-91ba-60014fe1f2a9    3.4T     1% /
sdb                                                                      
├─sdb1 vfat   EFI   BBDE-F352                             531.7M     0% /run/media/jk/EFI
└─sdb2 ext4         0e13adf9-8768-45bd-8763-b176ef33209a  202.2G     2% /home/jk/dev
sr0                                                                      
[jk@jk ~]$ cat /etc/fstab

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a device; this may

be used with UUID= as a more robust way to name devices that works even if

disks are added and removed. See fstab(5).

<file system>             <mount point>  <type>  <options>  <dump>  <pass>

UUID=84fece6b-4c94-4c85-91ba-60014fe1f2a9 /              ext4    defaults,noatime 0 1
0e13adf9-8768-45bd-8763-b176ef33209 /home/jk/dev ext4 defaults,noatime 0 2

@janat08
Have you solved the problem?
You’ve marked the topic as solved.
Your disk is gpt (& no bios_grub partition)
and you do not have /boot/efi in fstab.

It is difficult to see that your problem is solved.
If it is working now, it won’t be …soon or in the future.

2 Likes

If the wiki gets going i’d check it out.

Forum support is equivalent to wiki and obviously more updated! :wink:

1 Like

I see there is already a disk

I think we need exactly what goes in fstab to match the device or mount.

Ahh wait a second, I think that is the usb live manjaro drive.

So yes like we learned many hours ago, no proper Grub installation.

I think the OP is close but needs special guidance with mounting, fstab or installing an esp partition.

No, it is a local drive.

There is an $esp already, just needs to be added in fstab. For now it can boot, because grub was installed with --removable, which installs a grub config part at $esp. But because $esp is not mounted as /boot/efi, any future changes from packages, or grub-update, will not be copied at that $esp grub config, only at /boot/grub/grub.cfg, which may very possibly create problems, serious or not.

1 Like

Ahh OK I see, so he needs to add a mount point for $esp in his /etc/fstab file.
Or we need to re-install grub Without the --removable option maybe?
Yes so this is want they want added too or clarified on the wiki???

The wiki talks about normal cases and to boot in the mode you want to install TLDR.
This OT case is a repair, not a fail after following the wiki.

2 Likes

But they didnt follow it. In the first couple posts here it was already pretty well guessed, then verified, that OP booted into legacy-bios and expected uefi. Didnt work… obviously. I guess due to the confusion then there were multiple attempts to ‘repair’ their legacy-bios install into being uefi. As it was a new install, the answer was just to do it right in the first place, not blame the tools as was initially the response.

2 Likes

I used partition manager to mount it into /boot/efi (sdb1>sda1/boot/efi).

Please post current

cat /etc/fstab
lsblk -f

UUID=84fece6b-4c94-4c85-91ba-60014fe1f2a9       /       ext4    defaults,noatime        0       1
UUID=0e13adf9-8768-45bd-8763-b176ef33209a       /home/jk/dev    ext4    noatime 0       2
/home/jk/dev/swapfile   swap    swap    defaults        0       0
/dev/sdb1       /boot/efi       vfat    defaults        0       0
[jk@jk Desktop]$ lsblk -f
NAME   FSTYPE LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda                                                                      
└─sda1 ext4         84fece6b-4c94-4c85-91ba-60014fe1f2a9    3.2T     5% /
sdb                                                                      
├─sdb1 vfat   EFI   BBDE-F352                             531.7M     0% /boot/efi
└─sdb2 ext4         0e13adf9-8768-45bd-8763-b176ef33209a  172.9G    16% /home/jk/dev
sr0                                                                      
[jk@jk Desktop]$  

Please reinstall.
gpt, in uefi
msdos, in bios-legacy.