Beeping Sounds When Entering Desktop

deepin

#1

Ever since last night’s update (I’m using the deepin DE) my laptop would boot into the desktop environment but I would hear a couple of beeps that would range from 1-3 are random each time. I noticed the power indicator is missing from the system tray and when I plug in the charger, it would show up again. What could be the issue? My laptop is a Lenovo Ideapad and is only 6 months old.
EDIT: I now noticed the keyboard layout icon is missing too and I can’t add new layouts anymore.

UPDATE: I decided to re-install the packages but that didn’t help. However, I disabled the option to login automatically and that seems to have fixed the problem although I hope this is actually fixed within the next update.


#2

Boot from a live disk to eliminate hardware failure as a possibility.


#3

I tried it and everything worked as should. I noticed that if I log out/log back in or restart the DE through the system monitor, both the power indicator and layout indicator return back to the tray.


#4

rtfm-sgs from your Motherboard :wink:


#5

It would make sense considering I messed around with the BIOS a while back but I don’t think that’s it considering those beeps would probably be heard while the laptop boots. The beeps I hear occur only once the DE loads up and I tested a live disk and the beeps were not present there. I believe the lack of the power module being loaded causes this.


#6

Sounds in /usr/share/sounds/freedesktop/stereo

Hear if it is inside :slight_smile: power-plug.oga
It is not the welcome melody from Deepin, isnt it? :smiley:


#7

Yeah it’s not the welcome melody they’re hard loud beeps which sound like something’s wrong.


#8

Just give me your address, I’ll come by and look in your manuals and google for you. :smiley: :slight_smile:
Or open the PC and cut the rope from speaker. :rofl:


#9

:grin::grin::grin:


#10

very loud, spill your coffee loud beeps? disable pcspeakr/bios beep

sudo rmmod pcspkr
sudo echo "blacklist pcspkr" > /etc/modprobe.d/nobeep.conf


#11

Thanks!


#12

Like I thought, you wanted the symptom gone but you didn’t want to know the cause.


#13

Yeah the beeping was too bothersome but I’m very certain it’s due to the update to the deepin-session-ui package which caused it to not load the system tray modules properly on startup