Beelink SER4 4800U: Issues with Wifi and other small things

Hello,
New to Manjaro (Linux Mint user)
I just received the Beelink SER4 4800U powered by Manjaro
Do you know what the default admin password is?
Also have you experimented with standby successfully?
At home, waking up doesn’t seem to work, I lose wifi, the PC freezes and I have to reboot!
Thank you in advance for your answers

Hello @Hbal64,

welcome to Manjaro. Also great to see that you’re using it on the SER4 by Beelink. If you talk about the password of the initial user it should be oem. However the installer Calamares should been able to create your own user and administrator with passwords of your choosing.

The version installed on the machine should be KDE Plasma. Based on the device itself also our regular releases should work without any extra adjustments.

It is recommended to update the system to the latest packages to see if those are fixing your issues. Another option would be to get one of our regular ISOs and boot from USB-Stick.

The devices we have on our end of SER4 we tested standby, suspend to RAM and had no issues with Wifi.

Keep us updated on your journey. We are here to help out.

Hello @philm ,
Thanks for your reply…
The password was “beelink” ( Beelink support sent it to me )
The version installed on the machine is KDE Plasma
Unfortunately, I can not obtain resume from suspend to work properly !
It takes more than one minute to get the desktop back after a black screen, the wifi is lost, the computer freezes and I have to reboot…
I used also the regular iso and the system was updated
I will later send a picture of my ACPI BIOS settings if it can help
Thanks again and have a nice Day
Best regards

1 Like

We have multiple kernels available via our tool mhwd-kernel

[phil@ser4 ~]$ mhwd-kernel -l
available kernels:
   * linux419
   * linux510
   * linux515
   * linux518
   * linux519
   * linux54
   * linux60
   * linux515-rt
   * linux518-rt
   * linux519-rt

linux510 and linux519 can be tried too. Another thing would be to test the RAM. Linux is very picky about damaged RAM. If the ISO boots from USB, normally it should be fine as it does it only in RAM, but checking it might help too. You could download this tools and use etcher to burn it on USB Stick to test your RAM.

Hello @philm
My RAM is OK thanks for the tools
I tried 519, 518 and 510 with no success
Could you please check witch kernel you are using on the device you have ?
Here are the BIOS details ( version and ACPI settings )
https://is.gd/4KGI53
https://is.gd/YFvjCr
Thanks again for your help
Best regards, Hervé

The links seem to error out in 403 permission issues. Maybe check that @Hbal64. So the issue on your end is suspend to RAM or to disk? For the later a SWAP-file or SWAP partition might be needed.

Sorry,
The issue on my end is suspend to RAM ( S3 )
By the way, it seems to be better with 510 kernel except for the wifi I cannot connect with the device card
It works if I plug an old USB wifi dongle !
Do you have any information about the driver I have to install for the original wifi card to work ?
Thanks, Hervé


Seems your screenshots get deleted on those services. again 403.

Hello @philm ,

I modified my last message and uploaded the images of the BIOS

After several tries,

510 kernel: I could get the resume from suspend with but no Wifi… the MEDIATEK driver: mt7921e is missing in 510 kernel so I have to use an old USB wifi adapter
If you have a solution to install the driver, I’m interested

515 and newer kernel: Resume from suspend breaks everything and I have to reboot every time

Also, as you told me not to encounter this problem with the device you have tested, I think that the BIOS version may not be the same as mine… Would there be an update to do on this side?

Have a nice day and thanks a lot for your help