Battery consumption asus tuf gaming 705gd

Hello

I have a problem with my Asus laptop about battery consumption because I have only 1h-2h of battery life. Or with windows i’ts 5-6h approximately.

I use powertop and tlp (that I have configured). I tried optimus manager and slimbookbattery with no effects. I tested laptop-mode-tools but I have the same state with tlp.

my computer :

[axeln@axel-tufgamingfx705gd ~]$ inxi -Fazy
System:
  Kernel: 5.4.74-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=8ed3f1c2-e467-4c4f-a011-a963420d738d rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.20.2 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: ASUSTeK product: TUF Gaming FX705GD_FX705GD v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: FX705GD v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: FX705GD.306 date: 05/25/2020 
Battery:
  ID-1: BAT0 charge: 28.5 Wh condition: 60.0/64.1 Wh (93%) volts: 14.9/15.6 
  model: Simplo SDI ICR18650 type: Li-ion serial: <filter> status: Discharging 
  cycles: 41 
CPU:
  Info: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) microcode: D6 
  L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 36812 
  Speed: 900 MHz min/max: 800/2300 MHz Core speeds (MHz): 1: 895 2: 900 3: 899 
  4: 900 5: 899 6: 899 7: 900 8: 900 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK 
  driver: nvidia v: 455.38 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1c8d 
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
  bus ID: 1-11:3 chip ID: 13d3:56a2 serial: <filter> 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 
  driver: modesetting,nvidia unloaded: intel alternate: fbdev,nouveau,nv,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 128 size: 382x215mm (15.0x8.5") 
  diag: 438mm (17.3") 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.2.1 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:a348 
  Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel 
  v: kernel bus ID: 01:00.1 chip ID: 10de:0fb9 
  Sound Server: ALSA v: k5.4.74-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel 
  port: 6000 bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8168 v: 8.048.03-NAPI modules: r8169 port: 3000 
  bus ID: 03:00.0 chip ID: 10ec:8168 
  IF: enp3s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.03 TiB used: 280.46 GiB (26.7%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Kingston model: RBUSNS8154P3128GJ 
  size: 119.24 GiB block size: physical: 512 B logical: 512 B speed: 15.8 Gb/s 
  lanes: 2 serial: <filter> rev: E8FK11.C scheme: GPT 
  ID-2: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 0J scheme: GPT 
Partition:
  ID-1: / raw size: 44.06 GiB size: 43.12 GiB (97.86%) used: 25.01 GiB (58.0%) 
  fs: ext4 dev: /dev/nvme0n1p5 
  ID-2: /home raw size: 455.31 GiB size: 447.16 GiB (98.21%) 
  used: 255.40 GiB (57.1%) fs: ext4 dev: /dev/sda2 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 43.0 C mobo: 27.8 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 264 Uptime: 22m Memory: 7.63 GiB used: 2.78 GiB (36.4%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 
  pacman: 1598 lib: 426 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.08 

with powetop I have that (when i’m on internet cable):

  The battery reports a discharge rate of 20.2 W
  The energy consumed was 297 J
  The estimated remaining time is 1 hours, 45 minutes

  Summary: 1587,3 wakeups/second,  0,0 GPU ops/seconds, 0,0 VFS ops/sec and 33,8% CPU use

  Power est.              Usage       Events/s    Category       Description
    15.46 W      0,0 pkts/s                Device         Network interface: enp3s0 (r8168)      
    5.68 W     21,5 pkts/s                Device         Network interface: wlo1 (iwlwifi)
    496 mW     99,1 ms/s      78,6        Process        [PID 3854] /usr/lib/firefox/firefox -contentproc -childID 7 -isForBrowser -prefsLen 7266 -prefMapSize 234542 -parentBuildID 202
    303 mW     57,9 ms/s     192,8        Process        [PID 3220] /usr/lib/firefox/firefox
    177 mW     35,8 ms/s       8,5        Process        [PID 3018] /opt/Rocket.Chat/rocketchat-desktop --type=renderer --autoplay-policy=no-user-gesture-required --field-trial-handle=
    109 mW     21,8 ms/s      16,2        kWork          intel_atomic_commit_work
   86.5 mW     14,8 ms/s     144,9        Process        [PID 1266] /usr/bin/kwin_x11
   74.7 mW     14,9 ms/s      13,0        Process        [PID 886] /usr/lib/Xorg -nolisten tcp -auth /var/run/sddm/{6bc33573-b50c-41f4-be4c-f95522b6b71e} -background none -noreset -dis
   69.8 mW      5,3 ms/s     472,2        Timer          tick_sched_timer
   54.3 mW     10,5 ms/s      28,4        Process        [PID 3346] /usr/lib/firefox/firefox -contentproc -childID 2 -isForBrowser -prefsLen 6276 -prefMapSize 234542 -parentBuildID 202
   49.2 mW      9,5 ms/s      25,8        Process        [PID 3260] /usr/lib/firefox/firefox
   34.8 mW      6,0 ms/s      57,7        Process        [PID 2989] /opt/Rocket.Chat/rocketchat-desktop --type=gpu-process --field-trial-handle=17921104425496441948,8515400336391853025
   32.3 mW      5,6 ms/s      51,8        Process        [PID 3857] /usr/lib/firefox/firefox -contentproc -childID 7 -isForBrowser -prefsLen 7266 -prefMapSize 234542 -parentBuildID 202
   26.9 mW      5,2 ms/s      14,6        Interrupt      [7] sched(softirq)
   21.7 mW      3,9 ms/s      26,7        Process        [PID 3037] /opt/Rocket.Chat/rocketchat-desktop --type=renderer --autoplay-policy=no-user-gesture-required --field-trial-handle=
   20.0 mW      2,7 ms/s      71,9        Timer          hrtimer_wakeup

I install the open source driver for r8168 with no effect.

I use the last nvidia driver : video-hybrid-intel-nvidia-455-prime and the linux kernel 5.4 lts.

Someone can help me to improve my battery life ?

Edit : today i’m on wifi and I have on powertop :

PowerTOP 2.13     Overview   Idle stats   Frequency stats   Device stats   Tunables   WakeUp                            

The battery reports a discharge rate of 17.4 W
The energy consumed was 0.00 J
The estimated remaining time is 3 hours, 8 minutes

Summary: 470,0 wakeups/second,  0,0 GPU ops/seconds, 0,0 VFS ops/sec and 6,6% CPU use

Power est.              Usage       Events/s    Category       Description
  14.7 W     33,1 pkts/s                Device         Network interface: wlo1 (iwlwifi)
 77.8 mW     19,5 ms/s      49,3        Process        [PID 2837] /usr/lib/firefox/firefox -contentproc -childID 4 -isForBrowser -prefsLen 7155 -prefMapSize 234570 -parentBuildID 202
 39.6 mW      9,9 ms/s      31,9        Process        [PID 2590] /usr/lib/firefox/firefox
 29.1 mW      7,3 ms/s      62,9        Process        [PID 3474] powertop
 16.3 mW      4,1 ms/s      11,6        Process        [PID 1289] /usr/bin/plasmashell
 12.1 mW      3,0 ms/s      0,00        Timer          rtl8168_esd_timer
 10.4 mW      2,6 ms/s       1,9        Process        [PID 895] /usr/lib/Xorg -nolisten tcp -auth /var/run/sddm/{66b1024e-4469-4e76-998d-2b884fa7234d} -background none -noreset -dis
 7.44 mW      1,9 ms/s      58,0        Process        [PID 2426] /opt/Rocket.Chat/rocketchat-desktop
 7.29 mW      1,8 ms/s       4,8        Process        [PID 2716] /usr/lib/firefox/firefox -contentproc -childID 2 -isForBrowser -prefsLen 6276 -prefMapSize 234570 -parentBuildID 202
 5.98 mW      1,5 ms/s      12,6        kWork          handle_update
 5.22 mW      1,3 ms/s       4,8        Process        [PID 2536] /opt/Rocket.Chat/rocketchat-desktop --type=renderer --autoplay-policy=no-user-gesture-required --field-trial-handle=
 5.15 mW      1,3 ms/s      21,3        Process        [PID 2597] /usr/lib/firefox/firefox
 3.67 mW      0,9 ms/s       7,7        Process        [PID 1253] /usr/bin/kwin_x11
 3.24 mW      0,8 ms/s       2,9        Process        [PID 1395] /usr/bin/psensor
 2.89 mW      0,7 ms/s       6,8        Process        [PID 1383] /usr/bin/yakuake -session 101fe1e41e221a000160526638000000013010011_1605308556_249374
 2.60 mW    649,6 µs/s       3,9        Process        [PID 2295] /usr/lib/thunderbird/thunderbird

I moved my message from laptop to network and wifi because I think the problem is with the network card. But I don’t know why.